
Reviewing Data Processing 
Requests (DPRs) 

• Data Processing Requests (DPRs) 
– generated automatically by the PDPS 

– generated automatically from a PR (which specifies 
a PGE) 

• DPR information is used by… 
– Data Processing Subsystem 

– AutoSys production scheduling software 

• The Production Planner can review DPRs 

• M&O personnel cannot edit DPR fields 
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Reviewing DPRs (Cont.) 

• DPR List (Production Request Editor) 
– Each line represents a DPR, i.e., a job that will be 

run when all data and resource needs have been 
satisfied 

– For each DPR the list includes… 
»  DPR identification 

» relevant PGE 

» name of the corresponding PR 

» data start date and time, etc. 

– may be filtered, so that only DPRs with certain 
characteristics are displayed 
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Reviewing DPRs (Cont.) 

•	 Data concerning an individual DPR 
(Production Request Editor) 

– PGE parameters 

– UR File Mappings (PGE File Mappings) 
» input and output files for a particular DPR on the PGE 

File Mappings GUI 

» GUI displays one line of information for each file that 
may be used by or be produced by the PGE 
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Reviewing DPRs (Cont.) : 
UR File Mappings GUI 
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Reviewing DPRs (Cont.) : 
DPR List GUI 
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Reviewing DPRs (Cont.): 
Procedure 

•	 Access the Production Request Editor from 
the UNIX prompt 

•	 Select the Data Processing Request List by 
clicking on the DPR List tab 

•	 To list only the DPRs associated with a 
particular Production Request... 

– click on the option button associated with the 
Production Request field 

– highlight the desired PR in the option menu then 
click on the Filter button 

•	 Select a DPR to be reviewed from the list of 
Data Processing Requests, then click on the 
DPR View tab 
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Reviewing DPRs (Cont.): 
DPR View GUI 
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Reviewing DPRs (Cont.): 
Procedure 

•	 To obtain information concerning the PGE 
parameters, click on the PGE Parameters... 
button 

•	 When finished reviewing the PGE parameters, 
click on the OK button to return to the DPR 
View GUI 

•	 Click on the PGE File Mappings... button to 
display the UR File Mappings GUI 

•	 When finished reviewing the UR File 
Mappings, click on the OK button to return to 
the DPR View GUI 
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Reviewing DPRs (Cont.): 
Procedure 

•	 Review the Data Start Time and Data Stop 
Time 

•	 Review the Request Data and Status area of 
the GUI 

•	 When finished reviewing information 
concerning the DPR, repeat steps as 
necessary to review additional DPRs 
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Reviewing a Plan Timeline 

• Production Plan Timeline 
– graphic, timeline-oriented depiction of a production 

plan 

– displays a set of computers, arranged along the left 
side of the GUI 

– displays some period of time across the top edge of 
the GUI 

– execution of DPRs on a computer over a period of 
time is represented by several DPR bars across the 
GUI for that computer 

» bar represents a time period during which a PGE (as 
described by a DPR) is running 
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Reviewing a Plan Timeline (Cont.): 
Procedure 

• [TBD] 
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Production Planning Scenarios 

•	 Two scenarios from the Operations Scenarios 
for the ECS Project: Release A, 605-CD-001­
003, June 1996: 

– Routine Production Planning Scenario 

– Replanning Production Scenario 
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Production Planning Scenarios 
(Cont.) 

• Routine Production Planning Scenario 
– occurs during a given day of the Release A period 

at the Langley Research Center (LaRC) DAAC under 
the following conditions: 

» DAAC is in stable operations 

» The following components are all operating normally: 
TRMM instruments (including CERES), Sensor Data 
Processing Facility (SDPF), ECS Ingest Subsystem. 

» Pertinent PGEs have been integrated into the ECS 
production processing environment and are 
operating normally 
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Production Planning Scenarios 
(Cont.) 

• Routine Production Planning Scenario (Cont.) 
– scenario is based on the following assumptions: 

» all resource allocation issues have been resolved 
with the Resource Planner 

» Resource Planner has provided the Production 
Planner with the following items: list of resources 
available for use in processing, allocation profile with 
time for the available resources 

» PDPS database is complete in terms of PRs, DPRs 
and data availability predictions, etc. and is ready to 
support the planning activity 

» subscriptions have been entered against all data 
products required for processing 
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Production Planning Scenarios 
(Cont.) 

• Routine Production Planning Scenario (Cont.) 
- steps extracted and adapted from the 

scenario: 
– Production Planner reviews objectives for 

processing for the coming month 

– Production Planner starts the Production Request 
Editor and selects the option to access existing 
PRs 

– Production Planner selects the PR to be reissued 
from the PR List GUI and opens the PR Edit GUI to 
make modifications to the PR 

– Production Planner creates a plan for the coming 
month using the Planning Workbench 

– Production Planner selects the new plan option 
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Production Planning Scenarios 
(Cont.) 

• Routine Production Planning Scenario (Cont.) 
- steps extracted and adapted from the 

scenario: 
– Production Planner enters the time period (date/ 

time) for the plan [TBD] 

– Production Planner reviews the available PRs 
displayed on the Planning Workbench GUI 

– Production Planner is uncertain concerning the 
details of one of the PRs displayed and selects the 
PR to review the details [TBD] 

– Production Planner goes back to the lists of 
scheduled and unscheduled PRs and moves PRs 
between the lists until the scheduled list contains 
the desired PRs 
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Production Planning Scenarios 
(Cont.) 

• Routine Production Planning Scenario (Cont.) 
- steps extracted and adapted from the 

scenario: 
– Having selected the applicable PRs for the new 

Production Plan, the Production Planner activates 
the plan (using the Activate button) 

– Production Planner reviews the Production 
Planning Timeline GUI which was displayed when 
the Production Planner clicked on the Activate 
button 

– Production Planner reviews the new plan 

– Production Planner exits from the Production 
Planning Timeline GUI, saves the current plan, and 
returns to plan creation, selecting a PR, modifying 
its priority level and time period and scheduling it 
in the modified plan 53 
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Production Planning Scenarios 
(Cont.) 

• Routine Production Planning Scenario (Cont.) 
- steps extracted and adapted from the 

scenario: 
– Production Planner reviews the modified plan 

– Production Planner analyzes the results of the 
modified plan and decides that it achieves the 
goals; Production Planner saves the monthly 
Production Plan 

– Production Planner selects a baseline plan 
(monthly) using the Planning Workbench GUI 

– Production Planner starts the creation of a weekly 
Production Plan by opening an existing weekly plan 
using the Planning Workbench GUI 
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Production Planning Scenarios 
(Cont.) 

• Routine Production Planning Scenario (Cont.) 
- steps extracted and adapted from the 

scenario: 
– Production Planner reviews and updates the 

selected PRs as required on the basis of planning 
meetings and comments 

– Production Planner reviews the Production 
Planning Timeline GUI, decides that the plan meets 
the objectives and saves the plan 

– Production Planner selects a baseline plan (weekly) 
using the Planning Workbench GUI 

– Production Planner decides to review and activate 
the production schedule for the next day of 
processing 
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Production Planning Scenarios 
(Cont.) 

• Routine Production Planning Scenario (Cont.) 
- steps extracted and adapted from the 

scenario: 
– Production Planner selects the current weekly plan 

being used for the activation/schedule seeding 
operation 

– Production Planner enters the time range of the 
scheduling period, enters any comments and 
activates the plan 

– Production Planner reviews the resulting schedule 
and accepts the results 
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Production Planning Scenarios 
(Cont.) 

• Routine Production Planning Scenario (Cont.) 
– conditions at the completion of the routine 

production planning scenario: 
» planning database contains new and updated entries 

reflecting the current state of the Production Plan 

» DDS contains the published version of the plan and a 
timeline view [TBD] of the plan 

» e-mail messages will have been sent to all affected 
persons, as determined by the plan insertion or 
update 

» production schedule, as maintained by AutoSys, will 
have been updated and processing will proceed 
according to the schedule 
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Production Planning Scenarios 
(Cont.) 

• Replanning Production Scenario 
– occurs during a given day of the Release A period 

at the Langley Research Center (LaRC) DAAC 

– scenario is based on the following assumptions: 
» plan for the processing interval has been developed 

and activated so that the Processing system contains 
a queue of jobs and has been processing jobs for 
some time 

» because of unexpectedly long run times for some 
processing jobs, the actual processing accomplished 
has fallen behind the planned processing 
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Production Planning Scenarios 
(Cont.) 

•	 Replanning Production Scenario (Cont.) ­
steps extracted and adapted from the 
scenario: 

– In response to the Production Monitor’s notification 
that the planned objectives for the shift are not 
being met, the Production Planner launches the 
Planning Workbench GUI 

– Production Planner selects and opens the current 
weekly plan being used for the activation/schedule 
seeding operation 

– Production Planner reviews the resulting schedule 
and works to adjust priorities until the results are 
acceptable 

– Production Planner activates the new plan 
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Production Planning Scenarios 
(Cont.) 

•	 Replanning Production Scenario (Cont.) ­
steps extracted and adapted from the 
scenario: 

– Data Processing System will initiate PGE jobs 
according to the schedule of jobs transferred from 
the Planning System 
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Production Planning Scenarios 
(Cont.) 

• Replanning Production Scenario (Cont.) 
– conditions at the completion of the replanning 

scenario: 
» planning database contains new and updated entries 

reflecting the current state of the Production Plan 

» Document Data Server contains the published 
version of the plan and a timeline view [TBD] of the 
plan 

» e-mail messages will have been sent to all affected 
persons, as determined by the plan insertion or 
update 

» production schedule, as maintained by AutoSys, will 
have been updated and processing will proceed 
according to the schedule 
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Configuring AutoSys Screens/ 
Displays 

• AutoSys/AutoXpert 
– production scheduling tool 

– supports the operational activities surrounding 
production processing in the PDPS 

– assists with the following activities (among others): 
» job monitoring 

» job scheduling 

» fault notification 

» job restart 

» determining the effects of failure of a DPR 

» determining the cause and actions to be taken due to 
the failure of a DPR 
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Configuring AutoSys Screens/ 
Displays 

PDPS Simple Flow

Production Planning AutoSys Data Server 
Request Editor Workbench Subsystem 

PRE 

SSI&T 

PGE 

PW AS DS 
DPRs 

Subs 

Input/Output Granules


Start/End Date/Time 

Jobs 
Plan/ 
Schedule 

1.

2. 
. 
6. 
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Configuring AutoSys (Cont.) 

• AutoSys/AutoXpert (Cont.) 
– displays DPRs as job boxes 

– recognizes the following three categories of jobs: 
» command jobs 

» box jobs 

» file-watcher jobs 
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Configuring AutoSys (Cont.) 

• Command job 
– “command” can be a shell script, the name of an 

executable program, a file transfer, or any other 
command that causes execution of a UNIX 
command on client machine 

• Box job 
– collection of other jobs 

– provides an organizational structure for a group of 
jobs that should be run within the same time period 

» performs no processing action 
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Configuring AutoSys (Cont.) 

• File-watcher job 
– functions similarly to a command job 

– monitors the creation and size of a particular 
operating system file 

– allows AutoSys to know the status of external files 
that are needed in the processing of command jobs 
or box jobs 
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Configuring AutoSys (Cont.) 

• AutoSys Job Starting Parameters 
– Date and time scheduling parameters are met 

– Starting Conditions specified in the job definition 
evaluate to “true” 

– For jobs in a box, the box must be in the RUNNING 
state 

– The current status of the job is not ON_HOLD or 
ON_ICE 

•	 AutoSys finds all jobs that may be affected by 
any change in the truth of the starting 
parameters and determines whether or not to 
start the jobs 
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Configuring AutoSys (Cont.) 

• AutoSys Jobs (ECS) 
– DPRs generated by the Planning Subsystem 

» in response to the Production Planner’s selection of 
PGEs on a Production Request 

– AutoSys creates jobs from the DPRs 
» when a Production Plan that includes the Production 

Request is activated 
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Configuring AutoSys (Cont.) 

•	 Each DPR represents the execution of a 
single science software PGE 

– DPR may depend on the availability (as input) of 
data produced by another DPR 

• Effects of DPR dependencies 
– dependent DPRs are "held" by AutoSys until their 

data availability subscriptions are fulfilled 

– subscription manager software (in the PLS) informs 
the DPS to release the AutoSys jobs after all data 
subscriptions for a given DPR are fulfilled 

– DPS (as managed by the AutoSys Job Scheduling 
engine) runs the PGEs and associated jobs as the 
resources required for the tasks become available 

– procedure continues until all DPRs scheduled for 
the day have completed 
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Configuring AutoSys (Cont.) 

•	 DAAC Production Monitor uses AutoSys/ 
AutoXpert for... 

– monitoring/managing on-demand thresholds 
processing queues to optimize resource utilization 

– modifying DPR priorities and inputs as required 

– transferring/deleting/suspending/resuming DPRs as 
required (e.g., requests, resource problems, input 
data schedule problems, special events, schedules 
replans, etc.) 

– monitoring and providing processing status upon 
request 

– monitoring/reviewing input and output data 

– implementing production system reconfiguration in 
response to operations anomalies 
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Configuring AutoSys (Cont.) 

• Configuring AutoSys Runtime Options 
– Refresh Interval 

» determines how often the View Region will be 
updated 

– Ping Interval 
» defined by how often the connectivity will be 

evaluated 

– Hang Time 
» length of time jobs will continue to be displayed 

within a machine after they have completed running 

– Inches/Hr 
» specifies how much information is displayed on the 

screen 
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Configuring AutoSys (Cont.): 
Procedure 

• Configuring AutoSys Runtime Options 

•	 Launch AutoSys using UNIX commands to 
display the AutoSys GUI Control Panel 

•	 Click on either the HostScape, TimeScape, or 
JobScape button to display the 
corresponding AutoXpert GUI 

•	 Select Options → Edit Runtime Options from 
the pull-down menu to display the Runtime 
Options dialog box 
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Configuring AutoSys (Cont.): 
AutoSys GUI Control Panel 
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Configuring AutoSys (Cont.): 
AutoXpert HostScape GUI 

File Edit View Option 

8:49 
Monitor 

Xpert Engine 

Freeze Frame 

ACTIVATED 

STARTING 

RUNNING 
SUCCESS 

FAILURE 
TERMINATED 

RESTART 

QUE_WAIT 
ON_ICE 

ON_HOLD 

INACTIVE 

MACHINE UP 
MACHINE DOWN 

Job Console 

Alarm 

Current Job Name 

HostScape 

osprey 0 Alarm 

allocate.ceres12aF 

allocate.ceres1aT 

allocate.ceres2aT 

allocate.ceres4aF 

deallocate.ceres12aF 

Event Processor 1 

chamonix 0 Alarm 

heron 0 Alarm 

hatteras 0 Alarm 

execute.ceres2aT 

execute.ceres4aF 

windjammer 0 Alarm 

execute.ceres12aF 
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Configuring AutoSys (Cont.): 
AutoXpert TimeScape GUI 

TimeScape 

File Edit View Options 

13:55 
Monitor 

Xpert Engine 

Freeze Frame 

ACTIVATED 

STARTING 
RUNNING 
SUCCESS 
FAILURE 

TERMINATED 
RESTART 
QUE_WAIT 

ON_ICE 
ON_HOLD 

INACTIVE 

ACTUAL 

PROJECTED 

Job Console 

Alarm 

Current Job Name 

Job Name 

CERES_daily 
CERES_hourly 

ceres4aF 
allocate.ceres4aF 

stage.ceres4aF 
prepare.ceres4aF 
execute.ceres4aF 
destage.ceres4aF 

deallocate.ceres4aF 
ceres5aF 

allocate.ceres5aF 
stage.ceres5aF 
prepare.ceres5aF 
execute.ceres5aF 
destage.ceres5aF 
deallocate.ceres5aF 

ceres6aT 
allocate.ceres6aT 
stage.ceres6aT 
prepare.ceres6aT 
execute.ceres6aT 
destage.ceres6aT 
deallocate.ceres6aT 

ceres9aTF 
allocate.ceres9aTF 
stage.ceres9aTF 
prepare.ceres9aTF 

execute.ceres9aTF 
destage.ceres9aTF 
deallocate.ceres9aTF 

ceres1aT 
allocate.ceres1aT 
stage.ceres1aT 
prepare.ceres1aT 
execute.ceres1aT 
destage.ceres1aT 
deallocate.ceres1aT 

ceres12aF 
allocate.ceres12aF 
stage.ceres12aF 
prepare.ceres12aF 
execute.ceres12aF 
destage.ceres12aF 
deallocate.ceres12aF 

ceres2aT 
allocate.ceres2aT 
stage.ceres2aT 
prepare.ceres2aT 
execute.ceres2aT 
destage.ceres2aT 
deallocate.ceres2aT 

14:00 
13:54 
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Configuring AutoSys (Cont.): 
AutoXpert JobScape GUI 

JobScape 

File Edit View Options 

14:07 
Monitor ceres_daily 

Xpert Engine 

Freeze Frame 
ceres_hourly ceres1aT ceres12aF 

ACTIVATED

STARTING

RUNNING ceres4aF allocate.ceres12aF


SUCCESS

FAILURE


TERMINATED 
RESTART 

allocate.ceres4aF stage.ceres12aF 

QUE_WAIT 

ON_ICE 
ON_HOLD stage.ceres4aF prepare.ceres12aF 

INACTIVE 

TRUE 
prepare.ceres4aF execute.ceres12aF 

FALSE 

Job Console 
execute.ceres4aF destage.ceres12aF 

Alarm 

Current Job Name 
destage.ceres4aF deallocate.ceres12aF

execute.ceres5aF 

deallocate.ceres4aF 

ceres5aF ceres9aTF 

allocate.ceres5aF 

stage.ceres5aF 

allocate.ceres9aTF 

stage.ceres9aTF 

deallocate.ceres1aT 

allocate.ceres1aT 

stage.ceres1aT 

prepare.ceres1aT 

execute.ceres1aT 

destage.ceres1aT 
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Configuring AutoSys (Cont.): 
Procedure 

•	 If the refresh interval is to be modified, click 
on Refresh Interval (Seconds) and enter a 
value between 1 and 99999 (type or click) 

– default value is 30 seconds 

•	 If the ping interval is to be modified, click on 
Ping Interval (Seconds) and enter a value 
between 1 and 99999 

– default value is 300 seconds 

– if 99999 is entered, no ping commands are issued 

•	 If the hang time is to be modified, click on 
Hang Time (Minutes) and enter a value 
between 1 and 99999 

– default value is 1 minute 
77 

456-TP-003-001 



Configuring AutoSys (Cont.): 
Procedure 

•	 If the number of inches/hour is to be 
modified, click on Inches/Hr (inches) and 
enter a value to decrease or increase the 
current numerical value until the desired 
value is reached 

– default value is 2 inches/hr 

•	 When all desired modifications have been 
entered, click on the Apply button 

• Click on the OK button to close the dialog box 

•	 If another of the AutoXpert GUIs needs to 
have its runtime options configured, repeat 
steps as necessary 
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Configuring AutoSys (Cont.) 

• Configuring Hardware Groups 
– makes it easier to monitor the hardware associated 

with a particular function (e.g., testing, training, or a 
certain type of processing) 

– default group is “All Machines” 

– Production Monitor defines a specific set of 
machines to be monitored as a group 

» must know which machines are to be included in the 
group 

» should devise a useful name for the group 
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Configuring AutoSys (Cont.): 
Procedure 

• Configuring Hardware Groups 

•	 If necessary, log in to the planning server as 
described in Steps 1 through 7 of the 
procedure for Configuring AutoSys Runtime 
Options 

•	 Type cd /usr/ecs/Rel_A/COTS/autotree2 then 
press the Return/Enter key on the keyboard 

•	 Type vi xpert.groups.XXX (where XXX = the 
AUTOSERV instance) then press Return/Enter 
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Configuring AutoSys (Cont.): 
AutoSys Hardware Group File 

groupname: Training


plnn1sun


sprn1sgi


groupname: SSI&T


aitn1sun


aitn2sun
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Configuring AutoSys (Cont.): 
Procedure 

•	 Using vi editor commands create/modify 
hardware groups as necessary 

– first line of each machine group is in the format 
groupname: groupname 

– name of each machine to be included in the group 
is on a separate line 

• Press the Esc key 

• Type ZZ then press Return/Enter 
– New hardware groups are entered and saved in the 

file 
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Configuring AutoSys (Cont.): 
Procedure 

•	 Launch AutoSys by typing autosc & at the 
UNIX shell prompt 

• Click on the HostScape button 

•	 Select View → Select Machine Group from the 
pull-down menu 

•	 Select (highlight) the machine group to be 
applied 

•	 Click on the OK button to close the Machine 
Group Selection dialog box 
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Reviewing Hardware Status, DPR 
Dependency, etc. 

• Reviewing Hardware Status 
– Production Monitor reviews hardware status using 

AutoXpert HostScape GUI 

– Production Monitor can determine the following 
conditions (among others): 

» status of processors 

» condition of the queue 

» whether any processors are overloaded while others 
are idle 

» whether there are any system problems 

84 

456-TP-003-001 



Reviewing Hardware Status etc. 
(Cont.) 

• Reviewing Hardware Status (Cont.) 
– HostScape displays jobs on a machine-by-machine 

basis 
» which AutoSys server/client machines are up and 

active 

» which jobs are running or have recently run on each 
machine 

– HostScape can display hardware status in real-time 
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Reviewing Hardware Status etc. 
(Cont.): Procedure 

• Reviewing Hardware Status: 

• Launch AutoSys 

•	 Click on the HostScape button on the 
AutoSys GUI Control Panel 

•	 Review the Control Region to identify the 
color codes for the status of the machines 

• Review the machine type in the View Region 

•	 Review the machine boxes in the View Region 
to determine the status of individual 
machines 
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Reviewing Hardware Status etc. 
(Cont.): Procedure 

•	 Review the Alarm indicating buttons of 
individual machines in the View Region 

•	 Review the machine connection status in the 
View Region 

•	 To exit from HostScape select File → Exit 
from the pull-down menu then click on the OK 
button 
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Reviewing Hardware Status etc. 
(Cont.) 

• Changing the Hardware Status View 
– View Options provide three methods of viewing 

hardware status: 
» normal 

» global 

» zoom 
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Reviewing Hardware Status etc. 
(Cont.): Procedure 

• Changing Hardware Status Views: 

•	 Select a machine in the View Region by 
clicking on its name, then select 

– first Select View Level 

– then Global View 
» seven rows of machines are displayed 

» no job information is displayed 

•	 Select a specific machine by clicking on its 
name, then select Zoom in Machine 

– zoom view is displayed 

– table listing relevant data is displayed 
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Reviewing Hardware Status etc. 
(Cont.): Procedure 

• Select Dismiss 
– global view is displayed 

•	 Select View → Select View Level then select 
Normal View 

– normal view is displayed 

– three rows of machines are displayed 

– limited job information is displayed 
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Reviewing Hardware Status etc. 
(Cont.) 

• Reviewing DPR Dependencies 
– The Production Monitor reviews DPR dependencies 

using AutoXpert JobScape GUI 
» presents a Pert-like view of job processing from a 

logical (or job dependency) point of view 

» depicts all job types; i.e., command jobs, box jobs, 
and file-watcher jobs 

» depicts the nesting of jobs within boxes and the 
dependencies between jobs. 

» can be used for monitoring job flow in real-time 

» allows the Production Monitor to identify potential 
problems before they become actual problems 

– AutoSys defines job status in the terms listed in the 
table 

»  different states are color-coded 
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Reviewing Hardware Status etc. 
(Cont.) 

• Job States 
– Activated (white) 

– Starting (forest green) 

– Running (green) 

– Success (light blue) 

– Failure (red) 

– Terminated (red) 

– Restart (orange) 

– Que_Wait (yellow) 

– On_Ice (black) 

– On_Hold (black) 

– Inactive (white) 
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Reviewing Hardware Status etc. 
(Cont.) 

• ON_HOLD vs ON_ICE 
– ON_HOLD 

» Lose a Turn. (Can start anytime from stop point.) 

– ON_ICE 
» Go to Jail. Do not pass GO. Do not collect $200. 

(ALL conditions must be reset before starting again.) 
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Reviewing Hardware Status etc. 
(Cont.): Procedure 

• Reviewing DPR Dependencies: 

• Launch AutoSys 

•	 Click on the JobScape button on the AutoSys 
GUI Control Panel. 

•	 Review the Control Region to identify the 
True/False dependency legend 

– True = solid arrow (job dependencies have been 
met) 

– False = dashed arrow (job dependencies have not 
been met) 

•	 Review the Job Display to determine the 
status (color-coded) of DPRs 
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Reviewing Hardware Status etc. 
(Cont.): Procedure 

•	 Review the Job Display to determine the 
types of jobs 

– rectangle = Box Job 

– ellipse = Command Job 

– hexagon = File Watcher Job 

•	 Select a job (for which descendants are to be 
determined) by clicking 

•	 Review the job’s descendants by clicking and 
holding 

•	 Select Show Children from the Descendants 
pop-up menu 

– job’s first-level Command, File-Watcher, and Box 
Jobs appear 
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Reviewing Hardware Status etc. 
(Cont.): Procedure 

•	 Select Show All Descendants from the 
Descendants pop-up menu 

– job’s Command, File-Watcher, and Box Jobs appear 
for all levels 

•	 Select Hide All Descendants from the 
Descendants pop-up menu 

– default view is displayed 

– all descendants are hidden 

•	 To exit from JobScape select File → Exit from 
the pull-down menu then click on the OK 
button 
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Reviewing Hardware Status etc. 
(Cont.) 

• Reviewing the DPR Production Timeline 
– Production Monitor reviews the DPR Production 

Timeline using AutoXpert TimeScape 
» presents a Gantt-like view of a job processing from a 

temporal (time-related) point of view 

» depicts all job types; i.e., Command Jobs, Box Jobs, 
and File Watcher Jobs 

» depicts the nesting of jobs within boxes 

» depicts the duration of time it will take for jobs to 
complete 

» used for monitoring job flow in real-time 
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Reviewing Hardware Status etc. 
(Cont.): Procedure 

• Reviewing the DPR Production Timeline: 

• Launch AutoSys 

•	 Click on the TimeScape button on the 
AutoSys GUI Control Panel 

– current time is displayed in red in the View Region 

•	 Review the Control Region to identify the 
Actual/Projected legend for making 
comparisons in the View Region 

– projected is a rectangular (blue filled) graphic, to 
show average job completion time 

– actual is a striped ribbon, to show how much of the 
job has completed 
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Reviewing Hardware Status etc. 
(Cont.): Procedure 

Good vs Bad


Projected 

Actual 

Looks Good! 

Projected 

Actual 

Trouble! 
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Reviewing Hardware Status etc. 
(Cont.): Procedure 

•	 Review a job’s descendants by clicking and 
holding on the job 

•	 Select Show Children from the Descendants 
pop-up menu 

– job’s first-level Command, File Watcher, and Box 
Jobs appear 

•	 Select Show All Descendants from the 
Descendants pop-up menu 

– job’s Command, File Watcher, and Box Jobs appear 
with all levels 
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Reviewing Hardware Status etc. 
(Cont.): Procedure 

•	 Select Hide All Descendants from the 
Descendants pop-up menu 

– default view is displayed 

– all descendants are removed 

•	 To exit from TimeScape select File → Exit 
from the pull-down menu then click on the OK 
button 
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Reviewing Hardware Status etc. 
(Cont.) 

• Reviewing Alarms 
– Alarms indicate problems with job processing 

» failure of job processing 

» database problem 

» communications problem 

» hardware or software failure 

» some other error in the data processing system 

– Production Monitor reviews alarms using the 
AutoSys Alarm Manager 

» view alarms as they arrive 

» provide a response to an alarm 

» change alarm status 
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Reviewing Hardware Status etc. 
(Cont.) 

• Reviewing Alarms (Cont.) 
– Production Monitor can configure the Alarm 

Manager to display certain types of alarms only 
» type of alarm 

» alarm state 

» time of the alarm 
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Reviewing Hardware Status etc. 
(Cont.): Procedure 

• Reviewing Alarms: 

• Launch AutoSys 

•	 Click on the Ops Console button on the 
AutoSys GUI Control Panel to display the Job 
Activity Console GUI (also known as the Ops 
Console GUI) 

•	 Click on the Alarm button to display the 
Alarm Manager GUI 

• Click on an alarm in the Alarm List 
– relevant alarm information is displayed 

•	 Click the Response edit box and type in a 
response, if desired, then press Tab 
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Reviewing Hardware Status etc. 
(Cont.): Job Activity Console 

AutoSys Job Activity Console 

File View 

Job Name Description Status Command Machine | 

ground_event0 SUCCESS sleep 120 osprey 
ground_event1 SUCCESS sleep 120 heron 
ground_event2 SUCCESS sleep 120 hatteras 
ground_event3 SUCCESS sleep 120 osprey 
ground_event4 SUCCESS sleep 120 windjammer 
ground_event5 SUCCESS sleep 120 osprey 
ground_event6 SUCCESS sleep 120 hatteras 
ground_event7 SUCCESS sleep 120 heron 
job0 SUCCESS sleep 120 osprey 
job1 SUCCESS sleep 120 windjammer 
job2 SUCCESS sleep 120 heron 
job3 SUCCESS sleep 120 windjammer 
job4 SUCCESS sleep 120 osprey 

Currently Selected Job job0 

Description 

Command sleep 120 

Start Time 11/08 08:59:02 Status SUCCESS Machine osprey Priority 

End Time 11/08 09:01:02 Exit Code 0 Queue Name osprey Num. of Tries 

Run Time 00:02:00 Next Start 

Starting Conditions Job Report 

Atomic Condition Current State T/F 

Actions Show Reports 

Start Job On Hold Job Definition Summary 
Alarm 

Kill Job Off Hold Dependent Jobs Event 

Force Start Job Send Event Freeze Frame None Exit 
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Reviewing Hardware Status etc. 
(Cont.): Alarm Manager GUI 

Alarm Manager 

View ptions O

Alarm Type Job Name Time State Comment 

JOBFAILURE execute.ceres4aF 10/23 08:50:05 Open 

Currently Selected Alarm 

JOBFAILURE execute.ceres4aF 10/23 08:50:05 Open 

Response 

Alarm State 

Open 

Acknowledged 

Closed 

User Autosys@osprey 

Freeze Frame Select Job New Alarm 

OK Apply Cancel 
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Reviewing Hardware Status etc. 
(Cont.): Procedure 

•	 Update the Alarm State by clicking on 
whichever of the radio buttons appropriately 
describes the Alarm State 

– Open 

– Acknowledged 

– Closed 

•	 Click on the Apply button to enter the alarm 
response 

•	 Repeat steps as necessary to review and 
update multiple alarms 
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Reviewing Hardware Status etc. 
(Cont.): Procedure 

•	 When no more alarms are to be reviewed, 
click on the OK button 

– Alarm Manager quits (is closed) 

•	 To exit from the Job Activity Console (Ops 
Console) GUI click on the Exit button then on 
the OK button 
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Reviewing Hardware Status etc. 
(Cont.): Procedure 

• Configuring Alarm Selection: 

•	 Select View → Select Alarms from the pull­
down menu to display the Alarm Selection 
GUI 

•	 To select a single type of alarm, click on the 
desired alarm in the Select by Type alarm list; 
to select all types of alarms, click on the All 
Types button 

•	 To select multiple types of alarms: press and 
hold the Control (Ctrl) key on the keyboard 
while clicking the desired alarms in the Select 
by Type alarm list 
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Reviewing Hardware Status etc. 
(Cont.): Alarm Selection GUI 
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Reviewing Hardware Status etc. 
(Cont.): Procedure 

•	 To select all alarm states click on the All 
States button; to select alarms by state click 
on whichever of the Select by State toggle 
buttons properly describe(s) the state(s) to be 
selected: 

– Open 

– Acknowledge 

– Closed 

•	 To select all times click on the All Times 
button; to select alarms by time type the 
starting date in the From Date field 
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Reviewing Hardware Status etc. 
(Cont.): Procedure 

• Type the starting time in the From Time field 

• Type the end date in the To Date field 

• Type the end time in the To Time field 

•	 Click on the Apply button to apply selections 
without dismissing (closing) the Alarm 
Selection GUI 

•	 Click on the OK button to apply alarm 
selections and close the Alarm Selection GUI 

•	 If alarm sound is desired, select 
Options → Sound On on the Alarm Manager 
GUI 
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Reviewing Hardware Status etc. 
(Cont.): Procedure 

•	 If no alarms are to be reviewed, click on the 
OK button 

– Alarm Manager quits (is closed) 
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Reviewing Hardware Status etc. 
(Cont.) 

• Reviewing Job Selection Criteria 

– Production Monitor reviews job activities using the 
AutoSys Job Activity Console 

– AutoSys Job Selection GUI is used for... 
» specifying (filtering) jobs the Production Monitor will 

review 

» setting the criteria for displaying jobs by name, 
status and/or machine 
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Reviewing Hardware Status etc. 
(Cont.): Procedure 

• Reviewing Job Selection Criteria: 

• Launch AutoSys 

•	 Click on the Ops Console button on the 
AutoSys GUI Control Panel to display the Job 
Activity Console GUI 

•	 Choose View → Select Jobs from the pull­
down menu to display the Job Selection GUI 

115 

456-TP-003-001 



Reviewing Hardware Status etc. 
(Cont.): Job Selection GUI 
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Reviewing Hardware Status etc. 
(Cont.): Procedure 

•	 For the Select by Name option select all jobs 
by clicking on the All Jobs button; 
alternatives: 

– to select a particular job by name, type the name of 
the desired job in the Job Name field 

– to select a particular box by name, type the name of 
the desired box in the Box Name field then type in 
the Box Levels field how many levels of nesting you 
want to view for the box job 

•	 To select all job statuses click on the All 
Statuses button; to select jobs by status click 
on whichever of the Select by Status toggle 
buttons properly describe(s) the status(es) to 
be selected 
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Reviewing Hardware Status etc. 
(Cont.): Procedure 

• Select by Status toggle buttons 
– Starting 

– Running 

– Success 

– Failure 

– Terminated 

– Restart 

– Que Wait 

– Activated 

– Inactive 

– On Hold 

– On Ice 
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Reviewing Hardware Status etc. 
(Cont.): Procedure 

•	 To select all machines click on the All 
Machines button; alternatives: 

– to select jobs by the particular machine click on the 
name of the desired machine in the Select by 
Machine list 

– to select multiple machines, click and hold on the 
first machine then drag the cursor to the name of 
the last machine to be selected and release the 
mouse button 

119 

456-TP-003-001 



Reviewing Hardware Status etc. 
(Cont.): Procedure 

•	 Click on the desired order in the Sort Order 
area 

– Start Time 

– End Time 

– Job Name 

– Job Status 

– Machine Name 

– Unsorted 

•	 Click on the Apply button to apply selections 
without dismissing the Job Selection GUI 

•	 Click on the OK button to apply job selections 
and close the Job Selection GUI 

120 

456-TP-003-001 



Reviewing Hardware Status etc. 
(Cont.): Procedure 

•	 When the job activity has been adequately 
reviewed, click on Exit to quit the Job Activity 
Console display 

•	 Click on the OK button to confirm closing of 
the AutoSys Job Activity Console GUI 
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