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Abstract


This is Volume 3 of a series of 10 volumes containing training material for the Pre-Release B 
Testbed of the Earth Observing System Data and Information System (EOSDIS) Core System 
(ECS). This lesson provides a detailed description of the process required for creating, 
modifying, and implementing production requests and production plans and monitoring the 
processing of data processing requests. 

Keywords: training, instructional design, course objective, production request, production plan, 
data processing request, production, planning, processing. 
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Introduction


Identification 
Training Material Volume 3 is part of a series of Technical Papers that will be used to teach 
Maintenance and Operations (M&O) concepts to the M&O staff at the following Distributed 
Active Archive Centers (DAACs): Langley Research Center (LaRC), National Snow and Ice 
Data Center (NSIDC) and EROS Data Center (EDC). 

Scope 
Training Material Volume 3 describes the procedures by which the production team prepares 
production plans and monitors production processing.  This lesson is designed to provide the 
operations staff with sufficient knowledge and information to satisfy all lesson objectives. 

This document reflects the August 23, 1995 Technical Baseline maintained by the contractor 
Configuration Control Board (CCB) in accordance with ECS technical direction #11, dated 
December 6, 1994. 

Purpose 
The purpose of this Technical Paper is to provide a detailed course of instruction that forms the 
basis for understanding production planning and processing. Lesson objectives are developed 
and will be used to guide the flow of instruction for this lesson. The lesson objectives will serve 
as the basis for verifying that all lesson topics are contained within this Student Guide and slide 
presentation material. 

Organization 
This document is organized as follows: 

Introduction:	 The Introduction presents the document identification, scope, 
purpose, and organization. 

Student Guide:	 The Student Guide identifies the core elements of this lesson. All 
Lesson Objectives and associated topics are included. 

Slide Presentation:	 Slide Presentation is reserved for all slides used by the instructor 
during the presentation of this lesson. 
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Production Planning and Processing Overview


Lesson Overview 
This lesson will provide you with the complete process by which the production team prepares 
production plans and monitors production processing. The processes described in the lesson 
apply primarily to production planners and production monitors. The procedures involved in 
production planning and processing include such tasks as preparing production requests, 
preparing production plans and monitoring data processing. 

Lesson Objectives 
Overall Objective - The overall objective of the Production Planning and Processing lesson is 
for Science and Communications Maintenance and Operations (M&O) personnel to develop 
proficiency in the procedures that apply to production planning and production processing 
operations for the Earth Observing System (EOS) Data and Information System (EOSDIS) Core 
System (ECS). 

Condition - The student will be given oral or written information and requirements for 
performing production planning and processing activities, access to the planning and production 
processing systems and a copy of 456-TP-003-001, ECS Training Material Volume 3: 
Production Planning and Processing. 

Standard - The student will perform production planning and processing activities in accordance 
with the prescribed procedures without error. 

Specific Objective 1 - The student will perform the steps involved in creating a new production 
request. 

Condition - The student will be given a statement of the requirements for preparing a new 
production request, access to the planning system (through a workstation or terminal) and a copy 
of 456-TP-003-001, ECS Training Material Volume 3: Production Planning and Processing. 

Standard - The student will perform without error the steps involved in preparing a new 
production request in accordance with the applicable procedure. 

Specific Objective 2 - The student will perform the steps involved in modifying a production 
request. 

Condition - The student will be given a statement of the requirements for modifying a 
production request, access to the planning system (through a workstation or terminal) and a copy 
of 456-TP-003-001, ECS Training Material Volume 3: Production Planning and Processing. 

Standard - The student will perform without error the steps involved in modifying a production 
request in accordance with the applicable procedure. 

Specific Objective 3 - The student will perform the steps involved in creating a new production 
plan. 
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Condition - The student will be given a statement of the requirements for preparing a new 
production plan, access to the planning system (through a workstation or terminal) and a copy of 
456-TP-003-001, ECS Training Material Volume 3: Production Planning and Processing. 

Standard - The student will perform without error the steps involved in preparing a new 
production plan in accordance with the applicable procedure. 

Specific Objective 4 - The student will perform the steps involved in reviewing data processing 
requests. 

Condition - The student will be given a statement of the requirements for reviewing data 
processing requests, access to the planning system (through a workstation or terminal) and a 
copy of 456-TP-003-001, ECS Training Material Volume 3: Production Planning and 
Processing. 

Standard - The student will perform without error the steps involved in reviewing data 
processing requests in accordance with the applicable procedure. 

Specific Objective 5 - The student will perform the steps involved in reviewing a production 
plan timeline. 

Condition - The student will be given a statement of the requirements for reviewing a 
production plan timeline, access to the planning system (through a workstation or terminal) and a 
copy of 456-TP-003-001, ECS Training Material Volume 3: Production Planning and 
Processing. 

Standard - The student will perform without error the steps involved in reviewing a production 
plan timeline in accordance with the applicable procedure. 

Specific Objective 6 - The student will perform the steps involved in configuring AutoSys 
runtime options. 

Condition - The student will be given a statement of the requirements for configuring AutoSys 
runtime options, access to the data processing system (through a workstation or terminal) and a 
copy of 456-TP-003-001, ECS Training Material Volume 3: Production Planning and 
Processing. 

Standard - The student will perform without error the steps involved in configuring AutoSys 
runtime options in accordance with the applicable procedure. 

Specific Objective 7 - The student will perform the steps involved in configuring AutoSys 
hardware groups. 

Condition - The student will be given a statement of the requirements for configuring AutoSys 
hardware groups, access to the data processing system (through a workstation or terminal) and a 
copy of 456-TP-003-001, ECS Training Material Volume 3: Production Planning and 
Processing. 

Standard - The student will perform without error the steps involved in configuring AutoSys 
hardware groups in accordance with the applicable procedure. 

Specific Objective 8 - The student will perform the steps involved in reviewing hardware status 
(including changing hardware status views) using AutoSys. 
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Condition - The student will be given a statement of the requirements for reviewing hardware 
status (including changing hardware status views) using AutoSys, access to the data processing 
system (through a workstation or terminal) and a copy of 456-TP-003-001, ECS Training 
Material Volume 3: Production Planning and Processing. 

Standard - The student will perform without error the steps involved in reviewing hardware 
status (including changing hardware status views) using AutoSys in accordance with the 
applicable procedure. 

Specific Objective 9 - The student will perform the steps involved in reviewing data processing 
request (DPR) dependencies. 

Condition - The student will be given a statement of the requirements for reviewing DPR 
dependencies, access to the data processing system (through a workstation or terminal) and a 
copy of 456-TP-003-001, ECS Training Material Volume 3: Production Planning and 
Processing. 

Standard - The student will perform without error the steps involved in reviewing DPR 
dependencies in accordance with the applicable procedure. 

Specific Objective 10 - The student will perform the steps involved in reviewing the DPR 
production timeline. 

Condition - The student will be given a statement of the requirements for reviewing the DPR 
production timeline, access to the data processing system (through a workstation or terminal) and 
a copy of 456-TP-003-001, ECS Training Material Volume 3: Production Planning and 
Processing. 

Standard - The student will perform without error the steps involved in reviewing the DPR 
production timeline in accordance with the applicable procedure. 

Specific Objective 11 - The student will perform the steps involved in reviewing and 
configuring AutoSys alarms. 

Condition - The student will be given a statement of the requirements for reviewing and 
configuring AutoSys alarms, access to the data processing system (through a workstation or 
terminal) and a copy of 456-TP-003-001, ECS Training Material Volume 3: Production 
Planning and Processing. 

Standard - The student will perform without error the steps involved in reviewing and 
configuring AutoSys alarms in accordance with the applicable procedure. 

Specific Objective 12 - The student will perform the steps involved in reviewing job activities 
and job selection criteria using AutoSys. 

Condition - The student will be given a statement of the requirements for reviewing job 
activities and job selection criteria using AutoSys, access to the data processing system (through 
a workstation or terminal) and a copy of 456-TP-003-001, ECS Training Material Volume 3: 
Production Planning and Processing. 
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Standard - The student will perform without error the steps involved in reviewing job activities 
and job selection criteria using AutoSys in accordance with the applicable procedure. 

Specific Objective 13 - The student will perform the steps involved in modifying job priority 
using AutoSys. 

Condition - The student will be given a statement of the requirements for modifying job priority 
using AutoSys, access to the data processing system (through a workstation or terminal) and a 
copy of 456-TP-003-001, ECS Training Material Volume 3: Production Planning and 
Processing. 

Standard - The student will perform without error the steps involved in modifying job priority 
using AutoSys in accordance with the applicable procedure. 

Specific Objective 14 - The student will perform the steps involved in modifying job status 
using AutoSys. 

Condition - The student will be given a statement of the requirements for modifying job status 
using AutoSys, access to the data processing system (through a workstation or terminal) and a 
copy of 456-TP-003-001, ECS Training Material Volume 3: Production Planning and 
Processing. 

Standard - The student will perform without error the steps involved in modifying job status 
using AutoSys in accordance with the applicable procedure. 

Specific Objective 15 - The student will perform the steps involved in reviewing activity logs 
and job dependency logs. 

Condition - The student will be given a statement of the requirements for reviewing activity logs 
and job dependency logs, access to the data processing system (through a workstation or 
terminal) and a copy of 456-TP-003-001, ECS Training Material Volume 3: Production 
Planning and Processing. 

Standard - The student will perform without error the steps involved in reviewing activity logs 
and job dependency logs in accordance with the applicable procedure. 

Specific Objective 16 - The student will perform the steps involved in generating standard 
production reports. 

Condition - The student will be given a statement of the requirements for generating standard 
production reports, access to the data processing system (through a workstation or terminal) and 
a copy of 456-TP-003-001, ECS Training Material Volume 3: Production Planning and 
Processing. 

Standard - The student will perform without error the steps involved in generating standard 
production reports in accordance with the applicable procedure. 

Specific Objective 17 - The student will perform the steps involved in generating AutoSys 
reports. 

Condition - The student will be given a statement of the requirements for generating AutoSys 
reports, access to the data processing system (through a workstation or terminal) and a copy of 
456-TP-003-001, ECS Training Material Volume 3: Production Planning and Processing. 
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Standard - The student will perform without error the steps involved in generating AutoSys 
reports in accordance with the applicable procedure. 

Specific Objective 18 - The student will perform the steps involved in defining and running 
monitors/browsers. 

Condition - The student will be given a statement of the requirements for defining and running 
monitors/browsers, access to the data processing system (through a workstation or terminal) and 
a copy of 456-TP-003-001, ECS Training Material Volume 3: Production Planning and 
Processing. 

Standard - The student will perform without error the steps involved in defining and running 
monitors/browsers in accordance with the applicable procedure. 

Specific Objective 19 - The student will perform the steps involved in changing the database 
maintenance time. 

Condition - The student will be given a statement of the requirements for changing the database 
maintenance time, access to the data processing system (through a workstation or terminal) and a 
copy of 456-TP-003-001, ECS Training Material Volume 3: Production Planning and 
Processing. 

Standard - The student will perform without error the steps involved in changing the database 
maintenance time in accordance with the applicable procedure. 

Specific Objective 20 - The student will perform the steps involved in performing science 
product quality assurance (QA). 

Condition - The student will be given a statement of the requirements for performing science 
product QA, access to the data processing system (through a workstation or terminal) and a copy 
of 456-TP-003-001, ECS Training Material Volume 3: Production Planning and Processing. 

Standard - The student will perform without error the steps involved in performing science 
product QA in accordance with the applicable procedure. 

Importance 
This lesson applies to students who will be members of the ECS production team (especially 
production planners and production monitors). The lesson will provide them with the knowledge 
and skills needed when performing their assigned tasks. 

Those tasks include (among other things) preparing production requests, preparing production 
plans and monitoring DPR production. The lesson describes why and how the activities are 
performed. Consequently, the students will become aware of what tasks they will be performing 
on the job and how to accomplish those tasks. 
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Creating/Updating a Production Request


Science Software and Production Requests 
Production planning occurs at the Data Active Archive Centers (DAACs). It is the process by 
which the Production Planner notifies the Planning Subsystem (PLS) of the science processing 
jobs that are to be processed and when they are to be processed. 

Science Software (SS) is one of the keys to production planning and processing: 

• does the actual data processing. 

• is developed by satellite Instrument Teams (ITs). 

•	 is embodied in Product Generation Executives (PGEs) when the software is 
integrated into the ECS production processing environment. 

 	PGEs are science software code (e.g., executable programs or shell scripts) that 
contain the instructions for processing data to create the desired products. 

The Production Request (PR) is another key to production planing and processing. The 
Production Planner defines ECS science data processing jobs in terms of PRs. 

• A PR is an order for data to be produced by the data processing system. 

•	 A single PR may specify several jobs that are to be run over a period of time or a 
single job producing a single set of data. 

•	 PRs may apply to the processing of new data (standard PRs or standing orders) or the 
reprocessing of existing data (reprocessing PRs). 

• Each PR identifies a specific PGE for generating a particular type of product. 

 	Some PGEs are dependent on others; i.e., some PGEs require input data that are 
the output of other PGEs. 

 	Prior to Release B there was to be no automatic "data chaining" to determine 
whether there was a particular sequence for scheduling the processing of PGEs 
that were prerequisite to generating a higher-level product. 

 	The planning software will recognize and reject a PR when the PR specifies a 
PGE that requires data from another PGE that has not yet been specified in a 
PR. 

Planning Subsystem 
The Planning Subsystem in the ECS Science Data Processing Segment (SDPS) is the subsystem 
that the Production Planner uses when developing a production plan. The Production Planner 
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has access to the Planning Subsystem through the Production Request Editor and the Planning 
Workbench. The Production Request Editor (PRE) is used for creating or modifying PRs; the 
Planning Workbench is used for scheduling PRs. 

The Planning Subsystem performs the following functions: 

• uses each PR to generate either one or a series of Data Processing Requests (DPRs). 

 Each DPR corresponds to one execution of a single PGE. 

 	Each DPR contains the information that is needed by the SDPS processing 
function, including PGE-related information. 

•	 checks the availability of the data required for the DPR, either from the data server (if 
the data have been previously ingested) or from internal predictions (if the data are 
expected to arrive in the future). 

•	 determines what data will be included in the DPR output so the system can make 
predictions concerning the availability of data for subsequent PGEs. 

Figure 1 shows the relationships among the PRs, PGEs, and DPRs as they are accessed through 
the Production Request Editor graphical user interface (GUI). 

Production Planning Considerations 
During normal operations it is expected that the Production Planner will not have to add PRs to 
the PDPS database very frequently. The frequency of this activity is, to some extent, determined 
by the IT responsible for the science software. 

•	 The PR is a template request to generate a particular data product and results in a 
production run of the associated IT-provided PGE. 

 	PR specifies a time range over which the data products are to be produced or the 
PGEs are to be scheduled. 

⋅ 	 PR might request that the data product be produced for only a single day’s 
data. 

⋅ 	 PR might request that data products be produced for every opportunity of 
input data for several months, resulting in several hundred jobs being planned 
and run as the input data become available. 

 	Early in a mission the IT may prefer to request processing for a short time 
period only (e.g., a week or less). 

⋅ 	 At that time the IT is gaining an understanding of the on-orbit behavior of the 
instrument, the resulting data, and the interaction of the science processing 
software with real data. 
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PR List 
PR 1 
PR 2 
PR3 

PR Edit 
PGE(1/PR) 
Start/End 

DPR List 
DPR1 
DPR2 
DPR3 

DPR View 
Plan/Actual 

(View) 

(View) (View)(Edit/View) 

To 
AutoSys 

PGEs PGE 
Parm 

PGE Mapping 
UR In/Out 

(View)(Edit/View)(Select) 

Figure 1. Production Request Editor Flow 

⋅ 	 IT reviews the quality of the products and notifies the Production Planner of 
the need for any changes to the PR (e.g., discontinue the PR, change time 
ranges, or modify input parameters). 

 	When the IT has developed a good understanding of the instrument’s behavior, 
the team may be comfortable requesting processing for months at a time. 

 	DAAC operations may have operational reasons for wanting to issue processing 
requests for a more limited time period. 

•	 The Production Planner has to balance the various considerations when determining 
whether or not to create or update a PR. 

Planning decisions are made on the basis of locally defined planning strategies. The production 
planning tools are intended to be flexible enough in their design to support the particular 
planning and scheduling cycles of the operations organization at each DAAC. 

Before planning production the Production Planner must coordinate with the Resource Planner to 
resolve all resource allocation issues. The Resource Planner provides the Production Planner 
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with a list of resources available for use in processing and an allocation profile with time for 
those resources. 

The Production Planner prepares a monthly and weekly production plan. In addition, the 
Production Planner develops a daily production schedule from the most current weekly plan. 
Although production planning varies from DAAC to DAAC, the following guidelines are 
generally applicable: 

• Monthly plans 

 developed for the coming month and one or two months in advance. 

 	produced, reviewed, updated, published and distributed approximately two 
weeks before the beginning of the month. 

 	plan for the coming month is used to establish a baseline against which 
production targets can be measured. 

• Weekly plans 

 	produced, reviewed, updated, published and distributed approximately five days 
before the beginning of the coming week. 

 	used to produce a baseline for comparison of planned vs. actual production 
results. 

• Daily plan or schedule 

 produced each day for the next processing day. 

 	developed from the current weekly plan, adjusted to reflect the actual 
processing accomplished and the actual resources available at the time the daily 
schedule is generated. 

During normal processing, when reasonably accurate predictions of the processing time for the 
PGEs are available, the processing schedule should result in a reasonably accurate prediction of 
when data products will be generated. However, during abnormal situations (e.g., equipment 
failure), what is actually accomplished could depart significantly from the plan. In such 
situations, the Production Planner may choose to develop new plans to reflect current events. 
This process is known as “replanning.” 

Creating a New Production Request 
The new Production Request process begins when the Production Planner starts the Production 
Request Editor graphical user interface (GUI) from a UNIX prompt. The Production Planner 
enters the Request Definition, PGE parameters, duration, and comments for the new Production 
Request. 
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Before creating the new PR the Production Planner must have available the following 
information: 

• Name of the PR. 

• Priority of the PR. 

• PGE to be used in processing the PR. 

• PGE parameters to be used. 

• Parameter(s) to be changed (optional) 

• Start Date. 

• Start Time. 

• End Date. 

• End Time. 

• Comments (if applicable). 

The Production Planner assigns an initial processing priority based on the local DAAC policy. 
Job Priority specifies the priority of the job, with 1 (one) being the highest priority and 99 the 
lowest. 

Creating a New Production Request 

NOTE: Commands in Steps 1 through 10 are typed at a UNIX system prompt. 

1 Access the command shell. 

• The command shell prompt is displayed. 

2 Type xhost + then press the Return/Enter key on the keyboard. 

3 Open another UNIX window. 

4
 Start the log-in to the planning server by typing either telnet servername (e.g., 
plnn1sun), rlogin servername, or rsh servername in the second window then press the 
Return/Enter key. 

• If you use the telnet command, a Login: prompt appears; continue with Step 5. 

•	 If you use either the rlogin or rsh command, the system uses the User ID currently in 
use; go to Step 6. 

5
 If a Login: prompt appears, log in as yourself by typing your UserID then pressing the 
Return/Enter key. 

6 At the Password: prompt type your Password then press the Return/Enter key. 
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7 Type setenv DISPLAY clientname:0.0 then press the Return/Enter key. 

•	 It is recommended that you use the terminal/workstation IP address instead of the 
machine-name for the clientname. 

8 Type cd /path then press Return/Enter. 

•	 Change directory to the directory (e.g., 
/home/kummerer/ssit/ProductionRequestEditor) containing the Production Request 
Editor set-up file (i.e., PR_Setup.com). 

9 Type source PR_Setup.com then press Return/Enter. 

• The source command sets the environment variables. 

10 Type PREditor then press Return/Enter to launch the Production Request Editor GUI. 

• The Production Request Editor Introductory GUI (Figure 2) is displayed. 

11 Select the Production Request Editor by clicking (single click) on the PR Edit tab. 

• The PR Edit GUI page (Figure 3) is presented. 

12 Type your UserID in the Originator field. 

•	 The Origination Date field will be automatically filled when the Production Request 
is saved at the end of the procedure. (You do not need to fill in this field.) 

13 Type the priority for the PR in the Priority field. 

•	 Remember that the job Priority field specifies the priority of the job with 1 (one) as 
the highest priority and 99 the lowest priority. 

14
 Click on the PGE... button. 

• The PGE Selection GUI (Figure 4) is displayed. 

15 Select the desired PGE from the list by clicking on the appropriate row in the table. 

• The PGE list is scrollable. (If there are items on the list in addition to those currently 
visible in the window, the additional items can be viewed by clicking on the arrows 
associated with the scrollbars.) 
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Figure 2. Production Request Editor Introductory GUI 
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Figure 3. PR Edit GUI 
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Figure 4. PGE Selection GUI 
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16 Click on the OK button. 

• The Production Request - PR Edit GUI page (Figure 3) is displayed. 

•	 The following fields are automatically filled: 

 Satellite Name 

 Instrument Name 

 PGE Name 

 PGE Version 

17 Click on the PGE Parameters... button. 

• The PGE Parameter Mappings GUI (Figure 5) is displayed. 

• The PGE Parameter Mappings GUI has a table that lists the following information: 

 Parameter Name. 

 Logical Id. 

 Default Value. 

 Override Value. 

 Description. 

18
 If any PGE parameter(s) should be changed, select (highlight) a parameter to be changed 
by clicking on the corresponding row in the list of parameters. 

• The parameter row is highlighted. 

• If you do not change the parameters, the values in the Default column will be used. 

• The PGE parameter mappings list is scrollable. 

19 Type the desired value in the Parameter Mapping field. 

• The value in the Override Value column is updated. 

•	 If any other parameter is to be changed, highlight it and type the desired value in the 
Parameter Mapping field. 

20 Click on the OK button to approve the changes. 

• The Production Request - PR Edit GUI (Figure 3) is displayed. 

21
 Type the desired start date (in MM/DD/YY format) in the Duration  Start  Date 
field, then press the Tab key on the keyboard to advance to the next field. 

22
 Type the desired start time (in hh:mm format) in the Duration  Start  Time field, 
then press the Tab key on the keyboard to advance to the next field. 
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Figure 5. PGE Parameter Mappings GUI 

19 456-TP-003-001




20 

23	 Type the desired end date (in MM/DD/YY format) in the Duration  End  Date field, 
then press the Tab key on the keyboard to advance to the next field. 

24	 Type the desired end time (in hh:mm format) in the Duration  End  Time field, 
then press the Tab key on the keyboard to advance to the next field. 

25 Type any relevant comments in the Comments field. 

26 Select Save As from the File pull-down menu (File → Save As). 

27	 Type a filename for the production request in the Selection field then click on the OK 
button to save the production request. 

• The Production Request is saved. 

• The Origination Date and Originator fields are automatically updated. 

•	 If no PR name has been entered in the PR Name field, you will be prompted to enter 
a PR name during the “Save” process. 

28 Select File → New to clear the entries on the Production Request Editor GUI. 

• Return to Step 11 to create another new PR. 

29 Select File → Exit to quit the Production Request Editor GUI. 

• The UNIX window is available for entering other commands. 

There is a quick-step version of the preceding procedure. Do not use the quick-step procedure 
until you have become very familiar with creating new production requests. 

It is also possible to create a new PR by editing or modifying an existing PR and renaming it. 
This is particularly quick and useful if there are only minor differences between the existing PR 
and the new one. 

Editing or Modifying a Production Request 

This section explains how to edit or modify a Production Request. 

Before you make any changes to a PR, you must know what needs to be changed. You can 
change any of the following attributes of the PR: 

• Name of the PR (creates a new PR). 

• Priority of the PR. 

• PGE to be used in processing the PR. 

• PGE parameters to be used. 

• Start Date. 
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• Start Time. 

• End Date. 

• End Time. 

• Comments (if applicable). 

To edit/modify a new Production Request by the Production Planner, execute the procedure steps 
that follow. Perform only those steps of the procedure that are applicable to the changes you 
want to make. You do not have to go through all of the fields in the PR to successfully modify 
it. However, you must save the modified PR (Steps 20 and 21) to make the changes effective. 

Editing/Modifying a Production Request 

1	 Launch the Production Request Editor as described in Steps 1 through 10 of the 
procedure for Creating a New Production Request. 

• The Production Request Editor Introductory GUI (Figure 2) is displayed. 

2 Select the Production Request List by clicking on the PR List tab. 

• The PR List GUI page (Figure 6) is presented. 

• The PR list is scrollable. 

3	 Identify a Production Request to be edited/modified from those shown in the list of 
Production Requests, then click on the PR Edit tab. 

• The PR Edit GUI page (Figure 3) is displayed. 

4	 Select File → Open from the pull-down menu to display a list of Production Requests 
from which to select the PR to be opened. 

• The list of Production Requests is displayed. 

5	 Select (highlight) the PR to be edited/modified by clicking on the corresponding PR 
name in the list of PRs. 

6 Click on the OK button. 

7 If the PR’s priority is to be changed, type the new priority in the Priority field. 

•	 Remember that the job Priority field specifies the priority of the job with 1 (one) as 
the highest priority and 99 the lowest priority. 

8 If the PGE is to be changed, click on the PGE... button. 

• The PGE Selection GUI (Figure 4) is displayed. 

• Perform Steps 9 and 10 to designate the new PGE. 

9 Select the desired PGE by clicking on the appropriate row in the table. 
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Figure 6. PR List GUI 
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10 Click on the OK button. 

• The Production Request - PR Edit GUI page (Figure 3) is displayed. 

•	 The following fields are automatically filled: 

 Satellite Name 

 Instrument Name 

 PGE Name 

 PGE Version 

11 If any PGE parameter(s) should be changed, click on the PGE Parameters... button. 

• The PGE Parameter Mappings GUI (Figure 5) is displayed. 

• Perform Steps 12 through 14 to designate the new PGE parameter(s). 

12	 Select (highlight) a parameter to be changed by clicking on the corresponding row in the 
list of parameters. 

• The parameter row is highlighted. 

• If you do not change the parameters, the values in the Default column will be used. 

13 Type the desired value in the Parameter Mapping field. 

• The value in the Override Value column is updated. 

•	 If any other parameter is to be changed, highlight it and type the desired value in the 
Parameter Mapping field. 

14 Click on the OK button to approve the changes. 

• The Production Request - PR Edit GUI (Figure 3) is displayed. 

15	 If the PR’s start date is to be modified, type the desired date (in MM/DD/YY format) in 
the Duration  Start  Date field, then press the Tab key on the keyboard to advance 
to the next field. 

16	 If the PR’s start time is to be modified, type the desired time (in hh:mm format) in the 
Duration  Start  Time field, then press the Tab key on the keyboard to advance to 
the next field. 

17	 If the PR’s end date is to be modified, type the desired date (in MM/DD/YY format) in 
the Duration  End  Date field, then press the Tab key on the keyboard to advance 
to the next field. 

18	 If the PR’s end time is to be modified, type the desired time (in hh:mm format) in the 
Duration  End  Time field, then press the Tab key on the keyboard to advance to 
the next field. 
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19 Type any relevant comments in the Comments field. 

20 Select Save As from the File pull-down menu (File → Save As). 

21	 Type a filename for the production request in the Selection field then click on the OK 
button to save the production request. 

• The Production Request is saved. 

• The Origination Date field is automatically updated. 

•	 If no PR name has been entered in the PR Name field, you will be prompted to enter 
a PR name during the “Save” process. 

22 Select File → New to clear the entries on the Production Request Editor GUI. 

• Return to Step 2 to edit/modify another PR. 

23 Select File → Exit to quit the Production Request Editor GUI. 

• The UNIX window is available for entering other commands. 

There is a quick-step version of the preceding procedure. In general you should avoid using 
quick-step procedures until you have become very familiar with normal procedures. 

24 456-TP-003-001




25 

Creating a New Production Plan


Creating and Activating a Production Plan 

The Production Planner uses the Planning Workbench when creating a plan for production data 
processing at the DAAC. The Planning Workbench provides the means by which the Production 
Planner selects specific PRs whose DPRs are to be run. The planning tool provides a forecast of 
the start and completion times of the jobs based upon historical experience in running these 
PGEs. Through the planning tool, when the generated plan is “activated,” the information 
included in the plan is transferred to the Data Processing Subsystem and loaded into the Platinum 
AutoSys tool where production processing is managed. Figure 7 shows the general flow of 
production requests/data processing requests from the Production Request Editor through the 
Planning Workbench to the AutoSys production management tool (as well as resource planning, 
which is not supported in the Pre-Release B Testbed). Figure 8 presents a simplified view of the 
flow through the Planning and Data Processing Subsystem (PDPS). 

The Production Planner creates a production plan by selecting PRs from two lists of PRs, i.e., the 
list of available “Unscheduled” PRs and the list of “Scheduled” PRs. Using arrow buttons, the 
Production Planner moves the PRs between lists until the “Scheduled” list contains the desired 
set of PRs that define the new plan. 

Before creating a new production plan the Production Planner must have available the following 
information: 

• Name of the plan. 

• Comments (if any). 

• PRs to be included in the new production plan. 

Creating a New Production Plan 

NOTE: Commands in Steps 1 through 16 are typed at a UNIX system prompt. 

1 Access the command shell. 

• The command shell prompt is displayed. 

2 Type xhost + then press the Return/Enter key on the keyboard. 

3 Open another UNIX window. 
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4	 Start the log-in to the planning server by typing either telnet servername (e.g., 
plnn1sun), rlogin servername, or rsh servername in the second window then press the 
Return/Enter key. 

• If you use the telnet command, a Login: prompt appears; continue with Step 5. 

•	 If you use either the rlogin or rsh command, the system uses the User ID currently in 
use; go to Step 6. 

5	 If a Login: prompt appears, log in as yourself by typing your UserID then pressing the 
Return/Enter key. 

6 At the Password: prompt type your Password then press the Return/Enter key. 

7 Type setenv DISPLAY clientname:0.0 then press the Return/Enter key. 

•	 It is recommended that you use the terminal/workstation IP address instead of the 
machine-name for the clientname. 

8 Type cd /path then press Return/Enter. 

•	 Change directory to the directory (e.g., /home/kummerer/ssit/PlanningWorkbench) 
containing the Planning Workbench set-up file (i.e., PLWB_Setup.com). 

9 Type source PLWB_Setup.com then press Return/Enter. 

• The source command sets the environment variables. 

10	 Type st_all.xxxx.csh (where xxxx = larc, nsidc, edc or gsfc, as applicable) then press 
Return/Enter. 

• The Message Handler window is displayed first. 

• Eventually the Planning Workbench GUI (Figure 9) is displayed. 

11 Click on the UNIX window to reactivate it. 

12	 Type st_pltl.xxxx.csh (where xxxx = larc, nsidc, edc or gsfc, as applicable) then press 
Return/Enter. 

• The Planning Timeline is activated. 

13 Click on the Planning Workbench GUI to reactivate it. 

• Data concerning the currently active production plan are displayed. 

•	 If you want to “kill” (deactivate) the currently active production plan without 
activating a replacement, click on the Kill button. 

•	 Whenever you activate a plan (by clicking on the Activate button), you automatically 
“kill” the currently active plan. 

14 Select File → New from the pull-down menu. 

• The “New” window appears. 
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Figure 9. Planning Workbench GUI 
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15 Type a name for the new plan, then click on the OK button. 

• The Planning Workbench GUI is displayed. 

• The Plan Name is displayed. 

• The Status displayed is Candidate. 

16 Type any relevant comments (up to 255 characters) in the Comments field. 

17	 Move PRs between the Unscheduled and Scheduled lists as necessary by selecting 
(highlighting) the PR to be moved by clicking on the PR in the list from which it is to be 
moved then clicking on the up or down arrow button (as applicable) to move the PR to 
the other list. 

• Highlighted PR disappears from one list and appears on the other. 

• The unscheduled and scheduled PR lists are scrollable. 

18 When the Scheduled list accurately reflects the PRs to be scheduled in the production 
plan, select File → Save (or File → Save As) from the pull-down menu to save the new 
production plan. 

19 Verify that the name for the new production plan is correct, then click on the OK button. 

• The new production plan is saved. 

20	 If the new plan is to be activated immediately, click on the Activate button to activate the 
new plan. 

• The currently active plan is killed (deactivated) and the new plan is activated. 

•  The Production Planning Timeline GUI (Figure 10) is displayed. 

21 If the new production plan is to be used as a baseline plan, click on the Baseline button. 

• The “New” window appears. 

•↑ The plan is recorded as well as the time of baselining so that it can be used in 
comparing future processing results with planned objectives. 

22	 If the production plan being displayed is active and should be deactivated, click on the 
Kill button. 

• The “New” window appears. 

• The plan is deactivated without activating another plan. 

23 Select File → Exit to quit the Planning Workbench GUI. 

• The UNIX window is available for entering other commands. 
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Figure 10. Production Planning Timeline GUI 

24	 At the UNIX prompt type slay_all.csh then press Return/Enter. 

• All Planning Workbench-related applications are closed. 

There is a quick-step version of the preceding procedure. Do not use the quick-step procedure 
until you have become very familiar with creating new production plans. 
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Reviewing Data Processing Requests	

Data Processing Requests 

Data Processing Requests (DPRs) are generated automatically by the PDPS. 

 DPR is generated automatically from… 

 a PR (which specifies a PGE). 

 ↑information on the PGE acquired during the Science Software Integration and 
Test (SSI&T) process. 

• DPRs are complex, reflecting the complexity of the PGEs. 

•↑ DPRs contain information that is used by the Data Processing Subsystem and the 
AutoSys production scheduling software. 

The Production Planner can review DPRs. 

• DPRs may provide useful information. 

• DPR fields cannot be edited by M&O personnel. 

 Modifications to DPR information would have undesirable side-effects. 

Displaying DPR Information 

The Production Request Editor can display DPR information in two ways: 

• DPR List. 

• Data concerning an individual DPR. 

The following characteristics pertain to the DPR List: 

•↑ Each line of the DPR List display represents a DPR, i.e., a job that will be run when 
all data and resource needs have been satisfied. 

•↑ For each DPR the list includes the DPR identification, relevant PGE, name of the 
corresponding PR, data start date and time, etc. 

•↑ The DPR list may be filtered, so that only DPRs with certain characteristics are 
displayed. 

↑ For example, the Production Planner may be interested in reviewing only 
those DPRs associated with a particular PR. 
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By selecting a particular DPR on the DPR List, the Production Planner can obtain data on that 
DPR, especially the following characteristics: 

• PGE parameters 

 ↑displayed in the same format as the PGE Parameter Mappings GUI (Figure 5) 
used in creating a PR. 

• PGE File Mappings (UR File Mappings) 

 ↑displays the input and output files for a particular DPR on the UR File 
Mappings GUI (Figure 11) 

 ↑GUI displays one line of information for each file that may be used by or be 
produced by the PGE, including the following data: 

⋅ ↑ Logical ID - The identification (ID) or tag used within the PGE to access the 
file. 

⋅ Granule ID - The reference used to identify the granule uniquely. 

⋅ ↑ Start/Stop Time - The start or stop date and time for the data contained in this 
file. 

⋅ ↑ Availability - Flag indicating whether or not the data file is known to be 
accessible to be staged for use in processing. 

⋅ ↑ UR (Universal Reference) - The uniform reference for each object associated 
with the Science Data Processing Segment (SDPS) that allows each SDPS 
service to understand and support the object. 

Before reviewing a DPRs the Production Planner must know the name of the PR that caused the 
system to generate the DPRs. 

The process of reviewing DPRs begins with the Production Planner starting the Production 
Request Editor from a UNIX prompt. The Production Planner specifies the name of the PR that 
led to the generation of the DPRs to be reviewed. In addition, the Production Planner can review 
DPR Predicted and Actual Start Times, Data Start Time, Status and Priority. 

Reviewing Data Processing Requests 

Launch the Production Request Editor as described in Steps 1 through 10 of the 
procedure for Creating a New Production Request. 

• The Production Request Editor Introductory GUI (Figure 2) is displayed. 
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Figure 11. UR File Mappings GUI 
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2	 Select the Data Processing Request List by clicking on the DPR List tab. 

• The DPR List GUI page (Figure 12) is displayed. 

• The table shown on the GUI provides the following information on the DPRs: 

 DPR Id - identification (name) of the DPR. 

 PGE Id - identification of the PGE specified in the DPR. 

 PR Name - name of the PR that led to the creation of the DPR. 

 Data Start Time - DPR’s start date and time. 

 Data Stop Time - DPR’s stop date and time. 

3	 To list only the DPRs associated with a particular Production Request, first click on the 
option button associated with the Production Request field. 

• An option menu of Production Requests is displayed. 

4 Highlight the desired PR in the option menu then click on the Filter button. 

• The DPRs for the specified PR only are shown in the DPR List. 

•↑ An alternative method of filtering PRs is to type the name of the PR in the 
Production Request field then click on the Filter button. 

5	 Identify a DPR to be reviewed from those shown in the list of Data Processing Requests, 
then click on the DPR View tab. 

• The DPR View GUI (Figure 13) is displayed. 

6	 Select File → Open from the pull-down menu to display a list of Data Processing 
Requests from which to select the DPR to be opened. 

• The list of Data Processing Requests is displayed. 

7	 Select (highlight) the DPR to be edited/modified by clicking on the corresponding DPR 
name in the list of DPRs. 

8 Click on the OK button. 

• The DPR View GUI shows the following information concerning the selected DPR: 

 DPR Name. 

 PR Name. 

 Origination Date 

 Originator 

 PGE Id. 

 Data Start Time. 
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Figure 12. DPR List GUI 
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Figure 13. DPR View GUI 

36 456-TP-003-001




37 

 Data Stop Time. 

 Predicted Start Date. 

 Predicted Start Time. 

 Actual Start Date. 

 Actual Start Time. 

 Priority. 

 Status. 

9	 To obtain information concerning the PGE parameters (of the PGE associated with the 
DPR), click on the PGE Parameters... button. 

•	 The PGE Parameters GUI (same format as Figure 5 except there is no Parameter 
Mapping field) is displayed. 

10	 When finished reviewing the PGE parameters, click on the OK button to return to the 
DPR View GUI. 

• The DPR View GUI (Figure 13) is displayed. 

11 Click on the PGE File Mappings... button. 

• The UR File Mappings GUI (Figure 11) is displayed. 

•	 The UR File Mappings GUI displays one line of information for each file that may 
be used by or be produced by the PGE associated with the selected DPR: 

 Logical Id.


 Granule Id


 Start Time (date and time).


 Stop Time (date and time). 

 Availability. 

 UR (universal reference). 

• The PGE’s input data and output data are displayed in separate areas. 

12	 When finished reviewing the UR File Mappings, click on the OK button to return to the 
DPR View GUI. 

• The DPR View GUI is displayed. 

13 Review the Data Start Time and Data Stop Time. 
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14 Review the Request Data and Status area of the GUI. 

•	 The DPR View GUI displays the following information concerning the selected 
DPR: 

 Predicted Start Date and Time.


 Actual Start Date and Time.


 Priority.


 Status.


•	 Predicted Start Date/Time and Actual Start Date/Time are displayed only if the 
Production Request has been scheduled. 

15	 When finished reviewing information concerning the DPR, repeat Steps 2 through 14 to 
review additional DPRs. 

16 Select File → Exit to quit the Production Request Editor GUI. 

• The UNIX window is available for entering other commands. 
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Reviewing a Plan Timeline


Production Plan Timeline 

A graphic, timeline-oriented depiction of a production plan, as shown in Figure 10, can be 
displayed. The timeline application is available and minimized when the Production Planning 
Workbench is initiated. When the minimized timeline application object is selected, the 
production plan timeline graphic is displayed. 

The display represents a set of computers, arranged along the left side of the GUI, and some 
period of time as indicated across the top edge of the GUI. The execution of DPRs on a 
computer over a period of time is represented by several DPR bars across the GUI for that 
computer. A bar represents a time period during which a PGE (as described by a DPR) is 
running. Each bar has the name of the PGE. Scroll bars allow scrolling up and down through the 
full list of computers and left and right in time. 

Reviewing a Plan Timeline 

[TBD]
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Production Planning Scenarios


The following two scenarios from the Operations Scenarios for the ECS Project: Release A, 
605-CD-001-003, June 1996, illustrate production planning: 

• Routine Production Planning Scenario 

• Replanning Production Scenario 

Routine Production Planning Scenario 

This scenario occurs during a given day of the Release A period at the Langley Research Center 
(LaRC) DAAC under the following conditions: 

• The system at the DAAC is in stable operations. 

• The following components are all operating normally: 

 TRMM instruments (including CERES). 

 Sensor Data Processing Facility (SDPF). 

 ECS Ingest Subsystem. 

• Pertinent PGEs have been integrated into the ECS production processing environment 
and are operating normally. 

The scenario describes the process for the development of plans for production processing at the 
LaRC DAAC. The following three planning time cycles are described in this scenario: 

• monthly plan. 

• weekly plan 

• daily plan/schedule. 

The time-frames identified here indicate a possible scheme for the generation of these plans. It is 
the intent that the production planning tool be flexible enough in its design to support the 
particular planning and scheduling cycles of the operations organization of each DAAC. 

The scenario describes the addition of a Production Request into the Planning and Data 
Processing System (PDPS) database. This is not a routine activity but is described here for the 
sake of covering other operator interfaces that have a bearing on the routine production planning 
activity. 

The Production Planner prepares a monthly and weekly production plan. In addition, the 
Production Planner develops a daily production schedule from the most current weekly plan. 
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Monthly plans are developed for the coming month and one or two months in advance. 

•↑ The monthly plans are generally produced, reviewed, updated and 
published/distributed approximately two weeks before the beginning of the month. 

•↑ The monthly plan for the coming month is used to establish a baseline against which 
production targets can be measured. 

Weekly plans are developed for the coming week. 

•↑ Weekly plans are produced, reviewed, updated and published/distributed 
approximately five days before the beginning of the coming week. 

•↑ The weekly plan is used to produce a baseline for comparison of planned vs. actual 
production results. 

A daily plan or schedule is produced each day for the next processing day. 

•↑ The daily schedule is developed from the current weekly plan, adjusted to reflect the 
actual processing accomplished and the actual resources available at the time of the 
daily schedule generation. 

The LaRC DAAC will be operating on a 16-hour per day processing schedule during the Release 
A period. 

The Production Planner sends the next 16 hour portion daily production schedule to Data 
Processing Subsystem (DPS), representing the processing workload for the day. 

In the current scenario, the Instrument Team (IT) for the CERES instrument has a standing 
agreement with the Production Planner to input a PR covering a one-month period every month. 
The IT reviews the quality of the products on a monthly basis and provides any changes to the 
PR. Changes may include such items as the following factors: 

• discontinue PR. 

• change time ranges. 

• modify input parameters. 

The IT provides changes to the planner via e-mail prior to the time that the PR should be 
updated. For the last several months, there have been no changes to the PR other than to reissue 
it for continued processing. 

The scenario is based on the assumption that all of the following conditions have been met: 

• All resource allocation issues have been resolved with the Resource Planner. 

• The Resource Planner has provided the Production Planner with the following items: 

 list of resources available for use in processing. 

 allocation profile with time for the available resources. 
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•↑ The PDPS database is complete in terms of PRs, DPRs and data availability 
predictions, etc. and is ready to support the planning activity. 

• Subscriptions have been entered against all data products required for processing. 

The following steps have been extracted and adapted from the scenario: 

1. The Production Planner reviews objectives for processing for the coming month. 

• Production planning considerations include the following factors: 

 science software stability. 

 Instrument Team input. 

 project directives. 

•↑ The Production Planner notes that the current PR for a CERES product is due to 
expire. 

• The IT for CERES has requested that the PR be reissued for the next month. 

2. 	 The Production Planner starts the Production Request Editor from the normal 
Production Planner’s desktop and selects the option to access existing PRs. 

• The PR List GUI is displayed. 

3. 	 The Production Planner selects the PR to be reissued from the PR List GUI and 
opens the PR Edit GUI to make modifications to the PR. 

• The PR Edit GUI is displayed. 

•↑ The Production Planner uses the existing PR as a template for a new PR, which 
will have a new name and revised start and stop dates. 

• The system uses the new PR to generate a series of DPRs. 

 Each DPR corresponds to the execution of a single PGE. 

 ↑The availability of data required for each DPR is checked, either from the data 
server (if the data have been previously ingested) or from internal predictions 
as to when the data can be expected. 

 ↑The data to be output from the DPR are calculated to generate predictions of 
the availability of that data for subsequent PGEs. 

4. 	 The Production Planner creates a plan for the coming month using the Planning 
Workbench. 

•↑ The Planning Workbench is started from the normal Production Planner’s 
desktop. 

5. The Production Planner selects the new plan option. 

6. The Production Planner enters the time period (date/time) for the plan [TBD]. 
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7. 	 The Production Planner reviews the available PRs displayed on the Planning 
Workbench GUI. 

•↑ The Planning Workbench GUI shows separate lists of unscheduled and 
scheduled PRs. 

8. 	 The Production Planner is uncertain concerning the details of one of the PRs 
displayed and selects the PR to review the details. [TBD] 

9. 	 The Production Planner goes back to the lists of scheduled and unscheduled PRs and 
moves PRs between the lists until the scheduled list contains the desired PRs. 

10. Having selected the applicable PRs for the new Production Plan, the Production 
Planner activates the plan (using the Activate button). 

• The Production Planning Timeline GUI is displayed. 

11. The Production Planner reviews the Production Planning Timeline GUI which was 
displayed when the Production Planner clicked on the Activate button. 

• The system uses the following types of data to develop a monthly plan: 

 list of selected PRs. 

 information concerning the projected run time of the jobs. 

 system resource projections including ground event activities. 

 priorities associated with jobs. 

12. The Production Planner reviews the new plan. 

•↑ In this case not all of the intended processing objectives are accomplished as a 
result of the large amount of ground event time allocated to production 
resources during the interval for testing purposes. 

•↑ The Production Planner decides to develop a second candidate plan where the 
priorities of some reprocessing activities are lowered to allow standard 
processing objectives to be met. 

•↑ The Production Planner is aware that the testing activities will be completed 
shortly after and that sufficient resources will be available to keep current with 
standard processing and work off the backlog of reprocessing. 

13. The Production Planner exits from the Production Planning Timeline GUI, saves 
the current plan, and returns to plan creation, selecting a PR, modifying its priority 
level and time period and scheduling it in the modified plan. 

•↑ The Production Planner can prepare and save multiple plans during a planning 
session. 

14. The Production Planner reviews the modified plan. 
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15. The Production Planner analyzes the results of the modified plan and decides that it 
achieves the goals. The Production Planner saves the monthly Production Plan. 

16. The Production Planner selects a baseline plan (monthly) using the Planning 
Workbench GUI. 

• The baseline plan provides a reference point for “Plan vs. Actual” comparisons. 

•↑ The Planning Workbench creates a tabular representation of the information 
contained in the plan and transfers the resulting document to the document data 
server (DDS), where it is available to the public. 

17. The Production Planner starts the creation of a weekly Production Plan by opening an 
existing weekly plan using the Planning Workbench GUI. 

18. The Production Planner reviews and updates the selected PRs as required on the basis 
of planning meetings and comments. 

19. The Production Planner reviews the Production Planning Timeline GUI, decides 
that the plan meets the objectives and saves the plan. 

20. The Production Planner selects a baseline plan (weekly) using the Planning 
Workbench GUI. 

• The baseline plan provides a reference point for “Plan vs. Actual” comparisons. 

•↑ The Planning Workbench creates a tabular representation of the information 
contained in the plan and transfers the resulting document to the document data 
server (DDS), where it is available to the public. 

21. The Production Planner decides to review and activate the production schedule for the 
next day of processing. 

22. The Production Planner selects the current weekly plan being used for the 
activation/schedule seeding operation. 

•↑ Information from the current weekly plan will be rolled into the processing 
system scheduler. 

•↑ The plan for the day is updated to reflect any changes in the PDPS Planning 
database, such as the status of DPRs that were previously activated for 
processing, or changes in the resource allocation timeline for processing. 

23. The Production Planner enters the time range of the scheduling period, enters any 
comments and activates the plan. 

•↑ The system creates an ordered list of activities which are currently active in data 
processing and integrates with it other activities that may be scheduled within 
the scheduling window or time period. 

• The Planning System processes the list. 
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 ↑If the DPR is already active (i.e., in the Data Processing System), the entry 
available to the data processing system is updated to ensure the most current 
information with possible priority adjustments. 

 If the DPR is not active, it is scheduled into the Data Processing System. 

24. The Production Planner reviews the resulting schedule and accepts the results. 

•↑ The Data Processing System will initiate PGE jobs according to the schedule of 
jobs transferred from the Planning System. 

At the completion of the scenario, the planning database contains new and updated entries 
reflecting the current state of the Production Plan. The DDS contains the published version of 
the plan and a timeline view [TBD] of the plan. E-mail messages will have been sent to all 
affected persons, as determined by the plan insertion or update. The production schedule, as 
maintained by AutoSys, will have been updated and processing will proceed according to the 
schedule. 

Replanning Production Scenario 

This scenario occurs during a given day of the Release A period at the Langley Research Center 
(LaRC) DAAC when the system at the DAAC is in stable operations. The scenario describes the 
process for the development of plans for production processing to replace or supersede plans that 
have already been established. 

During normal processing when reasonably accurate predictions of the processing time for the 
PGEs are available, the processing schedule should result in a good prediction of when data 
products will be generated. However, several difficult-to-predict or unpredictable factors can 
affect the planning system’s ability to produce a plan with accurate predictions. The following 
factors may have such effects: 

• Equipment failures. 

• Emergency or high priority processing. 

• Delayed input data. 

• PGE faults. 

•↑ PGEs with data product-dependent components that affect PGE run time (e.g., the 
PGE runs long or short when clouds are encountered). 

• PGEs with geo-location dependent processing. 

In such situations, the plan could depart significantly from what is actually accomplished. In 
such a situation, the production planner may choose to develop a new plan to reflect the current 
situation. Note however that this is not essential. Production will continue to process the 
planned jobs, redirecting jobs to other processors should one fail. Also, if a particular job and 
data product are important, priorities can be adjusted without replanning to speed up the delivery 
of the product. 
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In summary, the frequency of occurrence of replanning is difficult to predict. It is assumed that 
no more than two planning sessions per day might occur. 

The scenario is based on the assumption that all of the following conditions have been met: 

•↑ A plan for the processing interval has been developed and activated so that the 
Processing system contains a queue of jobs and has been processing jobs for some 
time. 

•↑ Because of unexpectedly long run times for some processing jobs, the actual 
processing accomplished has fallen behind the planned processing. 

The following steps have been extracted and adapted from the scenario: 

1. 	 In response to the Production Monitor’s notification that the planned objectives for 
the shift are not being met, the Production Planner launches the Planning 
Workbench GUI. 

•↑ The Planning Workbench is the mechanism for planning and replanning of 
production. 

•↑ The Planning Workbench seeds the AutoSys job scheduling software with 
processing jobs. 

2. 	 The Production Planner selects and opens the current weekly plan being used for the 
activation/schedule seeding operation. 

•↑ The plan for the day is updated to reflect any changes in the PDPS Planning 
database, such as the following factors: 

 status of DPRs that were previously activated for processing. 

 changes in the resource allocation timeline for processing. 

•↑ The impact of the delayed processing as determined from the DPRs’ statuses are 
reflected in the plan for the day. 

3. 	 The Production Planner reviews the resulting schedule and works to adjust priorities 
until the results are acceptable. 

•↑ The Production Planner uses Planning Workbench tools to update the plan and 
view the plan in timeline form. 

4. The Production Planner activates the new plan. 

•↑ Information from the updated plan will be rolled into the processing system 
software scheduler. 

•↑ The system creates an ordered list of activities which are currently active in data 
processing and integrates with it other activities that may be scheduled within 
the scheduling window or time period. 

• The Planning System processes the list. 

47 456-TP-003-001




48 

 ↑If the DPR is already active (i.e., in the Data Processing System), the entry 
available to the Data Processing System is updated to ensure the most current 
timing information with possible priority adjustments. 

 If the DPR is not active, it is scheduled into the Data Processing System. 

5. 	 The Data Processing System will initiate PGE jobs according to the schedule of jobs 
transferred from the Planning System. 

At the completion of the preceding scenario, the planning database contains new and updated 
entries reflecting the current state of the Production Plan. The Document Data Server contains 
the published version of the plan and a timeline view [TBD] of the plan. E-mail messages will 
have been sent to all affected persons, as determined by the plan insertion or update. The 
production schedule, as maintained by AutoSys, will have been updated and processing will 
proceed according to the schedule. 
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Configuring AutoSys Screens/Displays


AutoSys/AutoXpert Production Scheduling Tool 
The Planning and Data Processing Subsystem (PDPS) provides a batch processing environment 
to support the generation of data products. It manages, queues and executes Data Processing 
Requests (DPR) on the processing resources at a DAAC. The DPRs are submitted from the 
Planning Subsystem. The PDPS provides the operational interfaces needed to monitor the 
execution of science software PGEs specified in the DPRs. 

The AutoSys/AutoXpert software is a production scheduling tool intended to support the 
operational activities surrounding production processing in the PDPS. It assists with the 
following activities (among others): 

• job monitoring. 

• job scheduling. 

• fault notification. 

• job restart. 

• determining the effects of failure of a DPR. 

• determining the cause and actions to be taken due to the failure of a DPR. 

The AutoSys scheduling software in the DPS displays DPRs as job boxes. AutoSys recognizes 
the following three categories of jobs: 

• Command jobs. 

• Box jobs. 

• File-watcher jobs. 

A command job is the type most commonly thought of as a “job.” The “command” can be a 
shell script, the name of an executable program, a file transfer, or any other command that causes 
execution of a UNIX command on client machine. When all of the starting conditions for the 
particular job have been met, AutoSys performs the following functions: 

• executes the command (runs the job). 

• captures the exit code at job completion. 

•↑ sends the exit event (success or failure) and code back to the relational database 
management system (RDBMS). 

A box job is a collection of other jobs. It performs no processing action other than providing an 
organizational structure for a group of jobs that should be run within the same time period. Box 
jobs can be nested; i.e., box jobs can be included in other box jobs. Box jobs are particularly 
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useful for organizing, managing, and administering large numbers of jobs which are interrelated 
or have complex logic flows. 

Box jobs are subject to the following rules: 

•↑ If no other starting conditions are specified at the job level, a job within a box job 
runs as soon as the starting conditions for the box are satisfied. 

•↑ If there are no job-level starting conditions for some of the jobs in a box, those jobs 
will run in parallel. 

 ↑The jobs will run only once even if multiple start times are specified for some of 
the individual jobs. 

 Consequently, jobs in boxes will not be run several times inadvertently. 

•↑ Whenever any job in a box changes state, all jobs in the box are checked to see if they 
are eligible to be run. 

A file-watcher job functions in a manner that is similar to a command job; however, it has a 
special purpose, i.e., to monitor the creation and size of a particular operating system file. When 
the file has reached a specified minimum size and is no longer increasing in size, the file-watcher 
job sends AutoSys an event indicating that the file has arrived. The file-watcher job allows 
AutoSys to know the status of external files that are needed in the processing of command jobs 
or box jobs. 

When determining whether to start a job of any type, AutoSys evaluates the job with respect to 
the following the following starting parameters: 

• Date and time scheduling parameters are met. 

• Starting Conditions specified in the job definition evaluate to “true.” 

• For jobs in a box, the box must be in the RUNNING state. 

• The current status of the job is not ON_HOLD or ON_ICE. 

Every time there is an event that changes the truth of any of the preceding parameters, AutoSys 
finds all jobs that may be affected by the change and determines whether or not to start them. 

As previously mentioned, AutoSys jobs in the context of ECS are based on the DPRs generated 
by the Planning Subsystem in response to the Production Planner’s selection of PGEs on a 
Production Request. When a Production Plan that includes the Production Request is activated, 
AutoSys creates jobs from the DPRs. 

Each DPR represents the execution of a single science software PGE. However, a DPR may 
depend on the availability (as input) of data produced by another DPR. DPR dependencies result 
in the following mode of processing: 

•↑ Any DPRs that depend on data which are not yet available, are kept in a "held" state 
by AutoSys until their data availability subscriptions are fulfilled. 
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•↑ The subscription manager software, which is part of the Planning Subsystem, receives 
subscription notifications for the DPRs and informs the DPS to release the AutoSys 
jobs after all data subscriptions for a given DPR are fulfilled. 

•↑ The Data Processing Subsystem (as managed by the AutoSys Job Scheduling engine) 
runs the PGEs and associated jobs as the resources required for the tasks become 
available. 

• The procedure continues until all DPRs scheduled for that day have completed. 

The DAAC Production Monitor uses AutoSys/AutoXpert when performing the following 
functions: 

• modifying DPR priorities and inputs as required. 

•↑ transferring/deleting/suspending/resuming DPRs as required (e.g., requests, resource 
problems, input data schedule problems, special events, schedules replans, etc.). 

• monitoring and providing processing status upon request.


• monitoring/reviewing input and output data.


• implementing production system reconfiguration in response to operations anomalies.


The Production Monitor can configure some aspects of AutoSys, including the runtime options. 

Configuring AutoSys Runtime Options 
This section explains how to configure AutoSys runtime options. The procedure assumes that 
the Production Monitor has logged into the Production Workbench and the proper desk top 
environment is being displayed. 

The Production Monitor can define the following runtime options: 

• Refresh Interval. 

• Ping Interval. 

• Hang Time. 

• Inches/Hr. 

The Refresh Interval determines how often the View Region (the area on the right side of the 
GUI display where data are presented) will be updated. The Ping Interval is defined by how 
often the connectivity will be evaluated. The Hang Time is the length of time jobs will continue 
to be displayed within a machine after they have completed running. Inches/Hr specifies how 
much information is displayed on the screen. There are default values that apply to the runtime 
options unless the Production Monitor modifies them. 
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Table 1 lists the runtime options available for HostScape, TimeScape, and JobScape. Not all 
options are available for all GUI’s. 

Table 1. Runtime Options Table 
Interface Refresh Interval Hangtime PING Inches/Hour 

HostScape X X X 

TimeScape X X 

JobScape X 

The procedure assumes that AutoXpert HostScape is running. Perform only the steps that are 
applicable to the changes to be made (as specified in Table 1). Note that if the Freeze Frame 
feature is enabled, any changes entered will not take place until Freeze Frame has been disabled. 

Configuring AutoSys Runtime Options 

NOTE: Commands in Steps 1 through 10 are typed at a UNIX system prompt. 

1 Access the command shell. 

• The command shell prompt is displayed. 

2 Type xhost + then press the Return/Enter key on the keyboard. 

3 Open another UNIX window. 

4	 Start the log-in to the appropriate server by typing either telnet servername (e.g., 
sprn1sun), rlogin servername, or rsh servername in the second window then press the 
Return/Enter key. 

• If you use the telnet command, a Login: prompt appears; continue with Step 5. 

•↑ If you use either the rlogin or rsh command, the system uses the User ID currently in 
use; go to Step 6. 

5	 If a Login: prompt appears, log in as yourself by typing your UserID then pressing the 
Return/Enter key. 

6 At the Password: prompt type your Password then press the Return/Enter key. 

7 Type setenv DISPLAY clientname:0.0 then press the Return/Enter key. 

•↑ It is recommended that you use the terminal/workstation IP address instead of the 
machine-name for the clientname. 

8 Type cd /path then press Return/Enter. 

•↑ Change directory to the directory (e.g., /home/kummerer/ssit/AutoSys) containing the 
AutoSys set-up file (i.e., Autosys_Setup.com). 
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9 Type source Autosys_Setup.com then press Return/Enter. 

• The source command sets the environment variables. 

10 Type autosc & then press Return/Enter to launch AutoSys. 

• The AutoSys GUI Control Panel (Figure 14) is displayed. 

Figure 14. AutoSys GUI Control Panel 

11 Click on either the HostScape, TimeScape, or JobScape button. 

•↑ The AutoXpert GUI corresponding to the selected button is displayed (Figures 15­
17). 

12 Select Options → Edit Runtime Options from the pull-down menu. 

• The Runtime Options dialog box is displayed. 

13	 If the refresh interval is to be modified, click on Refresh Interval (Seconds) and either 
type in a value between 1 and 99999 or click on the <| and |> keys as necessary to 
decrease or increase the current numerical value until the desired value is reached. 

• Default value is 30 seconds. 

•↑ The Reloading Job Data window reappears as often as specified in the Refresh 
Interval (Seconds) field. 

14	 If the ping interval is to be modified, click on Ping Interval (Seconds) and either type in 
a value between 1 and 99999 or click on the <| and |> keys as necessary to decrease or 
increase the current numerical value until the desired value is reached. 

• Default value is 300 seconds. 

• If 99999 is entered, no ping commands are issued. 
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Figure 15. AutoXpert HostScape GUI 
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Figure 16. AutoXpert TimeScape GUI 
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Figure 17. AutoXpert JobScape GUI 
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15	 If the hang time is to be modified, click on Hang Time (Minutes) and either type in a 
value between 1 and 99999 or click the <| and |> keys as necessary to decrease or 
increase the current numerical value until the desired value is reached. 

• Default value is 1 minute. 

16	 If the number of inches/hour is to be modified, click on Inches/Hr (inches) and either 
type in a value or click the <| and |> keys as necessary to decrease or increase the current 
numerical value until the desired value is reached. 

• Default value is 2 inches/hr. 

17 When all desired modifications have been entered, click on the OK button. 

• The runtime options are set. 

• The dialog box closes. 

18	 If another of the AutoXpert GUIs needs to have its runtime options configured, repeat 
Steps 11 through 17 for the next GUI. 

19	 Select File → Exit then click on the OK button to quit any of the AutoXpert GUIs 
(HostScape, JobScape or TimeScape). 

• The UNIX window is available for entering other commands. 

20 Click on the Exit button of the AutoSys GUI Control Panel to quit AutoSys. 

Configuring Hardware Groups 
This section explains how to configure AutoSys hardware groups.  The purpose of configuring 
hardware groups is to make it easier to monitor the hardware associated with a particular 
function (e.g., testing, training, or a certain type of processing) rather than having to find those 
items in the default group, which is “All Machines.” 

The Production Monitor may define a specific set of machines to be monitored as a group. The 
Production Monitor must know which machines are to be included in the group and should 
devise a useful name for the group. 

The Production Monitor must have access to UNIX commands in order to perform the 
procedure. 

Configuring Hardware Groups 

1	 If necessary, log in to the planning server as described in Steps 1 through 7 of the 
procedure for Configuring AutoSys Runtime Options. 

2	 Type cd /usr/ecs/Rel_A/COTS/autotree2 then press the Return/Enter key on the 
keyboard. 
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3	 Type vi xpert.groups.XXX (where XXX = the AUTOSERV instance) then press 
Return/Enter. 

• The configuration file is displayed by the vi text editor. 

•	 The AUTOSERV instance can be determined by typing echo $AUTOSERV at the 
UNIX prompt. 

4 Using vi editor commands create/modify hardware groups as necessary. 

• An example of a hardware group file is shown in Figure 18. 

groupname: Training 

plnn1sun 

sprn1sgi 

groupname: SSI&T 

aitn1sun 

aitn2sun 

Figure 18. AutoSys Hardware Group File 

• The first line of each machine group is in the format groupname: groupname. 

• The name of each machine to be included in the group is on a separate line. 

•	 The following vi editor commands are useful: 

 h (move cursor left) 

 j (move cursor down) 

 k (move cursor up) 

 l (move cursor right) 

 i (insert text) 

 x (delete a character) 

 u (undo previous change) 

 Esc (switch to command mode) 
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5 Press the Esc key. 

6 Type ZZ then press Return/Enter. 

• New hardware groups are entered and saved in the file. 

• UNIX prompt is displayed. 

7 Launch AutoSys by typing autosc & at the UNIX shell prompt. 

8 Click on the HostScape button. 

• The HostScape GUI (Figure 15) is displayed. 

9 Select View → Select Machine Group from the pull-down menu. 

• The Machine Group Selection dialog box is presented. 

10 Select (highlight) the machine group to be applied. 

• The machine group is highlighted. 

11 Click on the OK button. 

• The selected machine group is applied. 

• The Machine Group Selection dialog box closes. 
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