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13.  Production Planning 

13.1Production Planning Process 

The Planning Subsystem supports site operations in developing a production plan based on 
locally defined strategy. Production Planning involves creation of Production Requests using the 
Production Request Editor and the scheduling of the Production Requests using the Planning 
Workbench. 

The Production Planner defines ECS science data processing requirements in terms of 
Production Requests (PRs). 

a. A PR is an order for data to be produced by the Data Processing Subsystem. 
b.	 Each PR identifies specific science software [in the form of a Product Generation 

Executive (PGE)] that is to be run and the data (in terms of a time period, set of 
orbits, etc.) that is to be processed to produce the desired output product(s). 

In response to a PR the Planning Subsystem generates either one or a series of Data Processing 
Requests (DPRs). 

a. Each DPR corresponds to one execution of a single PGE. 
b.	 Each DPR contains the information that is needed by the Data Processing Subsystem 

to execute the PGE and produce the desired output product(s). 

The Production Planner defines Production Strategies that specify values in several categories 
related to DPRs. 

a.	 The values specified in a Production Strategy can be used in determining the priority 
of each DPR. 

The Production Planner creates a Production Plan that specifies which PR(s) [and consequently 
which DPR(s)] should be sent to Data Processing at one time. 

a.	 When creating a Production Plan, the Production Planner can associate a particular 
Production Strategy with the PRs in the plan. 

b.	 When the Production Planner “activates” a Production Plan, the associated DPRs 
become accessible to Data Processing. 

The Production Planner uses the following principal tools in the Planning Subsystem: 
a.	 Production Request Editor GUI - for creating Production Requests and Data 

Processing Requests. 
b. Production Strategies GUI - for creating Production Strategies. 
c. Planning Workbench GUI – for creating and activating Production Plans. 
d. Planning Timeline – for reviewing Production Plans. 

Subsequent sections related to Production Planning address the following topics: 
a.	 Section 13.2 An overview of the process for creating Production Requests and 

Data Processing Requests and step-by-step procedures for using the Production 
Request Editor. 

b.	 Section 13.3 An overview of the process for creating Production Strategies and 
step-by-step procedures for using the Production Strategies GUI. 

Interim Update 13-1 611-TD-561-001 



c.	 Section 13.4 An overview of the process for creating and activating Production 
Plans and step-by-step procedures for using the Planning Workbench GUI and 
Planning Timeline. 

d.	 Section 13.5 An overview and step-by-step procedures for cleaning the PDPS 
database. 

e.	 Section 13.6 Referral to the procedures for tuning system parameters included in 
Chapter 14, Production Processing. 

13.2Creating Production Requests and Data Processing Requests 

From the Production Request Editor, the Production Planner can create new production requests, 
modify or delete production requests, and review or delete data processing requests. 

Each procedure outlined has an Activity Checklist  table that provides an overview of the task to 
be completed. The outline of the Activity Checklist is as follows: 

Column one - Order shows the order in which tasks should be accomplished. 

Column two - Role lists the Role/Manager/Operator responsible for performing the task. 

Column three - Task provides a brief explanation of the task. 

Column four - Section provides the Procedure (P) section number or Instruction (I) section 
number where details for performing the task can be found. 

Column five - Complete? is used as a checklist to keep track of which task steps have been 
completed. 

Table 13.2-1 provides an Activity Checklist for activities related to the creation of Production 
Requests and Data Processing Requests. 

Table 13.2-1. Production Requests and Data Processing Requests - Activity 
Checklist 

Order Role Task Section Complete? 

1 Production Planner Launch the Production Request Editor (P) 13.2.1 

2 Production Planner Create a New Production Request (P) 13.2.2 

3 Production Planner Edit/Modify a Production Request (P) 13.2.3 

4 Production Planner Delete a Production Request (P) 13.2.4 

5 Production Planner Display Data Processing Request 
Information 

(P) 13.2.5 

6 Production Planner Delete a Data Processing Request (P) 13.2.6 

7 Production Planner Re-Generate Granules Affected by Loss 
of Files from the Archive 

(P) 13.2.7 

NOTE:	 The procedures that follow are written under the assumption that PGEs have been 
previously created and are available for use with the same rule criteria that you 
are attempting to use. 
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13.2.1 Launch the Production Request Editor 

The Production Request Editor is invoked from a UNIX command line prompt. Table 13.2-2 
presents (in a condensed format) the steps required to launch the Production Request Editor. If 
you are already familiar with the procedures, you may prefer to use this quick-step table. If you 
are new to the system, or have not performed this task recently, you should use the following 
detailed procedures. 

1 At the UNIX command line prompt enter: 

setenv DISPLAY <clientname>:0.0 
a.	 Use either the X terminal/workstation IP address or the machine-name for the 

clientname. 
b.	 When using secure shell, the DISPLAY variable is set just once, before logging in to 

remote hosts. If it were to be reset after logging in to a remote host, the security 
features would be compromised. 

2	 In the terminal window, at the command line prompt, start the log-in to the 
Planning/Management Workstation by entering: 

/tools/bin/ssh <hostname> 
a. Examples of hostnames include e0pls03, g0pls01, or l0pls02. 
b.	 If you receive the message, “Host key not found from the list of known hosts. Are 

you sure you want to continue connecting (yes/no)?” enter yes (“y” alone will not 
work). 

c.	 If you have previously set up a secure shell passphrase and executed sshremote, a 
prompt to Enter passphrase for RSA key '<user@localhost>' appears; continue 
with Step 3. 

d. If you have not previously set up a secure shell passphrase, go to Step 4. 

3 If a prompt to Enter passphrase for RSA key '<user@localhost>' appears, enter: 

<Passphrase> 
a. Go to Step 5. 

4 At the <user@remotehost>’s password: prompt enter: 

<Password> 

5 Start the login to DCE by entering: 

dce_login 

6 At the Enter Principal Name: prompt enter: 

<DCE UserID> 

7 At the Enter Password: prompt enter: then press the Return/Enter key. 

<DCE Password> 
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8 In the terminal window, at the command line, enter: 

cd /usr/ecs/<MODE>/CUSTOM/utilities 
a. <MODE> is current mode of operation. 

1. TS1 - Science Software Integration and Test (SSI&T) 
2. TS2 - New Version Checkout 
3. OPS - Normal Operations 

b. “utilities” is the directory containing the Planning Subsystem start-up scripts. 

9 Set the application environment variables by entering: 

setenv ECS_HOME /usr/ecs/ 
a. Application home environment is entered 
b.	 When logging in as a system user (e.g., cmshared), the ECS_HOME variable may be 

set automatically so it may not be necessary to set it manually. 

10 Start the Production Request Editor by entering: 

EcPlPRE_IFStart <MODE> 
a. The Production Request Editor is launched. 

Table 13.2-2. Launch the Production Request Editor - Quick-Step Procedures 
Step What to Enter or Select Action to Take 

1 Log in to the Planning host using secure shell enter text, press Enter 

2 Log in to DCE enter text, press Enter 

3 Enter cd /usr/ecs/<MODE>/CUSTOM/utilities enter text, press Enter 

4 Set environment variables if necessary enter text, press Enter 

5 Enter EcPlPRE_IFStart <MODE> enter text, press Enter 

13.2.2 Create a New Production Request 

The process of creating a new Production Request begins with the Production Planner starting 
the Production Request Editor GUI. The Production Planner specifies the PGE, duration, and 
comments for the new Production Request. 
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TYPES OF DATA PROCESSING: ECS accommodates four general types of data processing. 

Routine Processing 

Reprocessing 

Ad-Hoc Reprocessing 

On-Demand Processing 

Pre-defined software production processing that is periodic 
and keyed to data arrival. For example, every day a 
Production Planner includes in the daily schedule a DPR 
for generating a particular Level 1A product from the most 
recent Level 0 data from the applicable satellite instrument. 

Typically involves using a new, improved PGE to process 
data that had previously been processed with an older 
version of the PGE. 

Production processing that involves rerunning a PGE to 
process data that had been previously processed. For 
example, if a product fails a quality assurance (QA) check, 
the same PGE could be run again on the same data set in 
the hope of creating an acceptable product. 

Involves ad-hoc processing initiated by an end-user (as 
opposed to the Production Planner). For example, a 
researcher using data from the Advanced Spaceborne 
Thermal Emission and Reflection Radiometer (ASTER) 
instrument on the Terra satellite may need a particular 
Level 2 product that has not yet been generated. The 
ASTER researcher would submit an on-demand request to 
have the product generated from a Level 1B product stored 
in the archive. 

NOTE:	 When reprocessing, it is important to generate DPRs for one chain completely 
before generating any DPRs for the next chain. For example, if PGE1 produces 
Product1 that is input to PGE2 that produces Product2 that is input to PGE3 that 
produces Product3, PRs for PGE1, PGE2, and PGE3 should be created for each of 
those DPRs for Chain1. Then PRs for Chain2 can be created, etc. 

A reprocessing DPR selects the latest version granule in the database as input. 
Consequently, if Product1 from Chain2 were in the database before the DPR for 
Chain1 PGE2 was created, the Chain1 DPR for PGE2 would select the Product1 
from Chain2 as its input and Product1 from Chain1 would not be used. 

PRODUCTION RULES: Production Rules provide templates for Instrument Teams to 
describe the relationship(s) between PGEs and their input and output data. The assumption of 
this documentation is that the user has knowledge of the specific production rules under which 
the PGE was created. Listed below is a sampling of the available production rules. 

Basic Temporal 	 Temporal (time) range of inputs matches the temporal 
range of outputs. 

Advanced Temporal	 Temporal range of inputs is offset from the expected 
temporal range of inputs and outputs. 
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Alternate Inputs 

Optional Inputs 

Min/Max Granules 

Optional DPRs 

Intermittent Activation


Metadata Checks


Metadata Query


Spatial Query/Spatial Pad


Closest Granule


Orbital Processing


PGE is run with different inputs based on the availability of 
various alternate input data sets. 

PGE is run with specified optional inputs if available; 
otherwise, PGE is run without them. 

Minimum number of input granules needed for full data 
coverage and maximum number of input granules to search 
for may be specified. Minimum and maximum number of 
outputs expected from the PGE may be specified. 

The only DPRs executed are those for which the non­
routine key input data actually become available (i.e., are 
either produced in data processing or can be acquired from 
the archive). 

Every nth DPR is activated; all other DPRs are skipped. 

DPR is run only if input data’s metadata value(s) meet(s) 
certain criteria. 

Input granule selection is based on metadata value(s). 

Input granule selection is based on the spatial coverage of 
another input (i.e., the key input). Spatial Pad involves 
adding area to all sides of the key input's spatial shape. All 
granules that intersect the expanded area are retrieved. 

DPR is generated if a required input granule within a 
particular time range (rather than an exact time) is 
available; otherwise, no DPR is generated. 

Selection of input times is based on orbit information. 

Table 13.2-3 presents (in a condensed format) the steps required to create a new production 
request. If you are already familiar with the procedures, you may prefer to use the quick-step 
table. If you are new to the system, or have not performed this task recently, you should use the 
following detailed procedures. 

1 Launch the Production Request Editor (refer to Section 13.2.1). 
a. The Production Request Editor GUI is displayed. 

2 Single-click on the PR Edit tab. 
a. The PR Edit GUI is displayed. 

NOTE:	 If the GUI is unresponsive, always check to see if a prompt window is hidden 
behind the main GUI waiting for a response. Respond to the window, then 
continue with the Production Request Editor GUI. 
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3	 Single-click and hold the PR Type option button to display a menu of types of 
production requests, move the mouse cursor to the desired selection (highlighting it), then 
release the mouse button. 
a.	 Options are: Routine, On-Demand [not currently available for selection], 

Reprocessing, and Ad-hoc Reprocessing. 

4	 Single-click and hold the User Type option button to display a menu of types of users, 
move the mouse cursor to the desired selection (highlighting it), then release the mouse 
button. 
a. Options are: Operator, DAAC Manager, Scientist, and Researcher. 

NOTE:	 The PR Name and Origination Date fields will be filled automatically when the 
Production Request is saved at the end of the procedure. (You do not need to fill 
in these fields.) 

5 In the Originator field either enter the actual name of the originator or enter: 

<username> 

6 In the Priority field enter: 

<Priority> 
a. Enter a number in the range of one (1) to ten (10). 

1. One (1) has the highest priority; ten (10) has the lowest priority. 
b.	 The Priority field specifies the Production Request Editor priority to be included in 

the Data Processing Request(s) that result(s) from the Production Request. 
c.	 Production Request Editor Priority is subsequently weighted according to the 

value specified in the Production Strategy selected from the Planning Workbench 
when a Production Plan is created that uses the Production Request. 

7 Single-click on the PGE... button. 
a. The PGE GUI is displayed. 

8 Select the desired PGE by single-clicking on the PGE. 
a. The desired PGE is highlighted. 

9 Single-click the Ok button. 
a. The PR Edit GUI is displayed. 
b. The following fields are automatically filled: 

1. Satellite Name. 
2. Instrument Name. 
3. PGE Name. 
4. PGE Version. 
5. Profile ID. 

10 Single-click on the PGE Parameters... button. 
a. The PGE Parameters GUI is displayed. 
b. PGE parameter data are displayed in a table that has the following columns: 

1. Parameter Name. 
2. Logical Id. 
3. Default Value. 
4. Override Value. 
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5. Description. 

11	 Select the parameter (if any) with the default value to be changed by single-clicking on 
the Parameter Name row. 
a. The parameter row is highlighted. 
b. Only the default values can be modified. 
c. Modify parameter values when and as directed by the customer (e.g., MODIS) only. 

12	 If a parameter with a default value to be changed has been selected, in the Override 
Value field enter: 

<override value> 

13	 If a parameter with a default value to be changed has been selected, single-click on the 
Apply button at the bottom of the PGE Parameter Mappings window. 
a. The new value is displayed in the Override Value column. 
b. Repeat Steps 11 through 13 to modify additional parameters (if applicable). 

14 Single-click on the Ok button to approve the changes. 
a. The PR Edit GUI is displayed. 

**The procedures that follow involve the implementation of specific 
PRODUCTION RULES.** 

MODIS uses  1) Temporal Rules, to include Basic and Advanced Temporal specifications, 
2) Orbit-Based Activation and 
3) Period/Calendar Specification, 
4) Conditional Activation, 
5) Additional inputs and 
6) DataBase Query. 

ASTER uses both Temporal Rules, Basic and Advanced Temporal specifications. In addition, 
ASTER routine processing makes use of the Optional DPRs Production Rule to schedule 
and execute ASTER PGEs for new data that have been archived. The Production 
Planner specifies the insertion time range (i.e., the time period when the desired data 
were archived) as opposed to the collection time (when the satellite instrument gathered 
the data). 

MISR has primarily “orbit” based PGEs. 

Multiple “production rules” can be combined to complete a PR, however, Temporal- and Orbit­
based rules cannot be combined. 

To execute either a Basic or Advanced Temporal Production Rule, you must complete Steps 1�
14, specified above in 13.2.2. and specify date and time information for processing (Steps 30 and 
31). Then continue processing with Step 34, etc. as necessary. 

METADATA-BASED PRODUCTION RULE 
15	 If the PGE is subject to a metadata-based production rule and the value(s) to be checked 

need(s) to be changed, single-click on the Metadata Checks… button, perform Steps 16 
through 20 as applicable; otherwise go to Step 21. 
a. The MetadataChecks GUI page is displayed. 
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b.	 The MetadataChecks GUI has an InputDataType window that lists the input data 
types for the PGE. 

c.	 In addition, the MetadataChecks GUI has a metadata checks (MetaDataField-
Operator-Value-Type) window in which there is a table that lists the following 
information concerning each metadata check: 
1. MetaDataField. 
2. Operator. 
3. Value. 
4. Type. 

d.	 Initial values for metadata checks are entered during SSI&T; however, it is possible to 
modify the values using the MetadataChecks GUI when creating a production 
request. 
1 . 	 Modify metadata check values when and as directed by the customer (e.g., 

MODIS) only. 

16	 If it is necessary to change any value(s) for metadata checks, select an input data type 
with a value to be changed by single-clicking on the corresponding row in the 
InputDataType window. 
a. The input data type row is highlighted. 
b.	 The metadata check information for the highlighted input data type is displayed in the 

MetaDataField-Operator-Value-Type window. 

17	 Select (highlight) a metadata field with a comparison value to be changed by single­
clicking on the corresponding row in the MetaDataField-Operator-Value-Type 
window. 
a.	 The metadata field row is highlighted in the MetaDataField-Operator-Value-Type 

window. 
b. The identity of the metadata field is displayed in the MetaDataField window. 

18 If it is necessary to change any value(s) for metadata checks, in the Value field enter: 

<value> 

19 Single-click on the appropriate button from the following selections: 
a. OK - to approve the new value and dismiss the MetadataChecks GUI. 

1. The Production Request - PR Edit GUI is displayed. 
2. Go to Step 21. 

b. Apply - to approve the new value without dismissing the MetadataChecks GUI. 
1. Go to Step 20. 

c.	 Cancel - to return to the Production Request - PR Edit GUI without saving the new 
value. 
1. The Production Request - PR Edit GUI is displayed. 
2. Go to Step 21. 

20	 If any additional value(s) to be checked need to be changed, repeat Steps 16 through 19 
as necessary. 

ALTERNATE INPUTS PRODUCTION RULE 
21	 If the PGE is subject to the Alternate Inputs Production Rule and the timer settings or 

the order of alternate inputs need to be changed, single-click on the Alternate Input 
Values… button and perform Steps 22 through 27 as applicable; otherwise go to Step 28. 
a. The AlternateInputValues GUI page is displayed. 
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b.	 The AlternateInputValues GUI has an AlternateListName window that lists the 
applicable alternate inputs. 

c.	 In addition, the AlternateInputValues GUI has an alternate input (Order-
DataType-LogicalID-Timer) window in which there is a table that lists the 
following information concerning each alternate input: 
1. Order. 
2. DataType. 
3. LogicalID. 
4. Timer. 

d.	 The initial set-up for alternate inputs is entered during SSI&T; however, it is possible 
to modify the set-up using the AlternateInputValues GUI when creating a 
production request. 

22	 If it is necessary to change timer settings or the order of alternate inputs, first select 
(highlight) an alternate input to be changed by single-clicking on the corresponding row 
in the AlternateListName window. 
a. The alternate input row is highlighted. 
b.	 Information concerning the highlighted alternate input is displayed in the Order-

DataType-LogicalID-Timer window. 

23	 Select (highlight) an alternate input with timer settings or the order of alternate inputs to 
be changed by single-clicking on the corresponding row in the Order-DataType-
LogicalID-Timer window. 
a.	 Alternate input row is highlighted in the Order-DataType-LogicalID-Timer 

window. 
b. The data type of the alternate input is displayed in the DataType field. 

24	 If it is necessary to change the order of alternate inputs, single-click on the up/down 
arrow buttons adjacent to the Order-DataType-LogicalID-Timer window as necessary 
until the highlighted alternate input has the proper order listed in the Order column of 
the window. 
a. If necessary, repeat Steps 23 and 24 to change the order of additional alternate inputs. 

25	 If the timer setting for an alternate input is to be modified, verify that the alternate input 
with the timer setting to be changed has been highlighted then in the Timer fields enter: 

<hh:mm:ss> 
a.	 Another method of changing timer settings (other than typing the numbers) is to 

single-click in each of the timer fields in turn and click on the up/down buttons 
adjacent to the Timer fields until the correct time is indicated. 

26 Single-click on the appropriate button from the following selections: 
a.	 OK - to approve the new alternate input setting(s) and dismiss the 

AlternateInputValues GUI. 
1. The Production Request - PR Edit GUI is displayed. 
2. Go to Step 28. 

b.	 Apply - to approve the new alternate input setting(s) without dismissing the 
AlternateInputValues GUI. 
1. Go to Step 27. 

c.	 Cancel - to return to the Production Request - PR Edit GUI without saving the new 
alternate input setting(s). 
1. The Production Request - PR Edit GUI is displayed. 
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2. Go to Step 28. 

27	 If any additional alternate input setting(s) need to be changed, repeat Steps 22 through 26 
as necessary. 

ASTER routine processing makes use of the Optional DPRs Production Rule to schedule and 
execute ASTER PGEs for new data that have been archived. The Production Planner 
specifies the insertion time range (i.e., the time period when the desired data were 
archived) as opposed to the collection time (when the satellite instrument gathered the 
data). 
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28	 Single-click on either the Collection Time or Insertion Time button (as applicable) if 
data are to be processed on the basis of time (rather than orbit). 
a.	 Normally the Collection Time (time when the data were collected by the instrument 

on the satellite) is used for specifying what data are to be processed. 
b.	 The Insertion Time option is available primarily for ASTER processing to allow the 

generation of DPRs for all data contained on an ASTER tape received from the 
ASTER Ground Data System (GDS). 

TIME- OR ORBIT-BASED PROCESSING? 
29 Single-click on either the UTC Time (Coordinated Universal Time) button or the Orbit 

button, depending on whether data to be processed is specified by time or orbit. 
a. If UTC Time is selected, go to Step 30. 
b. If Orbit is selected go to Step 32. 

TEMPORAL PRODUCTION RULES 
30 Enter the desired data start date and time in the Begin fields in the following format: 

<MM/DD/YYYY hh:mm:ss> 
a. As data are entered in each field the cursor automatically advances to the next field. 
b.	 Another method of entering date and time (other than typing the numbers) is to 

single-click in each of the date/time fields in turn and click on the up/down buttons 
adjacent to the date/time fields until the correct date/time is indicated. 

31 Enter the desired data end date and time in the End fields in the following format: 

<MM/DD/YYYY hh:mm:ss> 

ORBITAL PROCESSING PRODUCTION RULE 
32 If the Orbital Processing Production Rule applies, in the From field enter: 

<first orbit number> 

33 If the Orbital Processing Production Rule applies, in the To field enter: 

<last orbit number> 

INTERMITTENT ACTIVATION PRODUCTION RULE 
34 If the Intermittent Activation Production Rule applies, in the Skip field enter: 

<number of DPRs> 
a. If the Intermittent Activation Production Rule applies, perform Steps 35 and 36. 
b. If the Intermittent Activation Production Rule does not apply, go to Step 37. 

35 If the Intermittent Activation Production Rule applies, in the Keep field enter: 

<number of DPRs> 

36 If the first DPR is to be skipped, single-click on the SkipFirst button. 

37 If applicable, in the Comments field enter: 

<comments> 
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1

2

3

4

5

6

7

8

9

10

38	 Start the process of saving the production request and generating DPRs by executing the 
following menu path: 

File → Save As 
a. The File Selection window is displayed. 

39 In the Selection field enter: 

<PR name> 

40 Single-click on the OK button to save the production request. 
a. Eventually a Production Request Explosion into DPRs dialogue box is displayed. 

1. It may take several minutes or even hours for the process to complete. 
2 . 	If the explosion into DPRs is successful, the production request and 

corresponding DPR(s) are saved in the PDPS database and the Production 
Request PR Name and Origination Date fields are automatically updated. 

3.	 If the explosion into DPRs is not successful, the dialogue box contains a message 
to that effect and it will be necessary to troubleshoot the problem. 

41	 Single-click on the OK button to dismiss the Production Request Explosion into DPRs 
dialogue box. 
a. The dialogue box is dismissed. 

42	 To clear the entries on the Production Request Editor GUI execute the following menu 
path: 

File → New 
a. Return to Step 3 to create another new PR. 

43 To exit the Production Request Editor execute the following menu path: 

File → Exit 

Table 13.2-3. Create a New Production Request - Quick-Step Procedures (1 of 3) 
Step What to Enter or Select Action to Take 

Launch Production Request Editor GUI Use procedure in Section 13.2.1 

Select PR Edit tab single-click 

Select <PR type> from the PR Type: button single-click 

Select <user type> from the User Type: button single-click 

Enter <originator> in the Originator: field press Tab 

Enter <priority> in the Priority: field press Tab 

Select PGE... button single-click 

Select <PGE> from the PGE Selection list single-click 

Select OK single-click 

If changing PGE parameters, select PGE 
Parameters... button 

single-click 
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Table 13.2-3. Create a New Production Request - Quick-Step Procedures (2 of 3) 
Step What to Enter or Select Action to Take 

11 If changing PGE parameters, select <parameter> 
from the PGE Parameter Mappings list 

single-click 

12 If changing the PGE parameters, enter <override 
value> in the Override Value field 

enter text 

13 If changing PGE parameters, select OK single-click 

14 If changing metadata value(s), select Metadata 
Checks… button 

single-click 

15 If changing metadata value(s), select <input data 
type> from the InputDataType list 

single-click 

16 If changing metadata value(s), select <metadata 
field> from the MetaDataField-Operator-Value-
Type list 

single-click 

17 If changing metadata value(s), enter <value> in 
the Value field 

enter text 

18 If changing metadata value(s), select OK single-click 

19 If changing alternate input timer settings or the 
order of inputs, select Alternate Input Values… 
button 

single-click 

20 If changing alternate input timer settings or the 
order of inputs, select <alternate input> from 
AlternateListName list 

single-click 

21 If changing alternate input timer settings or the 
order of inputs, select <alternate input> from 
Order-DataType-LogicalID-Timer list 

single-click 

22 If changing the order of alternate inputs, reorder 
inputs in Order-DataType-LogicalID-Timer list 
using up/down arrows 

single-click 

23 If changing alternate input timer settings, enter 
<hh:mm:ss> in Timer fields 

enter text 

24 If changing alternate input timer settings or the 
order of inputs, select OK 

single-click 

25 Select either Collection Time or Insertion Time 
(as applicable) 

single-click 

26 Select either UTC Time or Orbit (as applicable) single-click 

27 Enter <MM/DD/YYYY hh:mm:ss> in the Begin 
fields (if applicable) 

enter text, press Tab 

28 Enter the <MM/DD/YYYY hh:mm:ss> in the End 
fields (if applicable) 

enter text, press Tab 

29 Enter the < first orbit number>  in the From field 
(if applicable) 

enter text 

30 Enter < last orbit number>  in the To field (if 
applicable) 

enter text 
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Table 13.2-3. Create a New Production Request - Quick-Step Procedures (3 of 3) 
Step What to Enter or Select Action to Take 

31 Enter <number of DPRs> in the Skip field (if 
applicable) 

enter number 

32 Enter <number of DPRs> in the Keep field (if 
applicable) 

enter number 

33 Select SkipFirst (if applicable) single-click 

34 Enter <comment> in the Comment field (if 
applicable) 

enter text 

35 Execute File → Save As single-click 

36 Enter <PR name> in the Selection field enter text 

37 Select Ok single-click 

38 Select Ok single-click 

13.2.3 Edit/Modify a Production Request 

Edits or modifications to a previously created production request result in a new production 
request. The new production request must be saved with a new name. 

Table 13.2-4 presents (in a condensed format) the steps required to edit/modify a production 
request. If you are already familiar with the procedures, you may prefer to use this quick-step 
table. If you are new to the system, or have not performed this task recently, you should use the 
following detailed procedures. 

1 Launch the Production Request Editor by performing procedure 13.2.1. 
a. The Production Request Editor GUI is displayed. 

2 Single-click on the PR Edit tab. 
a. The PR Edit GUI is displayed. 

3	 To display a list of Production Requests from which to select the PR to be opened 
execute the following menu path: 

File → Open 
a. A list of Production Requests is displayed in the File Selection window. 

4	 Select (highlight) the PR to be edited/modified by single-clicking on the corresponding 
PR name in the list of PRs. 

5 Single-click on the OK button. 
a. The PR information appears in the PR Edit GUI. 

NOTE:	 Perform only those steps of the procedure that are applicable to the changes you 
want to make. You do not have to go through all of the fields in the PR to 
successfully modify it. However, you must save the modified PR to make the 
changes effective. 
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6	 To change the type of production request select the desired PR Type from the option 
button by single-clicking and holding, moving the mouse cursor to the desired selection 
(highlighting it), then releasing the mouse button. 

7	 To change the user type select the desired User Type from the option button by single­
clicking and holding, moving the mouse cursor to the desired selection (highlighting it), 
then releasing the mouse button. 

8	 To change the originator in the Originator field either enter the actual name of the 
originator or enter: 

<username> 

9 To change the Production Request Editor Priority in the Priority: field enter: 

<Priority> 

10 If changing the PGE, single-click on the PGE... button. 
a. The PGE GUI is displayed. 

11 If changing the PGE, select the desired PGE by single-clicking on the PGE. 

12 If changing the PGE, single-click the Ok button. 

13 To change PGE parameters first single-click on the PGE Parameters... button. 
a. The PGE Parameters GUI displays. 

14	 When changing PGE parameters, select a parameter to be modified by single-clicking on 
the Parameter Name row. 
a. The parameter row is highlighted. 

15 When changing PGE parameters, in the Override Value field enter: 

<override value> 
a. Some PGEs may NOT have modifiable parameters. 

16	 When changing PGE parameters, single-click on the Apply button at the bottom of the 
PGE Parameter Mappings window. 

17 When changing PGE parameters, single-click on the Ok button to approve the changes. 
a. The Production Request Editor GUI is displayed. 

18	 If the PGE is subject to a metadata-based production rule and the value(s) to be checked 
need(s) to be changed, single-click on the Metadata Checks… button. 

19	 If it is necessary to change any value(s) for metadata checks, select an input data type 
with a value to be changed by single-clicking on the corresponding row in the 
InputDataType window. 

20	 If it is necessary to change any value(s) for metadata checks, select (highlight) a metadata 
field with a comparison value to be changed by single-clicking on the corresponding row 
in the MetaDataField-Operator-Value-Type window. 
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21 If it is necessary to change any value(s) for metadata checks, in the Value field enter: 

<value> 

22	 If it is necessary to change any value(s) for metadata checks, single-click on the 
appropriate button from the following selections: 
a. OK - to approve the new value and dismiss the MetadataChecks GUI. 
b. Apply - to approve the new value without dismissing the MetadataChecks GUI. 
c.	 Cancel - to return to the Production Request - PR Edit GUI without saving the new 

value. 

23	 If the PGE is subject to the Alternate Inputs Production Rule and the timer settings or 
the order of alternate inputs need to be changed, single-click on the Alternate Input 
Values… button. 

24	 If it is necessary to change timer settings or the order of alternate inputs, first select 
(highlight) an alternate input to be changed by single-clicking on the corresponding row 
in the AlternateListName window. 

25	 If it is necessary to change timer settings or the order of alternate inputs, select (highlight) 
an alternate input with timer settings or the order of alternate inputs to be changed by 
single-clicking on the corresponding row in the Order-DataType-LogicalID-Timer 
window. 
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26	 If it is necessary to change the order of alternate inputs, single-click on the up/down 
arrow buttons adjacent to the Order-DataType-LogicalID-Timer window as necessary 
until the highlighted alternate input has the proper order listed in the Order column of 
the window. 

27	 If the timer setting for an alternate input is to be modified, verify that the alternate input 
with the timer setting to be changed has been highlighted then in the Timer fields enter: 

<hh:mm:ss> 

28	 If it is necessary to change timer settings or the order of alternate inputs, single-click on 
the appropriate button from the following selections: 
a.	 OK - to approve the new alternate input setting(s) and dismiss the 

AlternateInputValues GUI. 
b.	 Apply - to approve the new alternate input setting(s) without dismissing the 

AlternateInputValues GUI. 
c.	 Cancel - to return to the Production Request - PR Edit GUI without saving the new 

alternate input setting(s). 

29	 If data are to be processed on the basis of time (rather than orbit), single-click on either 
the Collection Time or Insertion Time button (as applicable). 

30	 Single-click on either the UTC Time (Coordinated Universal Time) button or the Orbit 
button, depending on whether data to be processed is specified by time or orbit. 

31	 If data are to be processed on the basis of time and the data start time is to be modified, 
enter the desired data start date and time in the Begin fields in the following format: 

<MM/DD/YYYY hh:mm:ss> 

32	 If data are to be processed on the basis of time and the data end time is to be modified, 
enter the desired data end date and time in the End fields in the following format: 

<MM/DD/YYYY hh:mm:ss> 

33	 If the Orbital Processing Production Rule applies and the first orbit of data is to be 
modified, in the From field enter: 

<first orbit number> 

34	 If the Orbital Processing Production Rule applies and the last orbit of data is to be 
modified, in the To field enter: 

<last orbit number> 
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35	 If the Intermittent Activation Production Rule applies and the number of DPRs to skip is 
to be modified, in the Skip field enter: 

<number of DPRs> 

36	 If the Intermittent Activation Production Rule applies and the number of DPRs to keep is 
to be modified, in the Keep field enter: 

<number of DPRs> 

37	 If the Intermittent Activation Production Rule applies and the first DPR is to be skipped, 
verify that the SkipFirst button has been activated (single-click on the button if 
necessary). 

38 If applicable, in the Comments field enter: 

<comments> 

39 To save the modified production request execute the following menu path: 

File →  Save As 
a. File Selection Window appears. 

40 In the Selection field enter: 

<PR name> 
a. Production Request is named. 
b. Name must be changed. 

41 Single-click on the Ok button. 
a. Eventually a Production Request Explosion into DPRs dialogue box is displayed. 

42	 Single-click on the OK button to dismiss the Production Request Explosion into DPRs 
dialogue box. 
a. The dialogue box is dismissed. 

Table 13.2-4. Edit/Modify a Production Request - Quick-Step Procedures (1 of 3) 
Step What to Enter or Select Action to Take 

1 Launch Production Request Editor Use procedure in Section 13.2.1 

2 Select PR Edit single-click 

3 Execute File → Open single-click 

4 Select <PR name> from the Production 
Requests: list 

single-click 

5 Select OK single-click 
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Table 13.2-4. Edit/Modify a Production Request - Quick-Step Procedures (2 of 3) 
Step What to Enter or Select Action to Take 

6 Modify the <PR type> from the PR Type: button 
(if applicable) 

single-click 

7 Modify the <user type> from the User Type: 
button (if applicable) 

single-click 

8 Modify the <originator> in the Originator: field 
(if applicable) 

enter text 

9 Modify the <priority> in the Priority: field (if 
applicable) 

enter number 

10 If changing the PGE, select PGE... button single-click 

11 If changing the PGE, select <PGE> from the PGE 
Selection list 

single-click 

12 If changing the PGE, select OK single-click 

13 If changing PGE parameters, select PGE 
Parameters... button 

single-click 

14 If changing PGE parameter values, select 
<parameter> from the PGE Parameter 
Mappings list 

single-click 

15 If changing PGE parameter values, enter 
<override value> in the Override Value field 

enter text 

16 If changing PGE parameter values, select OK single-click 

17 If changing metadata value(s), select Metadata 
Checks… button 

single-click 

18 If changing metadata value(s), select <input data 
type> from the InputDataType list 

single-click 

19 If changing metadata value(s), select <metadata 
field> from the MetaDataField-Operator-Value-
Type list 

single-click 

20 If changing metadata value(s), enter <value> in 
the Value field 

enter text 

21 If changing metadata value(s), select OK single-click 

22 If changing alternate input timer settings or the 
order of inputs, select Alternate Input Values… 
button 

single-click 

23 If changing alternate input timer settings or the 
order of inputs, select <alternate input> from 
AlternateListName list 

single-click 

24 If changing alternate input timer settings or the 
order of inputs, select <alternate input> from 
Order-DataType-LogicalID-Timer list 

single-click 

25 If changing the order of alternate inputs, reorder 
inputs in Order-DataType-LogicalID-Timer list 
using up/down arrows 

single-click 
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Table 13.2-4. Edit/Modify a Production Request - Quick-Step Procedures (3 of 3) 
Step What to Enter or Select Action to Take 

26 If changing alternate input timer settings, enter 
<hh:mm:ss> in Timer fields 

enter text 

27 If changing alternate input timer settings or the 
order of inputs, select OK 

single-click 

28 Select either Collection Time or Insertion Time 
(as applicable) 

single-click 

29 Select either UTC Time or Orbit (as applicable) single-click 

30 Enter <MM/DD/YYYY hh:mm:ss> in the Begin 
fields (if applicable) 

enter text, press Tab 

31 Enter the <MM/DD/YYYY hh:mm:ss> in the End 
fields (if applicable) 

enter text, press Tab 

32 Enter the < first orbit number> in the From field 
(if applicable) 

enter number 

33 Enter < last orbit number> in the To field (if 
applicable) 

enter number 

34 Enter <number of DPRs> in the Skip field (if 
applicable) 

enter number 

35 Enter <number of DPRs> in the Keep field (if 
applicable) 

enter number 

36 Select SkipFirst (if applicable) single-click 

37 Modify <comment> in the Comment field (if 
applicable) 

enter text 

38 Execute File → Save As single-click 

39 Enter <PR name> in the Selection field enter text 

40 Select Ok single-click 

41 Select Ok single-click 

13.2.4 Delete a Production Request 

Production Requests can be deleted if necessary. Table 13.2-5 presents (in a condensed format) 
the steps required to delete Production Requests. If you are already familiar with the procedures, 
you may prefer to use this quick-step table. If you are new to the system, or have not performed 
this task recently, you should use the following detailed procedures. 

1 Launch the Production Request Editor (refer to Section 13.2.1). 
a. The Production Request Editor GUI is displayed. 

2 Single-click on the PR List tab. 
a. The PR List GUI is presented. 
b. A list of Production Requests is displayed. 
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3 Single-click on the Production Request to be deleted. 
a. The Production Request to be deleted is highlighted. 

4 Execute the following menu path: 

Edit→ Delete 
a.	 A dialogue box is displayed requesting confirmation of the decision to delete the 

Production Request. 

5 Single-click on the OK button to delete the Production Request. 
a.	 If there are no dependencies among Production Requests, a confirmation dialogue 

box is displayed. 
b.	 If there are dependencies among Production Requests, a “List Of Orphan DPRs” 

dialogue box is displayed. 

6 Single-click on the appropriate button from the following selections: 
a. OK - to confirm deletion of the Production Request(s) and dismiss the dialogue box. 

1. A “deletion completed” dialogue box is displayed. 
2. The Production Request(s) is/are deleted. 

b. Cancel - to preserve the Production Request(s) and dismiss the dialogue box. 
1. The dialogue box is dismissed. 
2. The Production Request(s) is/are not deleted. 

7 Single-click on OK to dismiss the “deletion completed” dialogue box. 
a. The “deletion completed” dialogue box is dismissed. 

8	 To start the process of exiting from the Production Request Editor GUI execute the 
following menu path: 

File → Exit 
a. A Do you really want to exit? dialogue box is displayed. 

9 Single-click on the appropriate button from the following selections: 
a. OK - to exit from the Production Request Editor GUI. 

1. The Production Request Editor GUI is dismissed. 
b. Cancel - to return to the Production Request Editor GUI. 

Table 13.2-5. Delete a Production Request - Quick-Step Procedures (1 of 2) 
Step What to Enter or Select Action to Take 

1 Launch Production Request Editor Use procedure in Section 13.2.1 

2 Select PR List tab single-click 

3 Select <PR name> from the Production 
Requests list 

single-click 

4 Execute Edit→ Delete single-click 
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Table 13.2-5. Delete a Production Request - Quick-Step Procedures (2 of 2) 
Step What to Enter or Select Action to Take 

5 Select OK single-click 

6 Select OK single-click 

7 Select OK single-click 

13.2.5 Display Data Processing Request Information 

The process of displaying Data Processing Request information begins with the Production 
Planner launching the Production Request Editor. The Production Planner can review DPRs 
associated with a specific PR. The Production Planner can review such DPR values as input 
granule(s), output granule(s), predicted and actual start times, data start time, status, and priority. 

Table 13.2-6 presents (in a condensed format) the steps required to display and review DPRs. If 
you are already familiar with the procedures, you may prefer to use this quick-step table. If you 
are new to the system, or have not performed this task recently, you should use the following 
detailed procedures. 

1 Launch the Production Request Editor (refer to Section 13.2.1). 
a. The Production Request Editor GUI is displayed. 

2 Single-click on the DPR List tab. 
a. The DPR List GUI is presented. 

3 Single-click on the Production Request pull-down arrow. 
a. A list of Processing Requests is displayed. 

4 Single-click on the Production Request for which a DPR listing is desired. 
a. The Production Request is entered into the Production Request field. 

5 Single-click on the Filter button. 
a. The list of DPRs associated with the selected Production Request is displayed. 

6 Single-click the DPR View tab. 
a. The DPR View GUI is displayed. 

7 Execute the following menu path: 

File → Open 
a. The File Selection GUI is displayed. 

8 Single-click on the desired DPR from list. 
a. DPR appears in the Selection field. 
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9 Single-click on the OK button. 
a. The DPR information is displayed on the DPR View GUI.

b. The DPR ID is a modification of the original PGE name.


10 Review Data Processing Request Identification information displayed. 
a. DPR Name.�
b. PR Name.�
c. Origination Date.�
d. Originator.�
e. PGE ID.�
f. Data Start Time.�
g. Data Stop Time.�

11 Single-click on the PGE Parameters... button. 
a. The PGE Parameter Mappings GUI displays.


12 Review the PGE Parameter Mappings information displayed. 
a. PGE parameter data are displayed in a table that has the following columns:


1. Parameter Name.�
2. Logical Id.�
3. Default Value.�
4. Override Value.�
5. Description.�

13 Single-click on the Ok button. 
a. The PGE Parameter Mappings GUI is dismissed.

b. The DPR View GUI is displayed.


14 Single-click on the PGE File Mappings... button. 
a. The UR File Mappings GUI is displayed.


15 Review the Universal Reference (UR) File Mappings information displayed. 
a. Input Data.�

1. Logical Id.�
2. Granule Id.�
3. Start Time(UTC)  (date and time).

4. Stop Time (UTC) (date and time).

5. Availability (date and time).

6. UR (granule universal reference).


b. Output Data (Displays the same data as shown for Input Data).


16 Single-click on the Ok button. 
a. The UR File Mappings GUI is dismissed.

b. The DPR View GUI is displayed.


17 Review the DPR Status information displayed. 
a. Predicted Start Time (date and time).

b. Actual Start Time (date and time).

c. Priority.�
d. Status.�
e.	 Predicted and Actual Start Times and Status are not displayed if the Production


Request has not been scheduled.
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18 Repeat steps 2 through 17 to review multiple DPRs associated with multiple PRs. 

19	 To start the process of exiting from the Production Request Editor GUI execute the 
following menu path: 

File → Exit 
a. A Do you really want to exit? dialogue box is displayed. 

20 Single-click on the appropriate button from the following selections: 
a. OK - to exit from the Production Request Editor GUI. 

1. The Production Request Editor GUI is dismissed. 
b. Cancel - to return to the Production Request Editor GUI. 

Table 13.2-6. Display Data Processing Request Information -
Quick-Step Procedures 

Step What to Enter or Select Action to Take 

1 Launch Production Request Editor Use procedure in Section 13.2.1 

2 Select DPR List tab single-click 

3 Select <PR name> from the Production 
Request option list 

single-click 

4 Select Filter single-click 

5 Select <DPR ID> from the Data Processing 
Requests list 

single-click 

6 Select DPR View tab single-click 

7 Execute File → Open single-click 

8 Select <DPR ID> from the Data Processing 
Requests list 

single-click 

9 Select Ok single-click 

10 Review DPR information read text 

11 Select PGE Parameters... button single-click 

12 Review PGE parameters read text 

13 Select OK single-click 

14 Select PGE File Mappings... button single-click 

15 Review input and output granule information read text 

16 Select OK single-click 

17 Repeat Steps 2 through 16 to review additional 
DPRs 

13.2.6 Delete a Data Processing Request 

DPRs can be deleted manually if necessary. Table 13.2-7 presents (in a condensed format) the 
steps required to delete DPRs. If you are already familiar with the procedures, you may prefer to 
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use this quick-step table. If you are new to the system, or have not performed this task recently, 
you should use the following detailed procedures. 

1 Launch the Production Request Editor (refer to Section 13.2.1). 
a. The Production Request Editor GUI is displayed. 

2 Single-click on the DPR List tab. 
a. The DPR List GUI is presented. 

3 Single-click on the Production Request pull-down arrow. 
a. A list of Production Requests is displayed. 

4 Single-click on the Production Request for which a DPR listing is desired. 
a. The Production Request is entered into the Production Request field. 

5 Single-click on the Filter button. 
a. A list of the DPRs associated with the Production Request is displayed. 

6 Single-click on the DPR to be deleted. 
a. The DPR to be deleted is highlighted. 

7 Execute the following menu path: 

Edit→ Delete 
a.	 A DPR deletion confirmation dialogue box is displayed requesting confirmation of 

the decision to delete the DPR. 

8 Click on the appropriate button from the following selections: 
a. OK - to confirm deletion of the DPR and dismiss the dialogue box. 

1. A deletion dialogue box is displayed. 
2. The DPR is deleted. 
3. If the DPR was the only DPR in the Production Request, the PR is deleted too. 

b. Cancel - to preserve the DPR and dismiss the dialogue box. 
1. The deletion confirmation dialogue box is dismissed. 
2. The DPR is not deleted. 

9 Select OK to dismiss the dialogue box. 
a. The dialogue box is dismissed. 

10	 To start the process of exiting from the Production Request Editor GUI execute the 
following menu path: 

File → Exit 
a. A Do you really want to exit? dialogue box is displayed. 

11 Single-click on the appropriate button from the following selections: 
a. OK - to exit from the Production Request Editor GUI. 

1. The Production Request Editor GUI is dismissed. 
b. Cancel - to return to the Production Request Editor GUI. 
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Table 13.2-7. Delete a Data Processing Request - Quick-Step Procedures 
Step What to Enter or Select Action to Take 

1 Launch Production Request Editor Use procedure in Section 13.2.1 

2 Select DPR List tab single-click 

3 Select <PR name> from the Production 
Request option list 

single-click 

4 Select Filter single-click 

5 Select <DPR ID> (DPR to be deleted) from the 
Data Processing Requests list 

single-click 

6 Execute Edit → Delete single-click 

7 Select OK single-click 

8 Select OK single-click 

13.2.7 Re-Generate Granules Affected by Loss of Files from the Archive 

The entry point for this procedure is the “Data Recovery Process” in Chapter 17, including 
(especially) the “Data Recovery Procedure for Known Files” and “SDSRV Retrieval of Granule 
Production History Metadata” sections. 

The role of this procedure is to initiate production of replacements for granules previously 
generated within this DAAC but now lost due to failure in the ECS Archive. In order to achieve 
this, Production Requests (PRs) for the generation of the replacement granules must be created, 
entered into a Production Plan, and activated. 

The PRs are created using the Production Request Editor (PRE). However, first the necessary 
parameters of the PRs must be retrieved from the Production History file (PH) of the lost 
granule. The PH file is itself acquired by use of the QA Monitor tool and, though the PH UR is 
supplied in the input to this process, this can be achieved only by first using the QA Monitor tool 
to search the SDSRV database for granules matching the lost granule. Hence, this process 
commences with use in the QA Monitor GUI of the attributes of each lost granule (shortname, 
versionID etc.) supplied in the input to this procedure. Refer to Chapter 17 for further 
information on the wider context of this procedure. 

The input to this procedure is the “Granules for PDPS Re-Generation” list. This is a list of 
granules and associated metadata generated by the procedure “SDSRV Retrieval of Granule 
Production History Metadata” (refer to Chapter 17). While the list can be obtained electronically, 
its use in this procedure is line-by-line. However, if available electronically, entries from it can 
be ‘cut and pasted’ into the input fields of the QA monitor GUI to avoid typing errors. 

The outputs of the procedure are as follows: 
a. Granule re-generation Production Requests entered into a production plan. 
b.	 The “PDPS Residual Granules List” which is a list of Granules which this PDPS can 

not re-generate or which it has been decided do not justify re-generation. This list is 
returned to the process in Chapter 17. 

Note that the following assumptions apply to the application of this procedure: 
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a.	 The Science Data Server (SDSRV) will provide a list of granules to be regenerated 
(“Granules for PDPS Re-Generation”). This list will contain information about the 
granules to be regenerated and a Universal Reference (UR) for the associated 
Production History tar file. 

b.	 When reproducing lost granules, all outputs of the PGE, not just those equivalent to 
the lost granule(s), will be produced and archived. 

c.	 It cannot be guaranteed that the PGE re-run will use the same inputs as were used 
during its original execution due to the variability of: Optional/Alternate inputs, Ad 
Hoc Reprocessing, Metadata Checks, Metadata Query and other Production Rules. 

d.	 It is possible that at the time of the original run of PGE, certain optional/alternate 
inputs were not available, which became available later. During the re-run of the 
PGE use of those additional or other optional inputs cannot be avoided. However, it 
can be assumed that an equivalent or better product than the original will be produced 
as a result. 

e.	 PDPS maintains a minimal amount of granule level versioning. By design, only the 
latest version of the granule will be used. If the PGE which is to be re-run uses inputs 
which have more than one granule level version, PDPS will use only the latest 
version of those inputs. However, if references to those granules have been deleted 
from the PDPS database (a delete script, which runs periodically, cleans up unused 
database entries), then PDPS will choose the first one returned from SDSRV. 
SDSRV does not guarantee any sort of ordering in this case but PDPS will select the 
latest granule from those returned (Note: depends on fix to NCR ECSed16326). 

f.	 At Production Request time, the default values for metadata checks can be 
overridden. The new values used are stored in the PDPS database but not in the 
Production History. If, at the time of re-run of the PGE, the references to that PGE 
have been deleted from PDPS database, the default metadata checks will be used. It 
is possible, therefore, that these default values will cause this DPR not to be run in 
this instance; e.g. if the metadata checks had been changed in the original run to be 
less restrictive. If these types of changes to metadata checks are required in order to 
get DPRs to run, then it is assumed that these defaults are saved as part of the PGE 
profile. 

g.	 In a manner that is similar to Metadata Checks, a Metadata Query specifies a query to 
be used to determine the input granules to be used for a DPR. For reasons of 
production timing or updated QA values, a product reproduced at a later date could 
have different granules used as input. Again, it can be assumed that in this case a 
better product will result. 

h.	 Other production rules (e.g., spatial query) could make it impossible to reproduce 
identical granules. 

i.	 If a PGE (PGE name, version and profile) has to support lost granules regeneration, 
then that PGE should not be deleted from the PDPS database. This means, in the 
SSIT Operational Metadata GUI, the delete flag for that PGE should not be checked. 

Table 13.2-8 presents (in a condensed format) the steps required to re-generate granules affected 
by loss of files from the archive. If you are already familiar with the procedures, you may prefer 
to use this quick-step table. If you are new to the system, or have not performed this task 
recently, you should use the following detailed procedures. 

1	 Determine whether all the granules in the input list “Granules for PDPS Re-Generation” 
should be reproduced. 
a.	 It is possible that some granules need not be reproduced, e.g. because a newer version 

of that product is available. 
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b.	 Granules that need not be reproduced should be added to the “PDPS Residual 
Granules” list. Also, at any time during this process, if it is determined that some 
granules cannot be regenerated or need not be regenerated, then those granules should 
be included in the "PDPS Residual Granules” list. 

2	 Retrieve (using the QA Monitor GUI) the Production History tar file from the archive for 
each granule in the “Granules for PDPS Re-Generation” list that needs to be reproduced. 
a. Procedures for using the QA Monitor GUI are presented in Chapter 15. 
b.	 Use the lost granule’s datatype, and “begin date” and “end date” values that 

encompass its RangeBeginningDateTime and RangeEndingDateTime. Note that the 
GUI interprets the dates in UTC format. 

c.	 For each granule that meets the query conditions and is displayed on the QA Monitor 
GUI, the granule’s UR, its Production History tar file’s UR, and the name of the 
Production History tar file are shown. For only one of the granules will the URs 
(both the granule UR and the Production History UR) match the URs for this granule 
in the input list. 
1.	 If the Query failed or did not return any hit that matched, add the granule to 

“PDPS Residual Granules” list. 
d. Retrieve the matching granule. 

1.	 The Production History tar file will be acquired to a directory that is configurable 
(the name of the configuration parameter is DpPrQA_DATA_DIR, and the 
default value for this parameter is $ECS_HOME/<MODE>/CUSTOM/data/DPS). 

2.	 The name of the tar file is the one that appears under the column Production 
History File Name on the QA Monitor GUI. 

e.	 Note that if more than one granule in the input list maps to the same Production 
History tar file, then the Production History tar file need not be retrieved multiple 
times. 

f.	 The Production History tar file contains the Process Control File (PCF) which has all 
the information needed to re-run the PGE. The following particulars have to be 
extracted from the PCF: 
1. PGE Name. 
2. PGE Version. 
3. PGE Profile ID. 
4. DPR Start time. 
5. DPR Stop time. 
6. PGE runtime parameters and their associated values. 

g. Identification of information in the PCF: 
1.	 The PGE Name, PGE Version, and the PGE Profile appear in the System Runtime 

Parameters section of the PCF. They are concatenated (with a # sign to separate 
them) and appear in the place reserved for “Software ID”. 

2.	 DPR Start time appears in the User Defined Parameter Section of the PCF under 
the logical ID 10258. 

3.	 DPR Stop time also appears in the User Defined Parameter Section of the PCF 
under logical ID 10259. 

4.	 All other logical IDs in the User Defined Parameter Section of the PCF form the 
run time parameters and their associated values. Note the logical ID and its 
corresponding values. 

5. An automated script could be written to extract the values from the PCF. 

3	 If the PGE name, version and profile that is extracted from the PCF does not appear as an 
Existing/New PGE, then add the granule that is to be regenerated to the “PDPS Residual 
Granules” list. 
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4	 From the SSIT host, launch the SSIT Manager GUI and invoke the PDPS Operational 
Metadata GUI. 
a. Procedures for using SSI&T tools are presented in Chapter 11. 

5	 If the PGE is not registered, register the PGE using the PDPS Science Update Metadata 
Update from the SSIT Manager GUI. 
a. The PGE must be registered before a production request can be entered. 

6	 If it is decided not to re-register the PGE, add the granule that is to be regenerated to the 
“PDPS Residual Granules” list. 

7	 From the Planning Workstation, launch the Production Request Editor GUI as 
described in Section 13.2.1. 

8	 Enter a Production Request (as described in Section 13.2.2) for the relevant 
PGE/version/profile ID. 
a. Use Ad-Hoc Reprocessing for the Processing Type. 
b.	 Use the DPR Start and Stop Time listed in the Production History for the Begin and 

End times. 
c.	 View the default PGE runtime parameters and compare them against the runtime 

parameters obtained from the Production History tar file. 
1.	 Modify the runtime parameter values to match exactly what was used in the 

original run. 
d.	 If granules that need to be regenerated are produced by PGEs that are chained, then 

the production requests must be entered in that order. 
1.	 For instance, if granules A and B are to regenerated, and PGEs P1 & P2 produce 

them and if P1 & P2 are chained (P2 takes P1’s outputs as its inputs) then the 
production request for P1 must be entered before entering one for P2. 

9	 Launch the Planning Workbench from the Planning Workstation as described in 
Section 13.3.1. 

10	 Create and activate a production plan that includes the newly created production 
request(s) as described in Section 13.3.2. 

11	 Return the output (“PDPS Residual Granules”) list to the “Data Recovery Procedure for 
Known Files” procedure in Chapter 17 for further processing. 
a.	 Those granules which were not re-generated by this process are listed in the output 

(“PDPS Residual Granules”) list. 

Table 13.2-8. Re-Generate Granules Affected by Loss of Files from the Archive -
Quick-Step Procedures (1 of 2) 

Step What to Enter or Select Action to Take 

1 Identify granules to be reproduced read text 

2 Add not-to-be-reproduced granules to the "PDPS 
Residual Granules "List 

enter text 
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Table 13.2-8. Re-Generate Granules Affected by Loss of Files from the Archive -
Quick-Step Procedures (2 of 2) 

Step What to Enter or Select Action to Take 

3 Retrieve Production History tar file for each 
element to be reproduced using the QA Monitor 
GUI 

Use QA Monitor procedures (Chapter 15) 

4 Obtain URs from the QA Monitor GUI Use QA Monitor procedures (Chapter 15) 

5 Extract PGE parameters from the Process 
Control File 

Use QA Monitor procedures (Chapter 15) 

6 Launch the PDPS Operational Metadata GUI 
from the SSIT Manager GUI if the applicable 
PGE is not registered 

Use SSIT procedure for launching the PDPS 
Operational Metadata GUI (Chapter 11) 

7 Register the PGE Use SSIT procedure for registering PGEs 
(Chapter 11) 

8 Launch the Production Request Editor GUI Use procedure in Section 13.2.1 

9 Enter the Production Request for Ad Hoc 
Reprocessing 

Use procedure in Section 13.2.2 

10 Launch the Planning Workbench Use procedure in Section 13.3.1 

11 Create and activate a plan for the newly created 
Production Request 

Use procedure in Section 13.3.2 

12 Return the output (“PDPS Residual Granules”) list 
to the “Data Recovery Procedure for Known 
Files” procedure (Chapter 17) 

13.3Creating Production Strategies 

A Production Strategy is a high-level set of priorities by which the Production Planner defines 
the rules for priorities and preferences in the processing of DPRs. The Production Planner uses 
the Production Strategies GUI to prepare Production Strategies. 

Production Strategies work on two levels. First, the Production Planner can update lists of DPR 
attributes so that each value an attribute can have is tied to a particular priority. For example, the 
DPR attribute “PR Type” has three values that may have their default priority of (e.g., 2) 
changed as follows (on a scale of 1 to 10): 

a. Routine 6 
b. On-Demand 10 
c. Reprocessing 4 

Next, the Production Planner can change the weight that each attribute's priority is given. For 
example, weights (from 1 to 100) might be assigned to the DPR attributes as follows: 

a. PR Type 45 
b. User Type 15 
c. PGE Type 20 

A weight is also given to the priority specified when the Production Planner created the 
Production Request as shown in the following example: 

a. Production Request Editor 20 
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The total weights assigned to PR Type, User Type, PGE Type and Production Request Editor 
[Priority] must equal 100. 

The values included in the selected strategy are read by the Planning Workbench when 
prioritizing the DPRs in a production plan. 

Finally, there is a Late Start Delta that can be used to increase the priority of all jobs that have 
been waiting in the Production Queue for more than a day. 

Table 13.3-1 provides an Activity Checklist for activities related to the creation of Production 
Strategies. 

Table 13.3-1. Production Strategies - Activity Checklist 
Order Role Task Section Complete? 

1 Production Planner Launch the Production Strategies GUI (P) 13.3.1 

2 Production Planner Define or Modify a Production Strategy (P) 13.3.2 

13.3.1 Launch the Production Strategies GUI 

The Production Strategies GUI is invoked as described in the procedure that follows. 
Table 13.3-2 presents (in a condensed format) the steps required to launch the Production 
Strategies GUI. If you are already familiar with the procedures, you may prefer to use the quick­
step table. If you are new to the system, or have not performed this task recently, you should use 
the following detailed procedures. 

1 At the UNIX command line prompt enter: 

setenv DISPLAY <clientname>:0.0 
a.	 Use either the X terminal/workstation IP address or the machine-name for the 

clientname. 
b.	 When using secure shell, the DISPLAY variable is set just once, before logging in to 

remote hosts. If it were to be reset after logging in to a remote host, the security 
features would be compromised. 

2	 In the terminal window, at the command line prompt, start the log-in to the 
Planning/Management Workstation by entering: 

/tools/bin/ssh <hostname> 
a. Examples of hostnames include e0pls03, g0pls01, or l0pls02. 
b.	 If you receive the message, “Host key not found from the list of known hosts. Are 

you sure you want to continue connecting (yes/no)?” enter yes (“y” alone will not 
work). 

c.	 If you have previously set up a secure shell passphrase and executed sshremote, a 
prompt to Enter passphrase for RSA key '<user@localhost>' appears; continue 
with Step 3. 

d. If you have not previously set up a secure shell passphrase, go to Step 4. 
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3 If a prompt to Enter passphrase for RSA key '<user@localhost>' appears, enter: 

<Passphrase> 
a. Go to Step 5. 

4 At the <user@remotehost>’s password: prompt enter: 

<Password> 

5 In the terminal window, at the command line, enter: 

cd /usr/ecs/<MODE>/CUSTOM/utilities 
a. <MODE> is current mode of operation. 

1. TS1 - Science Software Integration and Test (SSI&T) 
2. TS2 - New Version Checkout 
3. OPS - Normal Operations 

b. “utilities” is the directory containing the Planning Subsystem start-up scripts. 

6 Set the application environment variables by entering: 

setenv ECS_HOME /usr/ecs/ 
a. Application home environment is entered 
b.	 When logging in as a system user (e.g., cmshared), the ECS_HOME variable may be 

set automatically so it may not be necessary to set it manually. 

7 Start the Production Strategies GUI by entering: 

EcPlProdStratStart <MODE> 
a. The Production Strategies GUI is launched. 

Table 13.3-2. Launch the Production Strategies GUI - Quick-Step Procedures 
Step What to Enter or Select Action to Take 

1 Log in to the Planning host using secure shell enter text, press Enter 

2 Enter cd /usr/ecs/<MODE>/CUSTOM/utilities enter text, press Enter 

3 Set the environment variables if necessary enter text, press Enter 

4 Enter EcPlProdStratStart <MODE> enter text, press Enter 

13.3.2 Define or Modify a Production Strategy 

The Production Planner uses the Production Strategies GUI to develop Production Strategies. 
Table 13.3-3 presents (in a condensed format) the steps required to define or modify a production 
strategy. If you are already familiar with the procedures, you may prefer to use this quick-step 
table. If you are new to the system, or have not performed this task recently, you should use the 
following detailed procedures. 

1 Launch the Production Strategies GUI (refer to Section 13.3.1). 
a. The Production Strategies GUI is displayed. 
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2 If defining a new production strategy, execute the following menu path: 

File → New 
a. The fields of the Production Strategies GUI are reset. 

3	 If modifying an existing production strategy, first single-click the option button 
associated with the Production Strategies field, then highlight (in the option menu) the 
name of the production strategy to be modified. 
a.	 Data pertaining to the selected production strategy are displayed in the applicable 

fields of the Production Strategies GUI. 
b.	 Alternatively, it is possible to execute the following menu path: File → Open, select 

the desired production strategy from the list on the Open window, and single-click on 
the Ok button to open the production strategy. 

4	 If changing the default priority for PR Type, in the Default field below the PR Type 
button enter: 

<default value> 
a. The range for the default is from 1 to 10. 

5 	 If changing the default priority for User Type, in the Default field below the User Type 
button enter: 

<default value> 

6	 If changing the default priority for PGE Type, in the Default field below the PGE Type 
button enter: 

<default value> 

7	 If defining or modifying a priority for a type of production request, first single-click on 
the PR Type button. 
a.	 The different types of production requests are displayed in the Type List field at the 

bottom left of the GUI. 

8	 If defining a priority for a type of production request not currently listed in the PR Type 
Value-Priority list, single-click on that PR type in the Type List field. 
a. The PR type is highlighted. 
b.	 It is possible to highlight multiple PR types (by single-clicking on each one in turn) if 

they are all going to be assigned the same priority. 

9	 If redefining or deleting a priority for a type of production request already listed in the 
PR Type Value-Priority list, single-click on that PR type in the Value-Priority list. 
a. The PR type is highlighted. 
b.	 It is possible to highlight multiple PR types (by single-clicking on each one in turn 

while holding down either the Shift key or the Ctrl key) if the same action is going to 
be taken with respect to all of them. 

Interim Update 13-34 611-TD-561-001 



10	 If defining or modifying (not deleting) a priority, click on the up/down arrow buttons to 
the right of the Priority field until the desired priority value is displayed in the Priority 
field. 
a. Alternatively, in the Priority field enter: 

<priority value> 
b. The acceptable range for the priority is from 1 to 10. 

11 Single-click on the appropriate button from the following selections: 
a.	 Add - to approve a priority for an additional PR type and display the selected PR type 

and priority in the PR Type Value-Priority list at the left center of the GUI. 
b.	 Modify - to approve a revised priority for the selected PR type and display the PR 

type and modified priority in the PR Type Value-Priority list. 
c.	 Delete - to delete the priority for the selected PR type and remove the PR type and 

priority from the PR Type Value-Priority list. 

12	 Repeat Steps 7 through 11 as necessary until all PR Type priorities (as shown in the PR 
Type Value-Priority field) are correct. 

13	 If defining or modifying a priority for a type of user, first single-click on the User Type 
button. 
a.	 The different types of users are displayed in the Type List field at the bottom left of 

the GUI. 

14	 If defining a priority for a type of user not currently listed in the User Type 
Value-Priority list, single-click on that user type in the Type List field. 
a. The user type is highlighted. 
b. It is possible to highlight multiple user types (by single-clicking on each one in turn). 

15	 If redefining or deleting a priority for a user type already listed in the User Type 
Value-Priority list, single-click on that user type in the Value-Priority list. 
a. The user type is highlighted. 
b.	 It is possible to highlight multiple user types (by single-clicking on each one in turn 

while holding down either the Shift key or the Ctrl key). 

16	 If defining or modifying (not deleting) a priority, click on the up/down arrow buttons to 
the right of the Priority field until the desired priority value is displayed in the Priority 
field. 
a. Alternatively, in the Priority field enter: 

<priority value> 
b. The acceptable range for the priority is from 1 to 10. 

17 Single-click on the appropriate button from the following selections: 
a.	 Add - to approve a priority for an additional user type and display the selected user 

type and priority in the User Type Value-Priority list near the center of the GUI. 
b.	 Modify - to approve a revised priority for the selected user type and display the user 

type and modified priority in the User Type Value-Priority list. 
c.	 Delete - to delete the priority for the selected user type and remove the user type and 

priority from the User Type Value-Priority list. 
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18	 Repeat Steps 13 through 17 as necessary until all user type priorities (as shown in the 
User Type Value-Priority field) are correct. 

19 If defining a priority for a type of PGE, first single-click on the PGE Type button. 
a.	 The different types of PGEs are displayed in the Type List field at the bottom left of 

the GUI. 

20	 If defining a priority for a type of PGE not currently listed in the PGE Type 
Value-Priority list, single-click on that PGE type in the Type List field. 
a. The PGE type is highlighted. 
b. It is possible to highlight multiple PGE types (by single-clicking on each one in turn). 

21	 If redefining or deleting a priority for a PGE type already listed in the PGE Type 
Value-Priority list, single-click on that PGE type in the Value-Priority list. 
a. The PGE type is highlighted. 
b.	 It is possible to highlight multiple PGE types (by single-clicking on each one in turn 

while holding down either the Shift key or the Ctrl key). 

22	 If defining or modifying (not deleting) a priority, click on the up/down arrow buttons to 
the right of the Priority field until the desired priority value is displayed in the Priority 
field. 
a. Alternatively, in the Priority field enter: 

<priority value> 
b. The acceptable range for the priority is from 1 to 10. 

23 Single-click on the appropriate button from the following selections: 
a.	 Add - to approve a priority for an additional PGE type and display the selected PGE 

type and priority in the PGE Type Value-Priority list near the center of the GUI. 
b.	 Modify - to approve a revised priority for the selected PGE type and display the PGE 

type and modified priority in the PGE Type Value-Priority list. 
c.	 Delete - to delete the priority for the selected PGE type and remove the PGE type and 

priority from the PGE Type Value-Priority list. 

24	 Repeat Steps 19 through 23 as necessary until all PGE type priorities (as shown in the 
PGE Type Value-Priority field) are correct. 

25 In the Weight field below the PR Type button enter: 

<weight> 
a. The acceptable range for weights is from 1 to 100. 
b.	 The Total Weight field displays updated totals of all weighting factors as they are 

entered. 
c.	 When entering weights for the PR Type, User Type, PGE Type, and Production 

Request Editor factors, relative values can be entered without regard to whether the 
values in the four categories add up to 100. The Normalize button provides a means 
of eventually ensuring that the total of all four categories equals 100. 

d.	 The assigned weight in each category is multiplied by the priority for each type. To 
maintain a high priority (low number, such as one), assign a low weight; to ensure a 
low priority, assign a relatively high weight. 
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26 In the Weight field below the User Type button enter: 

<weight> 

27 In the Weight field below the PGE Type button enter: 

<weight> 

28 In the Production Request Editor field enter: 

<weight> 
a.	 The priority to which the weight is applied is the priority assigned using the 

Production Request Editor when a production request is created. 

29 Single-click on the Normalize button. 
a.	 The Planning Subsystem adjusts all weighting factors to produce a total weight of 100 

(as displayed in the Total Weight field). 

30	 If it is necessary to change the priority of jobs that have been waiting in the Production 
Queue for more than a day, in the Late Start Delta Priority field enter: 

<priority value> 
a. The range for the Late Start Delta Priority is from 1 to 100. 

31 To start the process of saving the production strategy execute the following menu path: 

File → Save As 
a. A Save As window similar to the File Selection window is displayed. 

32 In the Save As field enter: 

<strategy file name> 

33 Single-click on the appropriate button from the following selections: 
a. OK - to accept the file name in the Save As field. 

1. The Save As window is dismissed. 
2. The production strategy is saved with the specified file name. 

b. Cancel - to dismiss the. Save As window without saving the production strategy. 

34	 To start the process of modifying or creating another production strategy execute the 
following menu path: 

File → New 
a. Return to Step 3 to modify an existing production strategy. 

35	 To start the process of exiting from the Production Strategies GUI execute the following 
menu path: 

File → Exit 
a. A Do you really want to exit? dialogue box is displayed. 

36 Single-click on the appropriate button from the following selections: 
a. OK - to exit from the Production Strategies GUI. 
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1. The Production Strategies GUI is dismissed. 
b. Cancel - to return to the Production Strategies GUI. 

Table 13.3-3. Define a Production Strategy - Quick-Step Procedures (1 of 2) 
Step What to Enter or Select Action to Take 

1 Launch Production Strategies GUI Use procedure in Section 13.3.1 

2 Execute File → New single-click 

3 Enter <default priority> for PR Type if 
applicable 

enter text 

4 Enter <default priority> for User Type if 
applicable 

enter text 

5 Enter <default priority> for PGE Type  if 
applicable 

enter text 

6 Select PR Type button. single-click 

7 Select <PR type> from the Type List field single-click 

8 Enter <priority value> in the Priority field enter text or single-click as necessary 

9 Select Add single-click 

10 Repeat Steps 7 through 9 for additional PR types 
if applicable 

11 Select User Type button. single-click 

12 Select <user type> from the Type List field single-click 

13 Enter <priority value> in the Priority field enter text or single-click as necessary 

14 Select Add single-click 

15 Repeat Steps 12 through 14 for additional user 
types if applicable 

16 Select PGE Type button. single-click 

17 Select <PGE type> from the Type List field single-click 

18 Enter <priority value> in the Priority field enter text or single-click as necessary 

19 Select Add single-click 

20 Repeat Steps 17 through 19 for additional PGE 
types if applicable 

21 Enter <weight> for PR Type enter text 

22 Enter <weight> for User Type enter text 

23 Enter <weight> for PGE Type enter text 

24 Enter <weight> for Production Request Editor enter text 

25 Select the Normalize button single-click 

26 Enter <priority value> for Late Start Delta 
Priority 

enter text 

27 Execute File → Save As single-click 

28 Enter <strategy file name> in the Save As field enter text 
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Table 13.3-3. Define a Production Strategy - Quick-Step Procedures (2 of 2) 
Step What to Enter or Select Action to Take 

29 Select Ok single-click 

30 Execute File → Exit if desired single-click 

31 Select OK single-click 

13.4Creating Production Plans 

The planning process involves the Production Planner preparing monthly and weekly production 
plans as well as a daily production schedule from the most current weekly plan. Although 
production planning varies from DAAC to DAAC, the following guidelines are generally 
applicable: 

a. Monthly plans. 
1. Developed for the coming month and one or two months in advance. 
2.	 Produced, reviewed, updated, published and distributed approximately two weeks 

before the beginning of the month. 
3 . 	 Plan for the coming month is used to establish a baseline against which 

production targets can be measured. 
b. Weekly plans. 

1.	 Produced, reviewed, updated, published and distributed approximately five days 
before the beginning of the coming week. 

2. 	 Used to produce a baseline for comparison of planned vs. actual production 
results. 

c. Daily plan or schedule. 
1. Produced each day for the next processing day. 
2.	 Developed from the current weekly plan, adjusted to reflect the actual processing 

accomplished and the actual resources available at the time the daily schedule is 
generated. 

3.	 The daily plan is the type of plan that is implemented through the Planning 
Workbench GUI. 

4.	 If there is a very large processing volume, it may be advisable to divide the daily 
plan into multiple plans; e.g., one for each shift or one for each four-hour period. 

During normal processing, when reasonably accurate predictions of the processing time for the 
PGEs are available, the processing schedule should result in a reasonably accurate prediction of 
when data products will be generated. However, during abnormal situations (e.g., equipment 
failure), what is actually accomplished could depart significantly from the plan. In such 
situations, the Production Planner may choose to develop new plans to reflect current events. 
This process is known as “replanning.” 

Table 13.4-1 provides an Activity Checklist for activities related to the creation of Production 
Plans. 
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Table 13.4-1. Production Plans - Activity Checklist 
Order Role Task Section Complete? 

1 Production Planner Launch the Planning Workbench and 
Planning Timeline GUIs 

(P) 13.4.1 

2 Production Planner Create a New Production Plan (P) 13.4.2 

3 Production Planner Review a Plan Timeline (P) 13.4.3 

13.4.1 Launch the Planning Workbench and Planning Timeline GUIs 

The Planning Workbench and Planning Timeline GUIs are invoked from a UNIX command line 
prompt. Table 13.4-2 presents (in a condensed format) the steps required to launch the Planning 
Workbench and Planning Timeline GUIs. If you are already familiar with the procedures, you 
may prefer to use the quick-step table. If you are new to the system, or have not performed this 
task recently, you should use the following detailed procedures. 

1 At the UNIX command line prompt enter: 

setenv DISPLAY <clientname>:0.0 
a.	 Use either the X terminal/workstation IP address or the machine-name for the 

clientname. 
b.	 When using secure shell, the DISPLAY variable is set just once, before logging in to 

remote hosts. If it were to be reset after logging in to a remote host, the security 
features would be compromised. 

2	 In the terminal window, at the command line prompt, start the log-in to the 
Planning/Management Workstation by entering: 

/tools/bin/ssh <hostname> 
a. Examples of hostnames include e0pls03, g0pls01, or l0pls02. 
b.	 If you receive the message, “Host key not found from the list of known hosts. Are 

you sure you want to continue connecting (yes/no)?” enter yes (“y” alone will not 
work). 

c.	 If you have previously set up a secure shell passphrase and executed sshremote, a 
prompt to Enter passphrase for RSA key '<user@localhost>' appears; continue 
with Step 3. 

d. If you have not previously set up a secure shell passphrase, go to Step 4. 

3 If a prompt to Enter passphrase for RSA key '<user@localhost>' appears, enter: 

<Passphrase> 
a. Go to Step 5. 

4 At the <user@remotehost>’s password: prompt enter: 

<Password> 

5 In the terminal window, at the command line, enter: 

cd /usr/ecs/<MODE>/CUSTOM/utilities 
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a. <MODE> is current mode of operation. 
1. TS1 - Science Software Integration and Test (SSI&T) 
2. TS2 - New Version Checkout 
3. OPS - Normal Operations 

b. “utilities” is the directory containing the Planning Subsystem start-up scripts. 

6 Set the application environment variables by entering: 

setenv ECS_HOME /usr/ecs/ 
a. Application home environment is entered 
b.	 When logging in as a system user (e.g., cmshared), the ECS_HOME variable may be 

set automatically so it may not be necessary to set it manually. 

NOTE:	 The selection of a start-up script for launching the Planning Workbench GUI 
depends on the number of DPRs in the PDPS database. If the number is very high 
(~4000), the EcPlSomeStart script is used to start the underlying processes 
(Message Handler, System Name Server, and Resource Model). Then additional 
scripts are used to start the Planning Workbench GUI and the Production 
Planning Timeline GUI. If the number of DPRs in the PDPS database is not 
very high (less than about 4000), the EcPlAllStart script is used to start the 
underlying processes, Planning Workbench GUI and Production Planning 
Timeline GUI. 

7	 If the number of DPRs in the PDPS database is not large (less than about 4000), start the 
Planning Workbench-related applications by entering: 

EcPlAllStart <MODE> <Application_id> 
a. The System Name Server and Resource Model are launched. 
b. The Message Handler GUI is displayed. 
c. Eventually, the Planning Workbench GUI is displayed. 
d. Then the Production Planning Timeline GUI is displayed. 

1.	 The Production Planning Timeline GUI usually occupies the entire screen when 
it is initially displayed. 

e.	 The application_id or MSGSRV_ID is a number from 1 to 5. It identifies the 
message service in use so messages can be directed to the proper message handler 
GUI. Consequently, it is a good idea to use the same application_id consistently 
during a production planning session. 

f. Go to Step 11. 

8	 If the number of DPRs in the database is large (~4000 or more), start the Message 
Handler, System Name Server, and Resource Model by entering: 

EcPlSomeStart <MODE> <Application_id> 
a. The Message Handler GUI is displayed. 
b.	 Wait until the Resource Model is completely up before proceeding with starting the 

Planning Workbench GUI. 

9	 If the number of DPRs in the database is large (~4000 or more), start the Planning 
Workbench GUI by entering: 

EcPlWbStart <MODE> <Application_id> 
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a. The Planning Workbench GUI is displayed. 

10	 If the number of DPRs in the database is large (~4000 or more), start the Production 
Planning Timeline GUI by entering 

EcPlTlStart <MODE> <Application_id> 
a. The Production Planning Timeline GUI is displayed. 

11	 If the Production Planning Timeline GUI is occupying the whole screen, either single­
click on the “minimize” icon in the upper right corner of the GUI or adjust the window 
size and the view of the timeline as necessary using the mouse. 
a.	 Grab a corner of the timeline window with the cursor and resize the window as 

desired. 

Table 13.4-2. Launch the Planning Workbench and Planning Timeline GUIs -
Quick-Step Procedures 

Step What to Enter or Select Action to Take 

1 Log in to the Planning host using secure shell enter text, press Enter 

2 Enter cd /usr/ecs/<MODE>/CUSTOM/utilities enter text, press Enter 

3 Set environment variables if necessary enter text, press Enter 

4 Enter EcPlAllStart <MODE> <application_id> enter text, press Enter 

13.4.2 Create a New Production Plan 

The Production Planner uses the Planning Workbench when creating a plan for production data 
processing at the DAAC. The Planning Workbench GUI provides the means by which the 
Production Planner selects specific PRs whose DPRs are to be run. The planning tool provides a 
forecast of the start and completion times of the jobs based upon historical experience in running 
these PGEs (as determined during the SSI&T process). Through the planning tool, when the 
generated plan is “activated,” the information included in the plan is transferred to the Data 
Processing Subsystem and loaded into the Platinum AutoSys tool where production processing is 
managed. 

Table 13.4-3 presents (in a condensed format) the steps required to create a new Production Plan. 
If you are already familiar with the procedures, you may prefer to use this quick-step table. If 
you are new to the system, or have not performed this task recently, you should use the following 
detailed procedures: 

1 Launch the Planning Workbench (refer to Section 13.4.1). 
a. The Planning Workbench and Planning Timeline GUIs are displayed. 

2 Execute the following menu path on the Planning Workbench GUI: 

File → New 
a. The New Plan window is displayed. 
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3 In the Plan Names field enter: 

<plan name> 
a. Name is displayed in Plan Names field. 
b. Status is Candidate. 

4 Single-click on the appropriate button from the following selections: 
a. Ok - to accept the file name in the Plan Names field. 

1. The New Plan window is dismissed. 
2. The production plan is saved with the specified file name. 

b. Apply - to save the production plan without dismissing the New Plan window. 
1. The production plan is saved with the specified file name. 

c. Cancel - to dismiss the New Plan window without saving the production plan. 

5	 If applicable, single-click on the option button associated with the Strategy field, then 
select the desired production strategy from the option menu. 

6 If applicable, in the Comment field enter: 

<comment> 

7	 Select a Production Request to be scheduled by single-clicking on the request line and 
single-clicking on schedule/unschedule up and down arrows to move the Production 
Request from the Unscheduled panel to the Scheduled panel or vice versa. 
a. Production Request will appear in the appropriate panel. 
b.	 Operator can single-click on multiple Production Requests to add them all at the same 

time. 
c.	 If the PR depends upon another PR that is not scheduled, then the following message 

is displayed: “Production Request ‘xxx’ must be selected before DPR ‘yyy’ of 
Production Request ‘zzz’ can be scheduled.” 

d. If all DPRs associated with a PR have been run, the PR cannot be rescheduled. 
e.	 If processing of the currently active plan is to be continued when the new plan is 

activated, include the PR(s) for the currently active plan in the new plan. 
f.	 In the Scheduled list, items with the prefix “GE_” are resource reservations (also 

called “ground events”). 
g.	 All ground events are automatically scheduled with any plan; therefore, the ground 

events are normally displayed in the Scheduled list. 
h.	 Whenever a plan is activated, the ground events are activated as well as the DPRs 

associated with the specified PRs. 
i.	 If a ground event appears in the Unscheduled list, the ground event has lost 

allocations. 

8	 If the priority of any PR in the Scheduled list needs to be changed, perform Steps 9 
through 13; otherwise go to Step 14. 

9 Single-click on the PR entry in the Scheduled list to highlight it. 

10 Single-click on the Prioritize button. 
a. The Priority popup window is displayed. 

11 In the Production Request(s) priority field enter: 

<priority value> 
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12 Single-click on the appropriate button from the following selections: 
a. OK - to accept the new priority in the Production Request(s) priority field. 

1. The Priority popup window is dismissed. 
2. The new priority for the PR is saved in the database. 

b. Cancel - to dismiss the Priority popup window without saving the new priority. 

13 Repeat Steps 9 through 12 for any additional PR(s) needing a change of priority. 

14 Execute the following menu path: 

File → Save As 
a. The Save Plan window is displayed. 

15 If the plan name for the production plan is not displayed in the Plan Names field, enter: 

<plan name> 

16 Single-click on the appropriate button from the following selections: 
a. Ok - to accept the file name in the Plan Names field. 

1. The Save Plan window is dismissed. 
2. The production plan is saved with the specified file name. 
3. The Planning Workbench GUI is displayed. 
4. The Plan Name is displayed. 
5. The Status displayed is Candidate. 

b. Apply - to save the production plan without dismissing the Save Plan window. 
1. The production plan is saved with the specified file name. 

c. Cancel - to dismiss the Save Plan window without saving the production plan. 

17	 If the plan is to be activated immediately, perform Steps 18 and 19; otherwise go to 
Step 20. 

18 Single-click on the Activate button. 
a. A Confirm Activation dialogue box is displayed. 

19 Single-click on the appropriate button from the following selections: 
a. Yes - to activate the plan. 

1. The Confirm Activation dialogue box is dismissed. 
2. The new plan is activated. 
3.	 The time of plan activation is displayed next to Rollover Time on the Planning 

Workbench GUI. 
4.	 When a plan is activated the Data Processing Requests (DPRs) associated with the 

planned PRs are transferred to Job Management in the Data Processing 
Subsystem. 

5.	 Once its data dependencies have been satisfied, each DPR is “released” to be run 
as processing resources become available. 

6.	 Activating a new plan causes the current active plan to get "replanned over" by 
the selected plan. 

b. No – to dismiss the Confirm Activation dialogue box without activating the plan. 

20 If it is desired to baseline the plan, perform Steps 21 through 25; otherwise go to Step 26. 
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21 Single-click on the Baseline button. 
a.	 A confirmation dialogue box containing the message The current plan is <Plan 

Name>. Do you wish to baseline it?  is displayed. 
b. Clicking on the Baseline button records the plan and the time of baselining. 
c.	 A baseline plan can be used as a point of comparison with which to compare future 

plans and results. 

22	 If it is desired to baseline the plan, single-click on the appropriate button from the 
following selections: 
a. Yes - to baseline the plan. 

1 . 	 The confirmation dialogue box containing the message The current plan is 
<Plan Name>. Do you wish to baseline it?  is dismissed. 

2. The plan is baselined. 
b.	 No – to dismiss the confirmation dialogue box containing the message The current 

plan is <Plan Name>. Do you wish to baseline it?  without baselining the plan. 

23 Execute the following menu path: 

File → Save As 
a. The Save Plan window is displayed. 

24 If the plan name for the production plan is not displayed in the Plan Names field, enter: 

<plan name> 

25 Single-click on the appropriate button from the following selections: 
a. Ok - to accept the file name in the Plan Names field. 

1. The Save Plan window is dismissed. 
2. The production plan is saved with the specified file name. 

b. Apply - to save the production plan without dismissing the Save Plan window. 
1. The production plan is saved with the specified file name. 

c.	 Cancel - to dismiss the Save Plan window without saving the production plan as a 
baseline plan. 

26 Repeat Steps 1 through 25 to perform additional production planning activities. 

27 To view the Planning Timeline perform the procedure in Section 13.4.3. 

28	 To quit the Planning Workbench GUI when production planning is complete execute 
the following menu path: 

File → Exit 

29	 After quitting the Planning Workbench GUI single-click in the UNIX window used to 
start the Planning Workbench GUI. 
a.	 The Message Handler, System Name Server, and Resource Model should be shut 

down to eliminate unneeded processes and allow other operators to gain access to the 
Planning Workbench if necessary. 

30 Shut down Planning Workbench-related applications by entering: 
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1

2

3

4

5

6

EcPlSlayAll <MODE> <Application_id> 
a. The following Planning Workbench-related applications shut down: 

1. Planning Workbench (if it has not already been shut down). 
2. Planning Timeline (if it has not already been shut down). 
3. Message Handler. 
4. System Name Server. 
5. Resource Model. 

31 Obtain a list of active processes in the specified mode by entering: 

ps -ef | grep <MODE> 
a. A list of active processes in the specified mode is displayed. 
b. If an error message is received when ps -ef | grep <MODE> is entered, enter: 

ps -auxwww | grep <MODE> 

32	 Examine the list of processes running in the specified mode to determine whether the 
Message Handler, System Name Server, and Resource Model processes have actually 
been shut down. 
a. None of the following processes should be active: 

1. EcPlWb 
2. EcPlTl 
3. EcPlMsh 
4. EcPlSns 
5. EcPlRm 

33	 If any of the specified processes [especially the Message Handler, System Name Server, 
and/or Resource Model process(es)] is/are still active, terminate the active process(es) by 
entering: 

kill -15 <PROCESS_ID1> <PROCESS_ID2> <…> <PROCESS_IDx> 

34 Repeat Steps 31 through 33 as necessary. 

Table 13.4-3. Create a New Production Plan - Quick-Step Procedures (1 of 2) 
Step What to Enter or Select Action to Take 

Launch Planning Workbench Use procedure in Section 13.4.1 

Execute File → New single-click 

Enter <plan name> enter text 

Select Ok single-click 

Select <strategy> from Strategy button single-click 

Select <Production Request(s)> to 
schedule/unschedule 

single-click 

7 Select Schedule button or Unschedule button as 
applicable 

single-click 

8 Execute File → Save As single-click 

9 Enter <plan name> enter text 
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Table 13.4-3. Create a New Production Plan - Quick-Step Procedures (2 of 2) 
Step What to Enter or Select Action to Take 

10 Select Ok single-click 

11 Select Activate if applicable single-click 

12 Select Yes if applicable single-click 

13 Select Baseline if applicable single-click 

14 Select Yes if applicable single-click 

15 Execute File → Save As if applicable single-click 

16 Enter <plan name> if applicable enter text 

17 Select Ok if applicable single-click 

18 View the Planning Timeline if desired Use procedure in Section 13.4.3 

19 Execute File → Exit single-click 

20 Enter EcPlSlayAll <MODE> <Application_id> enter text, press Enter 

21 Enter ps -ef | grep <MODE> enter text, press Enter 

22 Enter kill -15 <PROCESS_ID1> 
<PROCESS_ID2> <…> <PROCESS_IDx> to 
terminate active process(es) if necessary 

enter text, press Enter 

13.4.3 Review a Plan Timeline 

Table 13.4-4 presents (in a condensed format) the steps required to review planning timelines. If 
you are already familiar with the procedures, you may prefer to use this quick-step table. If you 
are new to the system, or have not performed this task recently, you should use the following 
detailed procedures. 

1 Launch the Planning Workbench and Timeline GUIs (refer to Section 13.4.1). 
a. The Planning Timeline GUI is displayed. 
b.	 If you have previously saved a configuration file, you may load it by executing the 

following menu path: 

File → Load Configuration 
1. Change directory in GUI box, if necessary. 

c. Otherwise continue with Step 2. 

2 Execute the following menu path: 

File → Open Plan 
a. The Open Plan window is displayed with a list of plans. 

3 Single-click on the name (in the Items list) of the plan to be reviewed. 

4 Single-click on the appropriate button from the following selections: 
a. OK - to open the selected plan and dismiss the Open Plan window. 

1. The timeline for the specific plan is displayed. 
2. Name is displayed in the Title bar. 

b. Apply - to open the selected plan without dismissing the Open Plan window. 
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1. The timeline for the specific plan is displayed. 
2. Name is displayed in the Title bar. 

c. Cancel - to dismiss the Open Plan window without opening any plan. 

5 Observe the production plan information displayed on the timeline GUI. 

6	 If a different time scale (start and end dates and times) is desired, perform Steps 7 
through 10; otherwise, go to Step 11. 

7 Execute the following menu path: 

Time → Change Plan Window 
a. The plan window edit window appears with default times. 

8 In the Plan Win Start fields enter the start date and time in the following formats: 

<DD MMM YYYY> <hh:mm:ss> 

9 In the Plan Win End fields enter the end date and time in the following formats: 

<DD MMM YYYY> <hh:mm:ss> 

10 Single-click on the appropriate button from the following selections: 
a. OK - to accept the changes and dismiss the plan window edit window. 
b. Apply - to accept the changes without dismissing the plan window edit window. 
c. Cancel - to cancel the changes and dismiss the plan window edit window. 

11	 If a different time span is desired, single-click on the Show pushbutton and select one of 
11 time increments between 5 min and 168 hrs for the timeline scale. 
a. The entry “other” has no purpose at this time. 

12	 If no resources are displayed on the GUI or if different resources should be displayed, 
perform Steps 13 through 19; otherwise, go to Step 20. 

13 Execute the following menu path: 

Display → Change resources 
a.	 Resource edit window with lists of Available Resources and Viewed Resources is 

displayed. 

14 Single-click resource(s) in desired list. 
a. Multiple resources may be selected by single-clicking each desired resource. 

15 Single-click either Add or Del. 
a. Add to move the resource(s) from the Available list to the Viewed list. 
b. Del to remove items from the Viewed List. 

16	 To change the order in which resources are displayed on the timeline, single-click on an 
item in the Viewed Resources list. 

17	 To change the order in which resources are displayed on the timeline, single-click on the 
up or down arrow(s) as appropriate. 
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a. Selected resource moves up or down in order on the list. 

18 Repeat Steps 16 and 17 as necessary. 

19 Single-click on the appropriate button from the following selections: 
a. OK - to accept the changes and dismiss the Resource edit window. 
b. Apply - to accept the changes without dismissing the Resource edit window. 
c. Cancel - to cancel the changes and dismiss the Resource edit window. 

20	 If different color coding of the timeline is desired, perform Steps 21 through 25; 
otherwise, go to Step 26. 

21 Execute the following menu path: 

Display → Change colors 
a. Color grid appears with a list of Production Requests. 

22 Single-click on the Production Request name. 

23 Single-click on the desired color for the Production Request. 
a.	 New color appears on the horizontal bar between color and Production Request 

selections. 

24 Repeat Steps 22 and 23 as necessary. 

25 Single-click on the appropriate button from the following selections: 
a. OK - to accept the changes and dismiss the Color Selections window. 
b. Apply - to accept the changes without dismissing the Color Selections window. 
c. Cancel - to cancel the changes and dismiss the Color Selections window. 

26 Observe the production plan information displayed on the timeline GUI. 

27 If desired, save the current configuration as a file by executing the following menu path: 

File → Save Configuration 

28 Single-click on the appropriate button from the following selections: 
a. OK - to save the configuration and dismiss the Color Selections window. 
b. Apply - to save the configuration without dismissing the Color Selections window. 
c. Cancel - to dismiss the Color Selections window without saving the configuration. 

29 To exit the Planning Master Timeline GUI, execute the following menu path: 

File → Exit 
a. The Planning Master Timeline GUI is dismissed. 
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Table 13.4-4. Review a Plan Timeline - Quick-Step Procedures 
Step What to Enter or Select Action to Take 

1 Launch Planning Workbench and Timeline Use procedure in Section 13.4.1 

2 Load configuration file (execute File → Load 
Configuration) (optional) 

single-click 

3 Execute File → Open Plan single-click 

4 Select <plan name> single-click 

5 Select Ok single-click 

6 Observe the production plan information read text 

7 Execute Time → Change Plan window single-click 

8 Enter <DD MMM YYYY> <hh:mm:ss> in Plan 
Win Start fields 

enter text 

9 Enter <DD MMM YYYY> <hh:mm:ss> in Plan 
Win End fields 

enter text 

10 Select Ok single-click 

11 Select <time span> from Show pushbutton single-click 

12 Execute Display → Change resources single-click 

13 Select <resources> single-click 

14 Select Add single-click 

15 Select <viewed resource> to be reordered single-click 

16 Reorder viewed resources using up/down arrows single-click 

17 Select Ok single-click 

18 Execute Display → Change colors single-click 

19 Select <Production Request> single-click 

20 Select <color> for Production Request single-click 

21 Select Ok single-click 

22 Observe the production plan information read text 

23 Execute File → Save Configuration single-click 

24 Enter <file name> enter text 

25 Select Ok single-click 

26 Execute File → Exit single-click 

13.5Cleaning the PDPS Database 

In the /usr/ecs/<MODE>/CUSTOM/utilities directory on the Planning/Management Workstation 
there is a script that can be run to clean up some tables in a PDPS database. When it runs, the 
script tries to delete applicable records in the following order: 

a. Data Processing Requests based on timeStamp completionState(SUCC_DEL). 
b. Production Requests that have no associated DPRs. 
c.	 Dynamic data granules that are not used by any DPR or by the Data Processing 

Subsystem. 
d.	 List of data granules that are not deleted because of Data Processing Subsystem 

usage. 
e. PGEs marked with a deleteFlag. 

Interim Update 13-50 611-TD-561-001 



f. Science Software that has no associated PGE. 

The procedure for cleaning the PDPS database starts with the assumption that the applicable 
servers are running and the Production Planner has logged in to the ECS system. 

Table 13.5-1 provides an Activity Checklist for activities related to the database cleaning. 

Table 13.5-1. Database Cleaning - Activity Checklist 
Order Role Task Section Complete? 

1 Production Planner 
Database 
Administrator 

Clean the PDPS Database (P) 13.5.1 

13.5.1 Clean the PDPS Database 

The database cleaning script is invoked from a UNIX command line prompt. Table 13.5-2 
presents (in a condensed format) the steps required to clean the PDPS database. If you are 
already familiar with the procedures, you may prefer to use this quick-step table. If you are new 
to the system, or have not performed this task recently, you should use the following detailed 
procedures. 

1 At the UNIX command line prompt enter: 

setenv DISPLAY <clientname>:0.0 
a.	 Use either the X terminal/workstation IP address or the machine-name for the 

clientname. 
b.	 When using secure shell, the DISPLAY variable is set just once, before logging in to 

remote hosts. If it were to be reset after logging in to a remote host, the security 
features would be compromised. 

2	 In the terminal window, at the command line prompt, start the log-in to the 
Planning/Management Workstation by entering: 

/tools/bin/ssh <hostname> 
a. Examples of hostnames include e0pls03, g0pls01, or l0pls02. 
b.	 If you receive the message, “Host key not found from the list of known hosts. Are 

you sure you want to continue connecting (yes/no)?” enter yes (“y” alone will not 
work). 

c.	 If you have previously set up a secure shell passphrase and executed sshremote, a 
prompt to Enter passphrase for RSA key '<user@localhost>' appears; continue 
with Step 3. 

d. If you have not previously set up a secure shell passphrase, go to Step 4. 

3 If a prompt to Enter passphrase for RSA key '<user@localhost>' appears, enter: 

<Passphrase> 
a. Go to Step 7. 
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4 At the <user@remotehost>’s password: prompt enter: 

<Password> 

5 In the terminal window, at the command line, enter: 

cd /usr/ecs/<MODE>/CUSTOM/utilities 
a. <MODE> is current mode of operation. 

1. TS1 - Science Software Integration and Test (SSI&T) 
2. TS2 - New Version Checkout 
3. OPS - Normal Operations 

b. “utilities” is the directory containing the Planning Subsystem start-up scripts. 

6 Set the application environment variables by entering: 

setenv ECS_HOME /usr/ecs/ 
a. Application home environment is entered 
b.	 When logging in as a system user (e.g., cmshared), the ECS_HOME variable may be 

set automatically so it may not be necessary to set it manually. 

7 Start the database cleaning script by entering: 

EcPlDbClean <MODE> <dbuser> <dbpassword> <dbserver> <months> <days> 
a. <dbuser> is the user name for logging in to isql. 
b. <dbpassword> is the password for isql login. 
c. <dbserver> refers to the name of the PDPS database server (e.g., x0pls02_srvr). 
d.	 <months> is a number specifying the removal of records that are older than that 

number of months. 
e.	 <days> is a optional argument. It is a number that specifies the removal of records 

that are older than that number of days. 
f. Both <months> and <days> are taken into account by the cleaning script. 

Table 13.5-2. Clean the PDPS Database - Quick-Step Procedures 
Step What to Enter or Select Action to Take 

1 Log in to the Planning host using secure shell enter text, press Enter 

2 Enter cd /usr/ecs/<MODE>/CUSTOM/utilities enter text, press Enter 

3 Set environment variables if necessary enter text, press Enter 

4 Enter EcPlDbClean <MODE> <dbserver> 
<dbuser> <dbpassword>  <months> <days> 

enter text, press Enter 

13.6Tuning System Parameters 

The Production Planner works with the rest of the production team (i.e, Resource Planner and 
Production Monitors) to tune system parameters. Detailed procedures are included in 
Chapter 14, Production Processing. 
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