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Abstract


This document serves as a companion document to the Flight Operations Segment (FOS) 
Release A Instrument Support Terminal (IST) Toolkit Release Notes and the FOS Operations 
Tools Manual for the ECS Project and provides instructions and information on installation of 
the IST Release A toolkit software. These installation procedures describe the hardware and 
software configuration required to support the installation and operation of the software. This 
document is unique to FOS Release A IST operations and includes information not covered in 
the FOS Operations Tools Manual. 

Keywords: Installation, IST, FOS, software, hardware. 
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1. Introduction 

1.1 Purpose 

This installation guide provides information and instructions necessary to install, configure and 
start up the FOS Release A Instrument Support Terminal (IST) toolkit software in a Sun 
Microsystems operating environment. 

1.2 Organization 

This White Paper is organized as follows: 

•	 Section 1 defines the purpose, organization, review and approval process for this 
document. 

•	 Section 2 lists related documents required for the installation or operation of the IST 
toolkit software. 

• Section 3 describes how to install, configure, and start the IST toolkit software. 

• Section 4 illustrates how to checkout the IST toolkit 

• Section 5 documents the executable and data files included in the IST toolkit. 

1.3 Review and Approval 

This White Paper is an informal document approved at the FOS Office Manager level. It does 
not require formal Government review or approval; however, it is submitted with the intent that 
review and comments will be forthcoming. 

The ideas expressed in this White Paper are valid for Release A of IST toolkit software. The 
concepts and information presented in this paper are not expected to migrate into a formal CDRL 
delivery. 

Questions regarding technical information contained within this White Paper should be 
addressed to the following ECS contact: 

• ECS Contacts 

– Marina Glad, FOS Systems Engineering <mglad@eos.hitc.com> 

Questions concerning distribution or control of this document should be addressed to:


Data Management Office

The ECS Project Office

Hughes Information Technology Systems

1616 McCormick Drive

Upper Marlboro, Maryland 20774-5372
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2. Related Documents 

2.1 Related Documents 

The following documents provide additional information required for the operation of the IST 
toolkit software: 

343-WP-001-002	 Flight Operations Segment (FOS) Release A Instrument Support 
Terminal (IST) Toolkit Release Notes for the ECS Project, 
February 28, 1997 

609-CD-005-002	 Flight Operations Segment (FOS) Tools Manual for the ECS Project, 
February 27, 1997 

The Flight Operations Segment (FOS) Release A Instrument Support Terminal (IST) Toolkit 
Release Notes for the ECS Project identifies the subset of capabilities outlined in the FOS 
Operations Segment Tools Manual for the ECS Project which are applicable to Release A IST 
operations. 
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3. IST Toolkit Installation 

3.1 Introduction 

The FOS IST toolkit software may be installed from a 4-mm digital audio tape (DAT) or via FTP 
transfer. The following steps describe a typical standalone installation in a Hewlett Packard 
operating environment from a 4 mm DAT. 

3.2 Workstation Requirements 

1. Hewlett Packard B160L or HP715/100. 

2. 64 to 128 Megabytes of RAM, 128 Megabytes recommended. 

3. 6 Gigabyte fixed disk space for executable, database and user file storage. 

4. Hewlett Packard operating system HP UX 10-10 with vendor recommended patches. 

5. 20-inch graphics monitor capable of 1280 x 1024 screen resolution. 

3.3 Software Requirements 

The workstation must have the following software installed: 

1. X11R5 

2. Motif 1.2.3 

3. Sybase Client Version 10.0.2 (Sybase Corporation) 

3.4 System Changes 

3.4.1 Create a New User Account 

The System Administrator should create a new user account with its own home directory for 
installation of the FOS IST toolkit software. In these installation procedures, the home directory 
of the new user account is referred to as {home}. Where {home} appears in a directory name, 
the installer should substitute the actual home directory. 

3.4.2 Modify the .cshrc File 

1.	 If the .cshrc file does not contain a line setting the XFILESEARCHPATH variable, add 
the following line to the file: 

setenv XFILESEARCHPATH $MOTIFHOME/lib/%T/%N%S:/usr/lib/X11/app-defaults/%N 

2. If not already done, set the MOTIFHOME variable to the directory where Motif resides. 
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3. Update the USER variable, substituting the actual user ID for {user ID}: 

setenv USER {user ID} 

4.	 Update the LD_LIBRARY_PATH variable to include the directories where Sybase 
libraries and Motif libraries reside. 

3.4.3 Modify the /etc/services File 

Add the following 5 lines to the /etc/services file: 

msg-srv1 5110/tcp 
msg-srv2 5111/tcp 
msg-srv3 5112/tcp 
msg-srv4 5113/tcp 
msg-srv5 5114/tcp 

3.5 Install the IST Toolkit Software 

3.5.1 Copy the IST Tape Archive (TAR) file to the home directory 

1. Log on to the workstation under the new user account created in paragraph 3.4.1. 

2.	 Open a terminal window and change to the {home} directory by entering: 

cd 

3.	 From the {home} directory create the subdirectories fos, fos/istproto, pages and procs by 
entering the following command: 

mkdir fos fos/istproto pages procs 

4.	 Change to the {home}/fos/istproto directory. Insert the 4-mm DAT IST toolkit tape into 
the tape drive, copy the ISTDELIVERY.tar file to the …/istproto directory, and expand 
the ISTDELIVERY.tar file by entering the following commands: 

cd {home}/fos/istproto 

tar -xf /dev/rmt/0mnb 

tar -xvf ISTDELIVERY.tar 

5.	 In the fos/istproto subdirectory, create a symbolic link from AM1 to am1 by entering: 

ln -s am1 AM1 

3.5.2 Update Files with Site Specific References 

Update or create the files in Table 3.1 as described in 3.5.2.1 through 3.5.2.8. 
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Table 3-1. Data Files to be Updated 
File Name Function 

FosEnvVars Sets environment variables. 

IST_UserStationStartup Starts the user station in connected mode. 

IST_Standalone Starts the user station in standalone mode. 

MyKill Shuts down the user station processes. 

fos_sybsetup.script Specifies Sybase database configuration. 

data.db Specifies the Real Time server and user stations. 

3.5.2.1 Update the FosEnvVars File 

Change to the {home}/fos/istproto/am1/scripts/setup directory and edit the FosEnvVars file. 

1.	 Update “setenv FOS…” as follows: 

setenv FOS_ROOT {home}/fos 

3.5.2.2 Update the IST_UserStationStartup File 

Edit the IST_UserStationStartup file. 

1.	 Update “setenv FOS_ROOT…” as follows: 

setenv FOS_ROOT {home}/fos 

3.5.2.3 Update the IST_Standalone File 

Edit the IST_Standalone file. 

1. Update “setenv FOS_ROOT…” as follows: 

setenv FOS_ROOT {home}/fos 

3.5.2.4 Update the MyKill File 

Edit the MyKill file. 

1.	 Update the “set commonpath =...” statement as follows: 

set commonpath = “/fos/istproto” 

3.5.2.5 Update the fos_sybsetup.script File 

Edit the fos_sybsetup.script file. 

1. Update “setenv SYBASE…” as follows: 

setenv SYBASE /{directory where Sybase is installed} 
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2.	 Update the “switch” statement, substituting the host computer name for {host machine 
name}: 

switch (`uname -n`) 

case {host machine name}*: 

setenv DSQUERY fos1_srvr 

setenv PDB_DIR /fos/istproto/am1/pdb 

breaksw 

endsw 

3.5.2.6 Create a Link to evtdis.uid 

1.	 Remove the existing link. 

rm evtdis.uid 

2.	 Create a new link. 

ln -s {home}/fos/istproto/am1/bin/hp_ux_10-10/evtdis.uid evtdis.uid 

3.5.2.7 Update the data.db File 

Change to the {home}/fos/istproto/am1/config directory and update the data.db file. 

1.	 Update the data.db file to include the following 2 lines only. Substitute the name of the 
host computer for {host machine name}. 

foseoc6 1 1 

{host machine name} 2 0 

3.5.2.8 Create a fos-services File 

1.	 Change to the {home}/fos/istproto/am1/data directory and copy the example.fos-services 
file as follows, substituting the actual host computer name for {host machine name}: 

cp example.fos-services {host machine name}.fos-services 

2.	 Update the first 2 lines of the new fos-services file, substituting the actual host computer 
name for {host machine name}: 

epserver 9995/tcp {host machine name} 

evhandler 9996/tcp {host machine name} 
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3.5.3 Set up FOS User Interface page*.dat Files 

Set up FOS User Interface (FUI) pageSystem.dat and pageUser.dat files. 

1.	 If this is an initial installation, go on to step (2). If this is a reinstallation and a backup of 
the files in the {home}/pages directory exists, restore the user’s page definitions by 
copying the backup files to the {home}/pages directory. If no backup of the 
{home}/pages directory exists, go on to step (2). 

2. Set up FOS User Interface (FUI) pageSystem.dat and pageUser.dat files. 

a. Change to the {home}/fos/istproto/am1/scripts/setup directory and enter: 

setenv SCRIPT UserStation 

b.	 Enter the following command: 

source FosEnvVars 

c.	 Change the directory to ../../bin/hp_ux_10-10 and enter: 

DisplayBuilder -pageNoIPC 

The Display Builder Tool starts. 

d.	 Select Open under the File menu of the Display Builder window. The display 
selection dialog is displayed. In the Filter text entry box of the dialog box, type the 
following directory: 

{home}/fos/istproto/am1/displaydefs 

Click on the Filter button.


Select any display in the selection dialog, e.g., ALPHA1.


Click on the OK button.


e. Select Save under the File menu of the Display Builder window. 

f.	 Select Build to CM under the File menu of the Display Builder window. 

This creates a file called pageSystem.dat under the …/am1/displaydefs directory. 

g.	 Select Open under the File menu of the Display Builder window. The display 
selection dialog is displayed. In the Filter text entry box of the dialog, type the 
following directory: 

{home}/fos/istproto/am1/displaydefs 

Click on the Filter button.


Select any display in the selection dialog, e.g., ALPHA1.


Click on the OK button.
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h.	 Select Save As under the File menu of the Display Builder window. Save the file as 
{home}/pages/ALPHA1. 

i.	 Select Build to Local under the File menu of the Display Builder window. 

This creates a file called pageUser.dat under the {home}/pages directory. 

3.5.4 IST Startup in the Standalone Mode 

1.	 Change to the {home}/fos/istproto/am1/scripts/setup directory and run the Standalone 
Startup script. 

source IST_Standalone 

2.	 At completion of software startup, the terminal window and IST display windows may be 
iconified. 

Error messages relating to Sybase functions are acceptable in the standalone mode when the 
Sybase database is not available. A message is provided to indicate that end points are being 
registered in a local repository. 

3.5.5 IST Startup in the Connected Mode 

1.	 Change to the {home}/fos/istproto/am1/scripts/setup directory and run the User Station 
Startup script. 

source IST_UserStationStartup 

2.	 At completion of software startup, the terminal window and IST display windows may be 
iconified. 

3.5.6 IST Workstation Shutdown 

1.	 To end the IST session, open a terminal window and enter the following command at the 
{home}/fos/istproto/am1/scripts/setup directory: 

MyKill 

2. To verify all FOS processes have terminated, enter: 

/usr/bin/ps -ef |grep fos 

All processes which are still running will be listed on the screen. Table 5-1 lists FOS 
processes initiated during User Station startup.  If any of these FOS processes are still 
running, follow the instructions for terminating FOS processes in paragraph 3.5.7. 
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3.5.7 FOS Process Termination 

In exceptional cases, the MyKill script will not terminate all FOS processes. If a FOS process 
remains active after the MyKill script is run, perform the procedure below to terminate the 
remaining FOS processes. This procedure should be used only when the MyKill script fails. 

1.	 To list the remaining FOS processes enter: 

/usr/bin/ps -ef |grep fos 

2.	 For each remaining FOS process listed on the screen, starting with the process with the 
highest process ID, type: 

kill -2 <processid> 

3.	 Validate no FOS processes are running by entering: 

/usr/bin/ps -ef |grep fos 

4.	 For any FOS process listed on the screen, starting with the process with the highest 
process ID, type: 

kill -9 <processid> 
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4. IST Toolkit Checkout 

4.1 IST Installation Checkout 

The procedures described in this section verify installation and operation of the IST toolkit 
software. If any error messages are produced during this checkout , refer to Appendix B of the 
FOS Operations Tools Manual to identify the error in the table of event message definitions. 

4.1.1 Connected Mode 

The Control Window opens once the operator runs the IST_UserStationStartup script. The 
Room buttons (R1, R2, …, R6 ) and Procedures menu (Procs…) on the Control Window are 
not operational. Click on the Mini Ctrl button to switch to the Mini Control Window. Open and 
close the Procedure Builder, Display Builder and Room Builder Tools by clicking on the 
appropriate options under the Tools menu of the Control or Mini Control Windows. Click on the 
Help button to launch Netscape to a generic list of help topics. Click on the Event Window to 
validate event messages are displayed. 

The planning and scheduling tools are started via the IST_UserStationStartup script. Iconify the 
Activity Definer, Baseline Activity Profile (BAP) Definer, General Scheduler and Timeline 
Tools. 

4.1.2 Standalone Mode 

Open and close the Procedure Builder, Display Builder and Room Builder Tools by clicking on 
the appropriate options under the Tools menu of the Control or Mini Control Widows. 

The planning and scheduling tools are started via the IST_Standalone startup script. Iconify the 
Activity Definer, Baseline Activity Profile (BAP) Definer, General Scheduler and Timeline 
Tools. 

4.2 IST Problem Reporting 

To report problems related to the functionality of the Release A IST toolkit, submit an electronic 
mail message describing the problem to isttrble@eoc.ecs.nasa.gov. 
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5. IST Deliverable File Set 

5.1 IST Toolkit Executable Files 

The following files are required for the installation and operation of the IST toolkit. 

Table 5-1. IST Toolkit Deliverable Executable Files 
Executable File Name Executable File Name (cont.) 

CmdControl FpNsNameServer 

DisplayBuilder FpRmResourceModel 

DynamicPage FpTlTimeline 

evtdis.uid FrGrStringMgr 

FaAcCruncher FrRpRepeater 

FaDrReaderDriver FtDcDecom 

FaRmRequestManager FtDcDecomISTOrig 

FdDbOdfTable FuAnBuild 

FdDbTableDefSrv FuAnHandler 

FdEvEventHandler FuCwControlWindow 

FoNsNameServer FuDbWriteDefs 

FoPsParameterServer FuEcEnvCtrl 

FoRfReflector FuEvEvtdis 

FoRfReflectorISTOrig FuLbTableLoadBuilder 

FoSwNameServerSweeper FuLmLoadManager 

FpAdActivityDefiner FuPbProcBuilderWin 

FpBdBapDefiner FuPcProcController 

FpEhEventHandler FuRbRoomBuilder 

FpFsAsterFilter sns 

FpGsGeneralScheduler TlmRetriever 
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5.2 IST Toolkit Data Files 

Table 5-2. IST Toolkit Deliverable Data Files (1 of 2) 
Data File Name Data File Name (cont.) Data File Name (cont.) Data File Name (cont.) 

.EclTemplate display page definitions 
(in ../displaydefs 
directory) 

opscene.htlm st_rm 

.Xdefaults {from 
/home/fosint2} 

disposition orb.aos.db st_sns 

act.db disposition.pms orb.los.db st_tl 

ActDef etlConfig.db orb.sunrise.db state.db 

Alarm EUConv orb.sunset.db state.db_reinit 

Alarm.pms EUConv.pms orbitEventB.dat Status 

alloc.db event.dat P5Test status 

alloc.db_reinit event.db P5Test.pms Status.pms 

ALPHA1 EventOdf_1.0 pageSystem.dat status.pms 

ALPHA1.pms evtfilter.fdl ParmDataOdf_1.0 STBYonly 

AnalysisOdf_1.0 FixPreferences PidsOdf_1.0 STBYonly.pms 

appropriate fos-services 
file (Configured for the 
user account and unique 
IST host machine.) 

forward.html plan.db subsys.dat 

Aster fos_dba_env.script plot1 SystemOdf_1.0 

Aster.pms fos_sybsetup.script plot1.pms SystemPidsOdf_1.0 

asteract.db FosArch rconn.db test_table1 

ATCLOADGEN FosEnvVars RealTime test_table1.pms 

back.html FosHome.html RealTime.graph test12 

BAP FosNetscape RealTime.pms test12.pms 

bap.db FpTlXtl RealTime.table tlm_calcurve_005.pdb 

cdm_fixdata_005.pdb FuiCommandOdf_1.0 Replay tlm_calcurve_006.pdb 

cdm_fixdata_006.pdb gchw.db Replay.pms tlm_delta_005.pdb 

cfgops GcmrOdf_1.0 ReqManState.dat tlm_delta_006.pdb 

cmd_fixdata_006.pdb GcmrResponse roomSystem.dat tlm_desc_005.pdb 

cfgops.pms GcmrResponse.pms roomUser.dat tlm_desc_006.pdb 

cfgtest gcuser.db rs.db tlm_dstate_005.pdb 

cfgtest.pms GenSched RTS tlm_dstate_006.pdb 

cfgtest1 Header RTS.pms tlm_lgdesc_005.pdb 

cfgtest1.pms Header.pms sc.dat tlm_lgdesc_006.pdb 

cfgtrain1 HKonly Sim tlm_limsel_005.pdb 

cfgtrain1.pms HKonly.pms Sim.pms tlm_limsel_006.pdb 

cmd_desc_005.pdb hw.db srs.db tlm_parm_005.pdb 

cmd_desc_006.pdb IST_Standalone srsconn.db tlm_parm_006.pdb 
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Table 5-2. IST Toolkit Deliverable Data Files (2 of 2) 
Data File Name Data File Name Data File Name Data File Name 

cmd_lgdesc_005.pdb IST_UserStationStartup st_ad tlm_polyconv_005.pdb 

cmd_lgdesc_006.pdb jonspage st_bd tlm_polyconv_006.pdb 

cmd_parm_005.pdb jonspage.pms st_cmdActs tlm_rylim_005.pdb 

cmd_parm_006.pdb MachArch st_cmds tlm_rylim_006.pdb 

cmd_vardata_005.pdb mode.db st_eh Tlm16kDiagOdf_1.0 

cmd_vardata_006.pdb MyKill st_fs Tlm1kDiagOdf_1.0 

cmd_verify_005.pdb myRealTime.table st_fs2 TlmCmdFilterKeys.odf 

cmd_verify_006.pdb myRealTime.table.pms st_fs3 TlmCtiuOdf_1.0 

cmdproc.db Myrequest2.data st_fs4 TLMDecom 

CmdSelectFilterOdf_1.0 Myrequest2.meta st_fs5 TlmDecom 

CMS Myrequest2.out st_fs6 TLMDecom.pms 

command.db ncc_com st_fs7 TlmDecom.pms 

CommandOdf_1.0 ncc_com.pms st_fs9 TlmHealthOdf_1.0 

config.dat ncc_test st_gs TlmHouseOdf_1.0 

data.db ncc_test.pms st_lg TlmSelectFilterOdf_1.0 

DirKeywords.dat NccConfig.data st_lq toolSystem.dat 

st_ns user.db 
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Abbreviations and Acronyms


BAP Baseline Activity Profile


CM configuration management


DAT digital audio tape


ECS EOSDIS Core System


EOSDIS Earth Observing System Data and Information System


FOS Flight Operations Segment


FTP File Transfer Protocol


FUI FOS User Interface


IST Instrument Support Terminal


RAM random access memory


TAR tape archive
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