
7. Common Services 

The FOS includes tools that facilitate ordinary tasks and services. These tools provide the 
following capabilities: 

1. E-mail. 

2. Event Message Monitoring via the Local and Event_Display-Global windows. 

3. Message generation via the Quick-Message Generator. Messages are displayed on the 
Global Event Display window. 

4. User customization. 

5. File transfer via the Data Mover. 

6. Browse on-line documentation via the Document Reader. 

7. Help. 

8. Snapshots. 

9. Display page definition via the Display Builder. 

10. Telemetry monitoring. 

11. Room definition via the Room Builder. 

12. Report generation. 

13. Replay archived telemetry data. 

14. Create Schematic Dynamic Pages with RTWorks. 

7.1 E-mail 

The FOS uses Netscape’s commercial electronic mail software for composing, sending, and 
receiving electronic mail. Open Netscape and refer to Netscape’s online documentation for 
instructions on using Netscape Mail. 

7.2 Event Message Monitoring 

The FOS generates and displays event messages - informational text messages generated by 
processes running at the EOC or IST. Event messages can indicate user actions, limit violations, 
and spacecraft and instrument status. Event messages are categorized by spacecraft ID (i.e., AM1) 
and event types (i.e., RMS). Appendix B contains a list of the FOS event messages which are 
defined in the PDB. 
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To open a Local or Event_Display-Global window: 

The Event_Display-Local window displays events occurring on the userstation. The 
Event_Display-Global window displays events from the EOC, ISTs, the spacecraft, and 
instruments. Open the Local or Event_Display-Global window by clicking Tools... at the bottom 
of the Control window. The Tool Selection dialog box opens. Select Event_Display-Local 
(see Figure 7.2-1) or Event_Display-Global (see Figure 7.2-2) from the list of tools and click 
OK. 

Figure 7.2-1. Event_Display-Local Window 
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Figure 7.2-2. Event_Display-Global Window 

To manipulate the Event Display window: 

The Local and Event_Display-Global windows contain a timeline and scrolling chronological list of 
event messages. The list includes the time, spacecraft ID (if applicable), spacecraft subsystem, the 
FOS subsystem generating the event message, string ID (if applicable) or 0 (if the event message is 
not associated with a string), and the event message text. The event timeline contains a color­
coded tick mark for each event in the listing. Selecting the tick mark in the timeline automatically 
highlights the associated event message. 

To remove the event timeline from the Event Display window and enlarge the scrolling events 
display, click Show Graph. Restore the event timeline by clicking Show Graph again. 

To freeze the scrolling Event Display window, click Lock Scroll. To restore the scrolling 
Event Display, click Lock Scroll. 

To zoom in and out of the Event TimeLine: 

To focus on events occurring in a specific time range, use the mouse to point and drag over a time 
range in the timeline at the top of the Event Display window. A small magnifying glass appears to 
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the left of the time-line and the selected time range becomes the timeline’s new start and stop times. 
To zoom out and restore the view of all events in the timeline, click the Zoom Out to the left of 
the timeline. The zoom out state is the timeline’s default state. 

7.2.1 View Real-Time Event Messages 

Real-time events are displayed on all userstations with an active Event Display window. The 
timeline displays events as they occur, beginning with the first event after the Event Display is 
active on the userstation. 

The Control window displays the three most recent event messages in the Events list box. These 
event messages are color-coded as one of four message types: information - black lettering on gray 
background; warning - black lettering on yellow background; alarm - black lettering on red 
background; or fatal - white lettering on black background. Alarm messages blink on the screen 
until acknowledged. To acknowledge an alarm message, click the blinking message in the Control 
window and click ACK. 

7.2.1.1 Monitor System Event Messages 

Tivoli, a COTS product, monitors system resources at the EOC and generates event messages 
when EOC resources fall outside specified threshold values. These event messages are displayed 
via the Event_Display-Global window at the EOC and at ISTs. Although Tivoli was configured 
when the FOS software was delivered, the EOC System Administrator may reconfigure Tivoli to 
monitor additional or different system resources, specifying threshold values, polling intervals, 
and event messages for monitored resources. At present, Tivoli monitors events including: COTS 
application resources (i.e., Sybase daemon goes down), file system resources (i.e., Local disk 
partition (/usr/var/data/opt/tmp) has fewer than 150 inodes available), system resources (i.e., host 
goes down), network resources (i.e., client RPC bad calls increase 10%), print queues (i.e., 
availability of print queues). The System Administrator should refer to the Tivoli interface for the 
specific events Tivoli monitors and their corresponding threshold limits and polling intervals as 
well as events Tivoli could be configured to monitor. 

7.2.2 Save and Open Events 

Events being displayed in the Event Display window may be saved in ASCII format by selecting 
Save or SaveAs from the File menu. A saved event history file can be opened in a UNIX text 
editor. 

7.2.3 Access the Event History Archive through Netscape 

To access a complete event archive of global event message history, submit an 
FOS Event History form: 

1. Start Netscape and type in the URL for the FOS Event History form, 
http://www.eoc.ecs.nasa.gov/evhistform.html. 
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2. In the Event History form (Figure 7.2.3-1), enter criteria in the fields you want to filter on. 
The following fields are displayed on the Event History form: Spacecraft; Subsystem; 
Spacecraft Time Stamp; FOS Event Type; Severity; FOS Time Stamp; FOS Event ID#; 
FOS Event Message (the message text); FOS Trigger; FOS Host; and Source File. Time 
Stamps are entered as a range of time. Leaving the form blank returns all events in the 
database. 

3. Click Submit. 

4. A Netscape page is returned which displays event messages matching the criteria entered in 
the event history form field (see Figure 7.2.3-2). 
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Figure 7.2.3-1. FOS Event History Form 
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Figure 7.2.3-2. FOS Event History Report 
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7.2.4 Filtering Events 

Events are filtered in order to focus on a particular type of event, or to monitor events generated by 
a designated subsystem or spacecraft. There are two methods of filtering events: selecting filtering 
options under the Filter menu or clicking the Filter toggle box on the Event Display window. 

7.2.4.1 Filter Events via the Filter Menu 

Select a filter under the Filter menu of the Event Display window: Event Type, Subsystem, 
S/C ID (Spacecraft ID), or String ID. 

To filter events by Event Type: 

Select Event Type to activate the Event Type Filter dialog box (see Figure 7.2.4.1-1). To 
display events associated with a particular event type, click in the box next to the event type under 
the columns labeled Show. The events will be displayed in the event display and on the timeline 
in the color indicated in the dialog box. Select Bold to display the event text in a bolded font. 
Click All to set the Show button on all the event types. Click None to clear the Show button 
on all the event types. Click Apply to activate your filter selections in the Event Display window. 
Close the filter dialog box by clicking Close. 

Figure 7.2.4.1-1. Event Type Filter Dialog Box 

To filter events by Spacecraft Subsystem: 

Select Subsystem to activate the Subsystem Filter dialog box (see Figure 7.2.4.1-2). To display 
events associated with a particular subsystem, click in the box next to the subsystem name under 
the columns labeled Show. The events will be displayed in the event display and on the timeline 
in the color indicated in the dialog box. Select Bold to display the events in the event display in a 
bolded font. Click All to set the Show button on all the subsystems. Click None to clear the 
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Show button on all the subsystems. Click Apply to activate your filter selections in the Event 
Display window. Close the filter dialog box by clicking Close. 

Figure 7.2.4.1-2. Subsystem Filter Dialog Box 

To filter events by Spacecraft: 

Select S/C ID to activate the S/C ID Filter dialog box (see Figure 7.2.4.1-3). To display events 
associated with a particular spacecraft, click in the box next to the spacecraft name under the 
columns labeled Show.  The events will be displayed in the event display and on the timeline in 
the color indicated in the dialog box. Select Bold to display the event text in a bolded font. Click 
All to set the Show button on all the Spacecraft Iss. Click None to clear the Show button on 
all the Spacecraft Ids. Click Apply to activate your filter selections in the Event Display window. 
Close the filter dialog box by clicking Close. 
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Figure 7.2.4.1-3. Spacecraft ID Filter Dialog Box 

To filter events by String ID: 

Select String ID to activate the String ID Filter dialog box (see Figure 7.2.4.1-4). Select one or 
more string IDs to filter in the dialog box and click OK. 

Figure 7.2.4.1-4. String ID Filter Dialog Box 

7.2.4.2 Filter Events by String 

To filter events based on a substring in the event text, click Filter in the Event Display window. 
Enter text in the Search String field and click Apply.  Events matching the text entered in the 
Search String field are displayed in the Timeline and Event Display. Click Reset to remove the 
filter and display all events. 
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7.2.5 Search for Events 

To search for events in the Event Display window, click Search in the Event Display window. 
Enter text in the Search String field and click Apply. The first event matching the text entered 
in the Search String field is highlighted in the Event Display. Click Apply again to highlight the 
next occurrence of the string in the Search String field. To clear Search String click Reset. 

7.2.6 Timeline Setup 

The timeline can be configured to graph the events three different ways. Events can be graphed by 
S/C Id, Subsystem, or Event Type. From the Timeline menu select Event Type, Subsystem, 
or S/C Id. When the Event Display window starts, the default setup is Event Type. 

7.3 Quick-Message Generator 

The Quick Message Generator sends messages (up to 240 characters) to every Global Event 
Display active at your site. Messages are assigned one of four severity levels by the sender: 
information - black lettering on gray background; warning - black lettering on yellow background; 
alarm - black lettering on red background; or fatal - white lettering on black background. 

Monitor the messages you send and receive via the Global Event Display window, which displays 
events from the EOC, ISTs, the spacecraft, and instruments in a color corresponding to the 
message’s severity level. 

Start the Global Event Timeline by clicking Tools... at the bottom of the Control window. The 
Tool Selection dialog box opens. Select Event_Display-Global from the list of tools and click 
OK. The Global Event Display window opens (see Figure 7.2-2). 

7.3.1 Send a Quick Message 

1. Start the Quick Message Generator (see Figure 7.3.1-1). 

Click Tools... at the bottom of the Control window. The Tools dialog box opens. Select 
Quick_Message from the list of tools. 

2. Enter a user name, subsystem or any character string. 

Regardless of the text entered in the To: box, the event message will be displayed on every 
userstation at your location with an active Global Event Timeline. 

3. Assign a severity level to the message. 

Click on the Severity menu and select the appropriate level - Info, Warning, Alarm, or 
Fatal. 

4. Type a message. 

Enter a message less than 240 characters in the box below the To: and Severity boxes. 

5. Send or cancel the message. 
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Click Cancel to discard the message or Send to send the message. 

The Event Message Generator closes. 

Figure 7.3.1-1. Quick Message Generator 

7.4 User Customization 

The FOS includes the capability to customize the user’s environment by specifying fonts and 
window colors, selecting default printers, specifying data directories, associating function keys 
with ECL commands, associating the Control window room buttons with user-defined rooms, and 
establishing the background color for dynamic pages (also known as telemetry pages). 

Open the User Customization window (see Figure 7.4-1) by clicking Tools... on the Control 
window or Mini Control window. When the Tool Selection dialog box opens, select User 
Customization from the list of tools and click OK. 

Figure 7.4-1. User Customization Window 
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7.4.1 Specify Fonts and Window Colors 

1.	 Open the Application Colors and Fonts Customization window (See Figure 
7 .4 .1-1)  . 

Click Application Colors & Fonts on the User Customization window. 

The right portion of the Application Colors and Fonts Customization window, labeled 
“Customization Preview”, is a preview area where you can view the color and font changes 
before application. 

2. Set the foreground color. 

Select Foreground from the Color Selector list box and drag the red, green, and blue 
slider bars to the left or right until the desired color is displayed in the preview area. 

3. Set the background color. 

Select Background from the Color Selector list box and drag the red, green, and blue 
slider bars to the left or right until the desired color is displayed in the preview area. 

4. Set the top shadow color. 

Select Top Shadow from the Color Selector list box and drag the red, green, and blue 
slider bars to the left or right until the desired color is displayed in the preview area. 

5. Set the bottom shadow color. 

Select Bottom Shadow from the Color Selector list box and drag the red, green, and blue 
slider bars to the left or right until the desired color is displayed in the preview area. 

6. Select the monospace font. 

Select a font from the list of monospaced fonts. The monospace font selected will update 
all monospace fonts. 
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Figure 7.4.1-1. Application Colors and Fonts Customization Window 

7. Select the general purpose font. 

Select a font from the list of general purpose fonts. The font selected will update all fonts 
except monospace fonts. 

8. Apply the window colors and fonts selected. 

Click OK.  The Application Colors and Fonts Customization window closes. After the 
current session, the window colors and fonts will return to their default settings. 

or 

Click Default to establish the window colors and fonts selected as the default settings. 
Click OK to close the Application Colors and Fonts Customization window. 

7.4.2 Associate the Control Window Room Buttons with Rooms 

1. Open the Room Customization window (see Figure 7.4.2-1). 

Click Rooms on the User Customization window. 

The list box on the left of the window labeled Available Rooms, lists system and user­
defined rooms. The list of numbered rooms on the right labeled Selected Rooms 
represents the rooms associated with the room buttons (list item one represents the room 
associated with R1 on the Control window and so on through R5). 
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2.	 Clear all rooms associated with the room buttons. 

Click Clear All.  If you do not wish to clear the room buttons, skip this step. 

3. Associate a room with one of the Control window room buttons. 

Select the room from the Available Rooms list box which you wish to associate with a 
room button. Using the middle mouse button, drag the selected room to one of the five text 
fields labeled one through five. 

or 

Double click the room in the Available Rooms list box to associate it with the first empty 
list box. 

Figure 7.4.2-1. Room Customization Window 

4.	 Apply the rooms in the Selected Rooms list to the Control window room 
buttons for the current session only. 
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Click OK. The Room Customization window closes. After the current session, the rooms 
buttons will return to their default settings. 

or 

Establish the rooms in the Selected Rooms as the default settings for the 
Control window room buttons. 

Click Default. Click OK to close the Room Customization window. 

or 

Close the Room Customization window without updating the rooms 
associated with the room button. 

Click Cancel. 

7.4.3 Establish the Background Color for Dynamic Pages 

1.	 Open the Dynamic Page Color Intensities Customization window (see  
Figure 7.4.3-1). 

Click Dynamic Page Colors on the User Customization window. 

Figure 7.4.3-1. Dynamic Page Color Intensities Customization Window 
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2. Select the background color for dynamic pages. 

Select a color in the Color Selector list box. Drag the Intensity slider bar to the left or 
right respectively to lighten or darken the background color. 

3.	 Apply the selected background color and close the Dynamic Page Color 
Intensities Customization window. 

Click OK. 

or 

Apply the selected background color and leave the Dynamic Page Color 
Intensities Customization window open. 

Click Apply. 

or 

Close the Dynamic Page Color Intensities Customization window without 
updating the background color. 

Click Cancel. 

7.4.4 Assign an ECL Directive to a Function Key 

1. Open the ECL Directives Customization window (see Figure 7.4.4-1). 

Click Function Keys on the User Customization window. 

2.	 Select an unassigned function key to be associated with an ECL directive. 

Select a function key from the Function Key pull-down menu. 

3. Enter the ECL directive to be associated with the function key. 

Enter an ECL directive in the ECL Directive text field. Click Add to add the function 
key and directive to the table listing directives and their associated function keys. Repeat 
steps 2 and 3 to assign directives to additional function keys. 

4. Reassign a function key. 

Select the function key in the table which you wish to associate with a different directive. 
Click Modify.  The function key is listed in the Function Key pull-down menu. 
Update the directive in the ECL Directive text field and click Add. 

5. Remove the association between a function key and a directive. 

Select one or more rows in the table listing function keys and their associated directives. 
Click Delete. A dialog box opens, prompting you to confirm the deletion of the function 
keys by clicking Yes or cancel by clicking No. 
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Figure 7.4.4-1. ECL Directives Customization Window 

6.	 Update the function keys with the directives listed in the table. 

Click OK. The ECL Directives Customization window closes. 

or 

Cancel changes made to function keys. 

Click Cancel to discard the latest changes made to the assignment of directives to 
function keys. The ECL Directives Customization window closes 

7.5 Data Mover 

The Data Mover allows you to copy local files to a local or remote directory, delete local files, and 
copy remote files to a local directory. 

To open the Data Mover: 

Open the Data Mover by clicking Tools... on the Control window or Mini Control window. The 
Tool Selection dialog box opens; select Data Mover from the list of tools and click OK.  The 
Data Mover window opens (see Figure 7.5-1). 
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Figure 7.5-1. Data Mover Window 

7.5.1 Copy Local Files to a Local Directory 

1. Select Send as the Transfer Type. 

Click Send. 

The Data Mover Send window opens (see Figure 7.5.1-1). If you entered a location and 
directory during the current session, the Location and Directory pull-down menus reflect 
the previously selected location and directory. The text field below the Directory pull-down 
menu is the full path for the previously selected directory. The box below the path lists the 
files in the directory. 

If this is a new session (i.e., you have started the Data Mover and have not entered a 
location or directory) the Location pull-down menu reflects your local location. The 
Directory pull-down menu displays Other by default. The text field below the Directory 
pull-down menu is the full path of your home directory. The box below the path lists the 
files in your home directory. 

2. Select the directory where the files are located. 

Click on the Directory pull-down menu and select the directory where the files to be 
transferred are located, or type the directory into the box below the Directory pull-down 
menu and press <Return>. 
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Figure 7.5.1-1. Data Mover Send Window 

3. Select the files to be transferred. 

The filename and location will appear in the “Selected Files to Send” box. Click on the file 
name of a file to be transferred in the list of files and click Select . Repeat this process 
until all the files to be transferred are listed in the box entitled “Selected Files to Send.” To 
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deselect a file from the list of files, select the file name in the “Selected Files to Send” box 
and click Deselect. 

4. Validate that the destination site reflects your local location. 

Check that the location in the Location pull-down menu reflects your local location. The 
files will be sent to a local transfer directory. 

5. Start the transfer. 

Click Start Transfer. The files in the “Selected Files to Send” list are sent to the local 
transfer directory. The status of the file transfer process is provided in the Status text box 
at the bottom the Data Mover Send window. 

7.5.2 Copy Local Files to a Remote Location 

1. Select Send as the Transfer Type. 

Click Send. 

The Data Mover Send window opens (see Figure 7.5.1-1). If you entered a location and 
directory during the current session, the Location and Directory pull-down menus reflect 
the previously selected location and directory. The text field below the Directory pull-down 
menu is the full path for the previously selected directory. The box below the path lists the 
files in the directory. 

If this is a new session (i.e., you have started the Data Mover and have not entered a 
location or directory) the Location pull-down menu reflects your local location. The 
Directory pull-down menu displays Other by default. The text field below the Directory 
pull-down menu is the full path of your home directory. The box below the path lists the 
files in your home directory. 

2. Select the directory where the files are located. 

Click on the Directory pull-down menu and select the directory where the files to be 
transferred are located or type the directory into the box below and press <Return>. 

3. Select the files to be transferred. 

The filename and location will appear in the “Selected Files to Send” box. Click on the file 
name of a file to be transferred in the list of files and click Select . Repeat this process 
until all the files to be transferred are listed in the box entitled Selected Files to Send. To 
deselect a file from the list of files, select the file name in the “Selected Files to Send” box 
and click Deselect. 

4. Select the Remote destination. 

Select the location where the files will be sent under the Location pull-down menu: 
ASTER, CERES, EOC, MISR, MODIS, MOPITT, SDVF. 
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5. Start the transfer. 

Click Start Transfer.  The files in the Selected Files to Send are sent to the transfer 
directory established at the remote location for incoming files. The status of the file transfer 
process is provided in the Status text box at the bottom the Data Mover Send window. 

7.5.3 Copy Files from a Remote Location 

1. Select Receive as the Transfer Type. 

Click Receive. 

The Data Mover Receive window opens (see Figure 7.5.3-1). The Location pull-down 
menu reflects the default location, your local location. The Directory pull-down menu 
displays Other by default. The text field below the Directory pull-down menu is the full 
path for the default directory. The box below the path lists the files in the default directory. 

2. Select the remote location. 

Click on the Directory pull-down menu and select the directory where the files to be 
transferred are located or type the directory into the box below and press <Return>. 

3. Select the remote directory where the files are located. 

Click on the Directory pull-down menu and select the directory where the files to be copied 
are located. 

4. Select the files to be transferred. 

The filename and location will appear in the “Selected Files to Send” box. Click on the file 
name of a file to be transferred in the list of files and click Select . Repeat this process 
until all the files to be transferred are listed in the box entitled Selected Files to Send. To 
deselect a file from the list of files, select the file name in the “Selected Files to Send” box 
and click Deselect. 
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Figure 7.5.3-1. Data Mover Receive Window 

5. Select the local destination directory. 

Click Select Directory…. The Data Mover Local Directory Selector window opens 
(see Figure 7.5.3-2). Select the destination directory under the Directory pull-down menu. 
The full path for the directory appears in the list box below the directory name. 
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Figure 7.5.3-2. Data Mover Local Directory Selector Window 

To find a directory or file, type filter criteria in the Find text box. Once you have selected 
the destination path, click OK. The Data Mover Local Directory Selection window closes. 

6. Start the transfer. 

Click Start Transfer. The files in the Selected Files to Retrieve are sent to the specified 
directory. The status of the file transfer process is provided in the Status text box at the 
bottom the Data Mover Send window. 

7.5.4 Delete Local Files 

1.	 Select Send as the Transfer Type and select the directory where the files are 
located. 

Click Send. 

The Data Mover Send window opens (see Figure 7.5.1-1). The Location pull-down menu 
reflects the default location, your local location. The Directory pull-down menu displays 
Other by default. The text field below the Directory pull-down menu displays the full path 
of your home directory. The box below the path lists the files in your home directory. 
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2. Select the directory where the files are located. 

Click on the Directory pull-down menu and select the directory where the files to be deleted 
are located. 

3.	 Select the local files to be deleted. 

Click on the name of the files to be deleted in the list of files. 

4. 	 Delete Files. 

Click Delete. The status will be displayed in the Status window for each file deleted. 

7.5.5 Close the Data Mover 

Click Cancel on the Data Mover window. 

7.6 Document Reader 

Document reader enables you to browse, search, and print on-line documentation via the Netscape 
browser. 

7.6.1 Browse a Document 

1. Open Document Reader. 

Open the Document Reader by clicking Tools… on the Control window or Mini-Control 
window. The Tool Selection dialog box opens. Select Document Reader from the list 
of tools and click OK. 

The Netscape browser opens. 

2. Open a World Wide Web (WWW) page. 

Select Open Location from the File menu. The Open Location dialog box opens. Type a 
Universal Resource Locator (URL) in the “Open Location” text field and click Open In 
Browser or Open In Editior. 

The home page opens. 

3. Open a text or html document listed as a link on a home page. 

Click a link on a home page that gives you the option to open a document in text or html 
format. 

or 

Open a text or html file located on a local drive. 

Select Open File from the File menu. The File Open dialog box opens. In the File Open 
dialog box, enter filter criteria in the “Filter” text area or select the directory to open in the 
“Directories” list box. Select the file in the “Files” list box and click OK to close the File 
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dialog box and open the file, or Cancel to close the File dialog box without opening the 
file. 

4. Scroll through the document. 

Page up or down in the document by pressing the <Page Up> or <Page Down> button or 
by pressing the up or down arrows at the top and bottom of the slider bar. 

5. Find text in the document. 

Select Find… under the Edit menu. Type the text in the Find dialog box, select the “Find 
Backwards” box to search back in the document and click the case sensitive toggle box to 
make the search case sensitive, and click Find. The next occurrence matching the text 
you entered is highlighted. Click Close to close the Find dialog box or Find to locate 
the next string matching the text you entered. If no text is found matching your entry in the 
direction you are searching, a dialog box opens indicating the search string was not found. 

6. Save the document. 

Select Save As from the File menu. The Save As dialog box opens. Select the folder to 
save the message in, select the file format. 

7. Edit the document. 

You cannot edit the document via the Netscape browser. Once you have saved the file, edit 
it using a text editor, such as vi or emacs, if the document was saved as a text file. 

8. Print the document. 

Specify the page setup by selecting Page Setup from the File menu. The Page Setup 
dialog box opens. Choose the setup options desired and click OK to apply the print 
options or Cancel to restore the default settings. Select Print from the File menu. The 
Print dialog box opens. Specify the printer, number of copies and print range; Click OK to 
print the range you indicated or Cancel to cancel the print job. The Print dialog box 
closes. 

9.	 Close the document. 

Select Close from the File menu. 

10. Close or minimize Netscape. 

Close Netscape by selecting Exit from the File menu. Minimize Netscape by selecting 
Minimize from the Netscape menu, located underneath the button in the top left corner of 
the Netscape window, or the button near the upper right corner. 

7.7 On-Line Help 

Access help by clicking the Help button in the window where you need help. The Netscape 
browser opens to a home page displaying context-sensitive help. To access the overview help 
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page which provides a list of help topics and links to help pages (see Figure 7.7-1), click the home 
button at the top of the Netscape window from any context sensitive page. 

Figure 7.7-1. FOS Overview Help Page 

7.8 Snapshots 

The FOS uses commercial software (xv) to capture snapshots of windows to a file or send 
snapshots to a printer. These instructions are for xv version 3.00. 

7.8.1 Take a Snapshot of a Window 

1. Open xv via UNIX. 
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xv 

Enter the UNIX command initiating xv in a UNIX xterm window. 

The xv window opens (see Figure 7.8.1-1). 

2. Open the xv controls window. 

Position the pointer anywhere on the xv window and click the right mouse button to open 
the xv controls window (see Figure 7.8.1-2). 

3. Snap a window. 

Click Grab and then click the window you want to snap. The snapped window is 
duplicated on the screen and a message in the message bar on the xv controls window 
indicates the size of the captured window and indicates that all desired colors were 
captured. 

4. Save the snap to a file. 

Click SAVE. The xv save window opens (see Figure 7.8.1-3). Select the directory 
where the file should be saved, the file format, and color option. Type a file name in the 
Save file box and click OK. 

5. Open the saved file. 

Open the file you just saved by clicking Load , selecting the directory and file name, and 
clicking OK. The window snap opens. 

6.	 Print the snap. 

Enter the UNIX print command. 

lpr filename 

or 

You can include the following alias in your startup script (i.e. .cshrc) to simplify the 
printing of snaps (printer variable must be set): 

alias prscreen “sleep10; xwd -frame | xpr -device ps | lpr” 

then type prscreen at a UNIX prompt, then click on your window. 

7. Close xv. 

Click Quit. 
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Figure 7.8.1-1. xv Window 

Figure 7.8.1-2. xv controls Window 
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Figure 7.8.1-3. xv save Window 

7.9 Display Builder 

The Display Builder tool enables you to create telemetry display screens called “dynamic pages.” 
A dynamic page displays parameters from the logical strings associated with that page. These 
parameters or mnemonics can be displayed on a dynamic page as tables, graphs, or alphanumeric 
fields. Once you have created a page and made the page locally or globally available via the 
Control window by selecting Build to Local or Build to CM, you can monitor telemetry on 
the page. Refer to Section 7.10 for instructions on monitoring telemetry on a dynamic page. 

7.9.1 Start Display Builder 

Open the Display Builder. 

Click Tools… on the Control window or Mini Control window. The Tool Selection 
dialog box opens; select Display Builder from the list of tools and click OK. 

The Display Builder Palette, Display Item Format, Data Display Item Data Sources, and 
Display Builder Console windows open. An empty dynamic page also opens in the 
Display Builder’s Dynamic Page window (see Figure 7.9.1-1). 

The Display Builder Palette and Dynamic Page remain open while the Display Builder Tool 
is running. To hide the Display Item Format, Display Item Data Sources, or Console 
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windows, select the name of the window from the Window menu of the Display Builder 
Palette window. 

Figure 7.9.1-1. Display Builder Windows (Palette, Format, Data Sources, 
Dynamic Page, and Console) 

7 .9 .2 Create a New Dynamic Page 

When the Display Builder Tool starts, the Display Builder’s Dynamic Page window opens with an 
empty page for editing. You can discard the page being edited and start over with a blank dynamic 
page by selecting New  from the File menu of the Display Builder Palette window (see 
Figure 7.9.2-1). 
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Figure 7.9.2-1. Display Builder Palette Window 

7.9.3 Open an Existing Dynamic Page 

1.	 Select Open from the File menu of the Display Builder Palette window. 

The Open dialog box opens (see Figure 7.9.3-1). 

2.	 Filter on dynamic pages in your local pages directory. 

Click Local. 
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The dynamic pages in the pages subdirectory of your home directory are listed in the Files 
list box. 

or


To filter on global system pages.


Click System.


The system dynamic pages are listed under Files. 

or 

Enter your own filter criteria. 

To define filter criteria, such as a path or file extension, type the criteria in the Filter text 
box. 

Figure 7.9.3-1. Open Dialog Box 

3. Select the dynamic page file to open from the Files list box. 

Highlight the file name and click OK. 

The dynamic page file opens and the Open dialog box closes. 

4. Save the file. 

Select Save or SaveAs from the File menu of the Display Builder Palette window and 
enter a lower case file name for the dynamic page. Upper case letters are not permitted in a 

7-33 609-CD-005-004




dynamic page file name. Note that saving the file does not make the page accessible via the 
Control window. Refer to Section 7.9.11 for instructions on making a dynamic page 
accessible via the Control window. 

5. Monitor the status of file operations. 

The Display Builder Console window (see Figure 7.9.3-2) provides status on file 
operations. 

Figure 7.9.3-2. Display Builder Console Window 

7.9.4 Associate a Logical String with a Dynamic Page 

One or more logical strings must be associated with each dynamic page. The dynamic page 
displays parameters you select from the available parameters for logical strings associated with the 
page. Refer to Section 9 for a discussion of logical strings. 

1.	 Open the Dynamic Page Logical String Management window (see Figure 
7 .9 .4-1)  . 

Select Logical String Management from the Page menu of the Display Builder Palette 
window. 

2. Select the Source and Mode. 

Specify the Source  (Real-Time, Replay, or Simulation) and Mode  (Operational, 
Test or Training) by selecting the appropriate options from the pull-down menus. 
Restore Source and Mode to their default settings by selecting * under the Source and 
Mode pull-down menus. 

The logical strings with attributes matching the source and mode selected appear in the list 
box. Repeat step 2 to include additional logical strings with different Sources and Modes 
in the list box. 
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Figure 7.9.4-1. Dynamic Page Logical String Management Window 

3. Establish the logical strings to associate with the dynamic page. 

Select the logical strings from which parameters will be chosen by selecting the strings in 
the Logical String Management List box and clicking Add.  To remove a logical string 
from the list box, highlight the string and click Remove. 

Once the list box contains the logical strings you want to associate with the dynamic page, 
click OK. 

7.9.5 Add a Display Item, Table or Graph to a Dynamic Page 

One or more logical strings must be associated with the dynamic page as described in section 7.9.4 
prior to adding a display item, table or graph to a dynamic page. On the Display Builder Palette 
window, click a Display Item (Field, Label, or Separator), or an item under Tables & 
Graphs (Table or 2D Graph). Drag the item to the Display Builder Dynamic Page and release 
the mouse button. 

Display items may be repositioned by clicking the item in the dynamic page and moving it with the 
mouse. Additional formatting options are available on the Display Item Format window. The 
options available in the Display Item Format window change based on the item selected for editing 
in the dynamic page (field, label, separator, or graph). 
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7.9.6 Associate a Parameter with a Display Item on a Dynamic Page 

A field, table, or graph displays data from the parameters associated with the display item. A field 
may be associated with one parameter, a table with up to 50 parameters, and a graph may have up 
to six parameters plotted along its y-axis against either spacecraft time or another parameter. 

1. Select a field, table, or graph on the dynamic page. 

2. Click Add  on the Display Item Data Sources window (Figure 7.9.6-4). 

The Display Item Parameter Selector dialog box opens (see Figure 7.9.6-1). Click Filter 
on the Display Item Parameter Selector dialog box. The Selection Filter Dialog box opens 
(see Figure 7.9.6-2). 

Figure 7.9.6-1. Display Item Parameter Selector Dialog Box 
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Figure 7.9.6-2. Selection Filter Dialog Box 

3. Filter parameters. 

On the Selection Filter, select the Spacecraft and Instrument to filter on. If applicable, 
select a sample type in the Sample Type list box. Click the Select button to move the 
highlighted parameter categories to the Selected list box. To remove a parameter category 
from the list of selected parameters, click the parameter in the Selected list box and click 
the Remove button. Once the Selected list box includes the parameter categories from 
which you want to select mnemonics, click OK. The Selection Filter dialog box closes and 
the Selection Filter list box on the Display Item Parameter Selector dialog box is updated 
with the parameter categories selected (see Figure 7.9.6-3). 
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Figure 7.9.6-3. Display Item Parameter Selector Dialog Box 

4. Select parameters to display. 

On the Display Item Parameter Selector dialog box, select a filter in the Selection Filter list 
box or click All to display a list of mnemonics in the Available Parameter list box. 
Select one or more parameters in the Available Parameter list box and press the ‚ 
button or press All‚ to move all parameters in the Available Parameters list to the 
Selected Parameters list box. 

Remove a parameter from the Selected Parameters list box by highlighting it and clicking 
· or click ·All to remove all parameters from the list. Once the Selected 
Parameters list box includes the parameters you want to associate with the display item, 
click OK.  The Display Item Parameter Selector dialog box closes and the selected 
parameters are applied to the field, table or graph. If more parameters are selected than are 
allowed to be associated with a field, table, or graph, the first parameter up to the total 
number of parameters allowed will be associated with the display item. 

5. View the parameters associated with a display item. 

Select the field, table, or graph. The parameter associated with the selected display item are 
listed in the Display Item Data Sources window (see Figure 7.9.6-4). 
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Figure 7.9.6-4. Display Item Data Sources Window 

6. Set the update rate for the page. 

Select Update Rate from the Page menu on the Display Builder Palette. The Update Rate 
dialog box opens (see Figure 7.9.6-5). Enter an update rate and click OK. 

Figure 7.9.6-5. Update Rate Dialog Box 

7.9.7 Edit Display Items on a Dynamic Page 

To edit labels: 

1. Select the label to be edited on the dynamic page. 

The options available in the Display Item Format window (see Figure 7.9.7-1) change 
based on selection of a label to be edited in the dynamic page. 
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Figure 7.9.7-1. Display Item Format Window 

2. Type the label and select formatting options. 

Type the label and select its alignment, position and color. Click Apply to update the label 
on the Dynamic Page. 

or 

Click Close to hide the Display Item Format window without updating the label. The 
formatting changes made prior to selecting Close will not be applied to the label. These 
changes remain in the Display Item Format window and can be applied when the window 
is reopened by selecting Apply. 

To edit separators: 

1.	 Select the separator (a horizontal or vertical line) to be edited on the 
dynamic page. 

The options available in the Display Item Format window change to formatting options for 
a separator as displayed in (see Figure 7.9.7-2.) 
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Figure 7.9.7-2. Display Item Format Window 

2. Select separator formatting options. 

Select the orientation, height, width and position of the separator. Click Apply to update 
the separator with the formatting options selected. 

or 

Click Close to hide the Display Item Format window without updating the label. The 
formatting changes made prior to selecting Close will not be applied to the separator. 
These changes remain in the Display Item Format window and can be applied when the 
window is reopened by selecting Apply. 

7.9.8 Edit a Field 

A field displays data from one parameter. 

1. Select the field to be edited on the dynamic page. 

The options available in the Display Item Format window change to reflect the selection of 
a field (see Figure 7.9.8-1). 
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Figure 7.9.8-1. Display Item Format Window 

2.	 Adjust the position, width and height for the field. 

Change the x and y coordinates, width or height of the field, if desired. 

3. Select the Field Components to display. 

Click the box next to the field components (Label, Units, Flag) to be displayed for the 
field. 

4. Select the Value Format. 
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Enter the text width, conversion type (Converted, Decoded or Raw), display type 
(Formatted, Hex, Octal, Binary, or Scientific Notation), alignment (Left, Center 
or Right), and the number of significant digits to show. 

5. Select the Label Format. 

Enter the text width, content (Mnemonic or Descriptor), and alignment (Left, Center, 
Right) for the label. 

6.	 Select the Units Format. 

Select the alignment for the units (Left, Center or Right). 

7. Apply the formatting to the Field. 

Click Apply to update the field with the formatting options selected. 

or 

Click Close to hide the Display Item Format window without updating the field. The 
formatting changes made prior to selecting Close will not be applied to the field. These 
changes remain in the Display Item Format window and can be applied when the window 
is reopened by selecting Apply. 

7.9.9 Edit a Table 

1. Select the table to be edited on the dynamic page. 

The options available in the Display Item Format window change to reflect the selection of 
a table in the dynamic page (see Figure 7.9.9-1). 

Figure 7.9.9-1. Display Item Format Window 
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2. Format the Table. 

Adjust the position and size of the table, if desired. Type a title for the table and select the 
format for the table columns (Mnemonic or Descriptor). Click Apply to update the 
table with the formatting options selected. Figure 7.9.9-2 is a dynamic page displaying 
sample data. 

or 

Click Close to hide the Display Item Format window without updating the table. The 
formatting changes made prior to selecting close will not be applied to the table. These 
changes remain in the Display Item Format window and can be applied when the window 
is reopened by selecting Apply. 

Figure 7.9.9-2. Dynamic Page Containing a Table 

7.9.10 Edit a Graph 

To edit a graph’s axes: 

1. Select the graph to be edited on the dynamic page. 

2. Format the graph. 
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Adjust the size and position of the graph by updating its x and y coordinates, width and 
height. Type a title in the Title list box and select the elements to display (Legend, Grid, 
Axes, Footer) in the graph. 

3.	 Select Axes from the Edit pull-down menu on the Display Item Format 
window. 

The options available in the Display Item Format window (see Figure 7.9.10-1) change to 
reflect the selection of axes from the Edit pull-down menu. 

Type the axes labels. Enter the x display interval (frequency of data refreshment), 
minimum and maximum axes values to display, and axes granularity (line thickness). One 
unit of time is 1.00000 day (24 hours). Click Apply to update the graph with the 
formatting options selected. 

or 

Click Close to hide the Display Item Format window without updating the graph. The 
formatting changes made prior to selecting close will not be applied to the graph. These 
changes remain in the Display Item Format window and can be applied when the window 
is reopened by selecting Apply. 
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Figure 7.9.10-1. Display Item Format Window 

4.	 Select Legend from the Edit pull-down menu on the Display Item Format 
window. 

The options available in the Display Item Format window (see Figure 7.9.10-2) update to 
reflect legend formatting options. 

Select the position and border for the legend and click Apply to update the legend with the 
formatting options selected. 

or 
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Click Close to hide the Display Item Format window without updating the legend. The 
formatting changes made prior to selecting close will not be applied to legend. These 
changes remain in the Display Item Format window and can be applied when the window 
is reopened by selecting Apply. 

Figure 7.9.10-2. Display Item Format Window 

5.	 Select Color and Line Style from the Edit pull-down menu on the Display 
Item Format window. 

The options available in the Display Item Format window (see Figure 7.9.10-2) update to 
reflect color and line style formatting options. Select a parameter in the Parameter list box 
and select the attributes to associate with the line from the Line, Point, Color and Limit Line 
pull-down menus. Click Apply to update the graph with the formatting options selected. 

or 
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Click Close to hide the Display Item Format window without updating the graph. The 
formatting changes made prior to selecting close will not be applied to graph. These 
changes remain in the Display Item Format window and can be applied when the window 
is reopened by selecting Apply. 

Figure 7.9.10-3. Display Item Format Window 

6.	 Select Footer from the Edit pull-down menu on the Display Item Format 
window. 

The Display Item Format window updates to reflect footer formatting options as displayed 
in Figure 7.9.10-4. 

Type the footer and select the footer border type. Click Apply to update the graph with 
the formatting options selected. 
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or 

Click Close to hide the Display Item Format window without updating the footer. The 
formatting changes made prior to selecting close will not be applied to footer. These 
changes remain in the Display Item Format window and can be applied when the window 
is reopened by selecting Apply. 

Figure 7.9.10-4. Display Item Format Window 

To display Minimum, Maximum and Current mnemonic values: 

To display the minimum, maximum, and current values for a graphed mnemonic, click on the line 
representing the mnemonic. The values are displayed at the bottom of the graph. 

7.9.11 Save the Dynamic Page 

Select Save or SaveAs from the File menu of the Display Builder Palette window to open the 
Save dialog box. Click on the Local button if you intend to build the page to local, click on the 
System button if you intend to build the page to CM. Local pages are saved to the “pages” 
subdirectory of your home directory while system pages are saved to …/displaydefs. Note that 
saving the file does not make the page accessible via the Control window. Refer to Section 7.9.12 
for instructions on making a dynamic page accessible via the Control window. 
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7.9.12 Add a Dynamic Page to the List of Pages under the Control 
Window 

Saving a dynamic page does not make the file accessible via the Control window where you enter 
ECL directives and connect to a logical string. To enable the page definition file to display 
telemetry while you are connected to a logical string, you must perform the following actions. 

1. Open the file and select Build to Local or Build to CM. 

Open the file you wish to make accessible to the Control window. If you wish to store the 
page definition file with your locally defined page definition files, select Build to Local 
under the File menu of the Display Builder Palette window. If you wish to store the file in 
the shared directory containing the global page definitions, select Build to CM. 

NOTE 
Selecting Build to CM makes display pages available in the system

"displaydefs" directory on the network or standalone machine where the

FOS software is installed. For example, if a user at an IST selects

Build to CM, the page is copied to the "displaydefs" directory at the

IST. Furthermore, pages in the "displaydefs" directory at the EOC are

not visible to ISTs. ISTs and the FOT can exchange display page files

via FTP or email. Newly received page files must be opened, saved to

the local "pages" or system "displaydefs" directory and "built to

local" or "built to CM" in order to be visible in the list of files

accessed via the Tlm Wins_ button on the Control window.


2.	 Enable the dynamic page to be persistent in rooms where the Display 
Builder is not open. 

Once the page definition has been Built to Local or Built to CM, the dynamic page can be 
present in rooms other than those containing the Display Builder tool. Select Persistent 
under the Pages menu of the Display Builder Palette window. 

Once you select Build to Local or Build to CM, the page is accessible via the Control 
window. Open the Dynamic Page dialog box by clicking Tlm Wins… and select a page 
to open. 

7.9.13 Exit the Display Builder 

Select Quit under the File menu of the Display Builder Palette window. 

7.10 Monitor Telemetry on a Dynamic Page 

After creating a dynamic page and making it accessible via the Control window as described in 
Section 7.9, you can monitor telemetry by connecting to a real-time logical string and opening a 
dynamic page. In addition, you can switch the data source being displayed from one logical string 
to another string and create a temporary dynamic page. 
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The FOS provides two tools for controlling telemetry displays in an active dynamic page, the Data 
Source Selector and Quick Analysis, which are described here in detail. As long as the page is 
persistent, the Display Builder tool need not be open. Access a dynamic page telemetry menu by 
opening an active dynamic page, positioning the mouse pointer on the active page, and clicking the 
right mouse button. The dynamic page telemetry menu and associated telemetry monitoring 
functions are only accessible via an active dynamic page. The dynamic page telemetry menu 
includes the following options: 

a.	 Pause/Resume: Pause suspends the update of parameters on a dynamic page. Once 
Pause is selected, the menu option changes to Resume, continuing the update of 
parameters on the page. 

b.	 Data Source Selector. The button opens the Data Source Selector window displaying 
logical string information and enabling you to switch between strings. 

c.	 Quick Analysis: The Quick Analysis button opens the Quick Analysis window enabling 
you to build a temporary dynamic page to display telemetry mnemonics. 

d.	 Converted:  The value of a parameter’s mnemonic in a converted format designed to be 
comprehensible without interpretation. (May be a string or decimal.) 

e. Decoded: The parameter’s mnemonic displayed as a floating point number. 

f. Raw: The parameter’s mnemonic displayed in hexadecimal format. 

Data Source Selector 

The Data Source Selector window displays all logical strings your current connections, as well as 
all strings available for connection. It also enables you to switch the strings being displayed. 
Although you can switch between strings being displayed, you may not change the number of 
strings being displayed on the string while the page is active. Prior to switching to a string, 
connect to the string as described in Section 9. You must be connected to a string prior to 
switching to that string. Changes in the strings being displayed on the page are not saved and 
consequently do not affect the page file. 

To switch between logical strings: 

1. Open a dynamic page. 

Click TlmWins… on the Control window to open the Telemetry Window Selection Box 
. Select a dynamic page from the list and click OK. 

2. Open the Data Source Selector window (see Figure 7.10.1-1). 

Position the pointer on the dynamic page, click the right mouse button and select Data 
Source Selector from the menu. 

7-51 609-CD-005-004




Figure 7.10.1-1. Data Source Selector 

All logical strings you are connected to are displayed in the window’s Assigned 
Connections table. All logical strings available for connection, including strings you are 
connected to, are listed in the Established Connections table. Choose one of the three 
options from the pull-down menu above the Established Connections table to display 
strings with processes running on your userstation (Local WKS), strings with processes 
running on the Real-Time server (Real-Time Server), or all logical strings (All). 

3. Connect to a logical string. 

If you are not connected to the string you wish to switch to, connect to the string as 
described in Section 9.6. After connecting to the string, click Refresh to update the 
Established Connections table to include the string. 

4. Switch between logical strings. 

Select a string in the Assigned Connections table and a string in the Established 
Connections table and click Switch Connection. 

5. Close the Data Source Selector. 

Click Close. 

Quick Analysis 

The Quick Analysis window enables you to create a temporary telemetry display page for analysis 
purposes. Parameters displayed on the page may be selected from the parameters displayed on the 
current, active dynamic page or the parameters from the string(s) associated with the dynamic page 
which are not currently displayed. Once the parameters for the temporary dynamic page are 
selected, they may be displayed in one of four formats: 

a. Telemetry Attributes. Display parameter attributes. 

b. Alphanumeric. Display parameters in field rows. 
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c. Table. Display parameters in a table. 

d. Graph. Display parameters in a graph. 

To create a temporary Telemetry Display page on the fly: 

1. Open a dynamic page. 

Click TlmWins… on the Control window to open the Telemetry Window Selection Box. 
Select a dynamic page from the list and click OK. 

2. Open the Quick Analysis window (see Figure 7.10.2-1).From a Dynamic Page: 

b.	 Position the pointer on the dynamic page, click the right mouse button, and select 
Quick Analysis from the menu. If Quick Analysis is accessed from a dynamic 
page, only the selected parameters in the open dynamic page will be available for the 
temporary dynamic page. These parameters will be listed in the Available list box on 
the Quick Analysis window. 

c. From The Control Window: Click Tools... at the bottom of the Control window. The 
Tools dialog box opens. Select Quick Analysis from the list of tools and click OK. 
If Quick Analysis is accessed from the Control window, the parameters from strings 
you are connected to may be displayed on the temporary dynamic page. 

3. Select parameters to display on the temporary dynamic page. 

a. If you accessed Quick Analysis from an open, active dynamic page: 

Parameters displayed on the dynamic page are listed in the Available list box if the 
parameters are selected on the dynamic page. Add additional parameters to the 
Selected list box by highlighting them in the Available list box and moving them to 
the list of selected parameters as described in step 4. 

b. If you accessed Quick Analysis from the Control window: 

Filter parameters by spacecraft subsystem. 

Click Filter… to open the Selection Filter dialog box. Select the spacecraft and 
instrument(s) to filter by from the Spacecraft and Instrument list boxes and click 
Select›. Once the Selected list box reflects the spacecraft and instruments you wish 
to filter by, click OK to close the Selection Filter dialog box. The parameters in the 
Available list box reflect parameters for the subsystems you selected. 

or 
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. 

Figure 7.10.2-1. Quick Analysis Window 

Select spacecraft subsystem(s) from which you wish to select parameters: Click the 
check box next to the pertinent subsystem(s) to add parameters for those subsystem(s) 
to the Available list box. 

4. Add parameters to the Selected list box. 

Select parameter(s) in the Available list box and click. To copy all available parameters to 
the Selected list box, click All. To remove parameters from the Selected list box, select 
the parameter(s) to be removed and click . Remove all parameters by clicking All. 

5. Select the format for the temporary display page. 

Once the Selected list box includes the parameters to be displayed on the temporary 
telemetry display page, select one of the four display options: Telemetry Attributes, 
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Alphanumeric, Table, or Graph. If the Telemetry Attributes or Alphanumeric 
format option is selected, proceed to step 7. 

6. Format the table. 

If the Table display option is sleeted, open the Table Format dialog box by clicking 
Format…. 

Enter a table title and select mnemonic or descriptive table names. 

7. Format the graph. 

If the Graph display option is selected, open the Graph Format dialog box (see Figure 
7.10.2-2) by clicking Format…. 

a. Enter a graph title and select graph formatting options. 

b. The options are: 

1. Title 
2. Show 

a) Legend 
b) Grid 
c) Axes 
d) Footer 

3. Edit 
e) Axes 
f) Legend 
g) Color & Line Style 
h) Footer 

8. Monitor telemetry via the temporary dynamic page. 

Click OK. 
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Figure 7.10.2-2 Graph Custom Dialog Box 

7.11 Room Builder 

The Room Builder tool enables you to create or modify room definitions. A room definition is a 
group of one or more windows, their size, position on the screen, and state (default or tiled) all are 
saved under a room name. The windows that comprise a room definition are called pages and may 
be tools or dynamic pages. The Control window is persistent in every room. Room definitions 
may be temporary - saved for the current session, or permanent - saved for future sessions. 

7.11.1 Define a New Room 

1. Select the Pages to Comprise the Room. 
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Open the tools and dynamic pages to be included in the room definition. To open a tool, 
select it from the Tools menu of the Control window. To open a dynamic page, click 
TlmWins… on the Control window to open the Dynamic Page dialog box. Select a 
dynamic page from the list and click OK. 

2. Position and Size Pages in the Room. 

Move and resize the windows on the screen into the desired room configuration with the 
mouse or by entering the PAGE directive followed by the appropriate subdirective in the 
Control window’s command line. The PAGE directive includes subdirectives for opening 
and manipulating a dynamic page. In addition, the frequency with which data displayed on 
the dynamic page is updated when you are attached to a logical string can be set via the 
PAGE directive. Refer to Appendix A for a complete list of ECL directives and their 
syntax. 

3. Establish the State of each Page in the Room. 

Iconify or restore windows into the desired room configuration using the Window menu or 
by entering the PAGE directive followed by the appropriate subdirective in the Control 
window command line. 

4. Open the Room Builder window (see Figure 7.11.1-1). 

Click Tools... at the bottom of the Control window. The Tools dialog box opens. Select 
Room Builder from the list of tools and click OK. 

5. Enter a Name for the Room Definition. 

Enter a name for the room in the Name text box of the Room Builder window. 

6. Save the Room Definition. 

To save the room definition for the current session only, click Temporary.  To save the 
room definition for future sessions, click Permanent. 

7. Establish the Current Configuration of the Room as Tiled or Untiled. 

Each room definition may have two settings, default and tiled. Although these two settings 
are categorized as default and tiled, the two states may include windows in any setting ­
tiled or untiled. 

To establish the current configuration of the room as the default setting, click Default. 

If desired, alter the room’s configuration to reflect the configuration you wish to delineate 
as the tiled layout and click Tiled. 

8. Close the Room Builder tool. 

Click OK. 

The Room Builder window closes. The newly defined room is listed under the 
Rooms… button on the Control window. 
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Figure 7.11.1-1. Room Builder Window 

7.11.2 Modify an Existing Room 

1. Enter the room to be modified. 

Select the name of the room under the Rooms… button on the Control window or enter 
the ROOM directive in the Control window’s command line. 

2. Update the room’s configuration or . 

Add, delete, reposition, resize, or iconify windows as described in steps 1 through 3 of 
Section 7.11.1. 

3 Open the Room Builder window. 

Click Tools... at the bottom of the Control window. The Tools dialog box opens. Select 
Room Builder from the list of tools and click OK. 

4.	 Enter the Name of the Room Definition. 

Enter the room’s name in the Name text box of the Room Builder window. 

5. Save the Room Definition. 

To save the room definition for the current session only, click Temporary.  To save the 
room definition for future sessions, click Permanent. 
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6. Establish the Current Configuration of the Room as Tiled or Untiled. 

Each room definition may have two settings, default and tiled. Although these two settings 
are categorized as default and tiled, the two states may include windows in any setting ­
tiled or untiled. 

To establish the current configuration of the room as the default setting, click Default. 

If desired, alter the room’s configuration to reflect the configuration you wish to delineate 
as the tiled layout and click Tiled. 

7.	 Close the Room Builder tool. 

Click OK. 

The Room Builder window closes. The existing room has been modified. 

7.11.3 Switch Between Rooms 

1. Enter the First Room. 

Click Rooms… to open the Rooms dialog box and select the room from the list or enter 
the ROOM directive in the Control window command line. 

2. Enter the Second Room. 

Select the name of a second room under the Rooms… button on the Control window 
or enter the ROOM directive in the Control window command line. 

The first room is not visible. The second room definition is visible on the screen. 

3. Switch Back to the First Room. 

Click the left arrow button on the Control window. 

The second room you entered is not visible. The first room definition is visible on the 
screen. 

4.	 Switch Back to the Second Room. 

Click the right arrow button on the Control window. 

The first room is not visible. The second room definition is visible on the screen. 

7.11.4 Delete an Existing Room 

1. Enter the room to be deleted. 

Click Rooms… and select the name of the room from the Rooms dialog box or enter the 
ROOM directive in the Control window command line. 

2. Open the Room Builder window. 
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Click the Tools... button at the bottom of the Control window. The Tools dialog box 
opens. Select Room Builder from the list of tools and click OK. 

3. Delete the open room definition. 

Click Delete or enter the ROOM DELETE directive in the Control window command 
line. 

7.12 Report Generator 

The Report Generator is not currently a FOS capability. Once Report Generator capabilities are 
implemented, this section of the Operations Tools Manual will be updated. 

7.13 Data Replay Controller 

The Data Replay Controller enables you to replay archived telemetry data and control the replay 
rate. Data played back from the database is displayed via system- or user-defined dynamic pages. 
Refer to the Display Builder section for instructions on creating, modifying, and making user­
defined telemetry (dynamic) pages accessible via the Control window. 

The data replay session can be dedicated - active on one userstation, or shared between multiple 
userstations. Any user may initiate a dedicated replay session or connect to an established shared 
replay session. However, a shared replay session may only be initiated by a user authorized to 
take Ground Control Authority. Prior to initiating a dedicated or shared replay session, open a 
dynamic page to view the telemetry data as described in the following text. 

7.13.1 Open a Dynamic Page 

Open one or more dynamic pages by clicking TlmWins… on the Control window to open the 
Telemetry Window Selection box. Select a dynamic page from the list and click OK.  The 
dynamic pages will display parameter value changes that occurred during the interval specified in 
the data replay request. Once you have opened dynamic pages to display telemetry data, initiate a 
dedicated or shared replay session, or connect to a shared replay session. 

Open the Data Replay Window: 

Open the Data Replay window (see Figure 7.13.1-1) by clicking Tools... at the bottom of the 
Control window. The Tools dialog box opens. Select Replay Control from the list of tools 
and click OK.  When the Data Replay Controller opens, the options in the bottom portion of the 
screen will be grayed out. 
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Figure 7.13.1-1. Data Replay Window 

7.13.2 Dedicated Replay 

On the Data Replay Controller window, select the spacecraft, database, data type, replay type 
(dedicated), and replay rate under Replay String Specification. Enter the year, day, and time to 
start and stop the telemetry data replay in spacecraft time format. Click Submit Request to 
submit the request. Click Cancel Request to discard the request. Once a request for archived 
telemetry data has been submitted by clicking Submit Request, the buttons in the bottom 
portion of the portion of the Replay Controller window are accessible. 
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To play archived telemetry data from a dedicated logical string: 

The default begin time listed in the Begin Time dialog box is the start time submitted in the data 
replay request. However, you can shorten the playback interval by typing a new begin time that is 
subsequent to the start time in the Begin Time dialog box. Click Play; the data replay begins at 
the time specified in the Begin Time dialog box. 

Monitor the dynamic page as it updates to reflect the telemetry data being played. The start and 
stop time span for the data replay is displayed in the bottom half of the Replay Controller window. 
As data plays, its time is displayed between the start and stop times, and the slider bar moves from 
left to right. To move ahead or behind in the replay time span, click the slider bar and drag it to the 
left or right. 

Pause the replay by clicking Pause .  Adjust the replay rate (in kilobits per second) by clicking 
the up or down arrow next to the Replay Rate dialog box. Click Play to play the data at the newly 
entered replay rate. To play the data starting from the begin time, click Reset. 

To step through archived telemetry data: 

Stepping through archived telemetry data enables you to play segments of the data span 1 to 59 
seconds long. Drag the slider bar to the starting point for the step. Select a duration for the step 
interval in seconds by clicking the up and down arrows next to the Step Interval dialog box. Click 
Step .  The interval plays for the number of seconds specified in the step interval text box and 
stops. Click Step to continue playing segments of the replay interval or Play to play the data at 
the rate specified in the Replay Rate dialog box. 

To terminate the data replay session: 

End the data replay session by clicking Kill. A dialog box opens, requesting that you verify your 
request to terminate the replay. Click OK to terminate the session or Cancel to cancel the 
termination request. The fields on the Replay Controller window return to their default settings, 
the start and stop times are blank, and the buttons in the lower portion of the window are grayed 
out. 

7.13.3 Shared Replay 

To initiate a shared replay session you must be eligible to receive Ground Control authority. Before 
submitting the request for a shared replay, connect to a logical string in a mirrored configuration, 
assume ground control privilege for the string you are connected to, create a shared logical string, 
connect to the newly created string in a mirrored configuration and, finally, assume ground control 
authority for the string. Detailed instructions are outlined in the following text. To connect to a 
shared replay session, refer to Section 7.13.4. 

To connect to a real-time logical string: 

In the command line of the Command Control window, enter the STRING CONNECT directive 
to associate your user station with the logical string established for the shared replay, for example 
STRING CONNECT STRING=100 CONFIG=MIRROR. Connecting to the string in a 
mirrored configuration is a prerequisite that enables you to take ground control. 
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To assume ground control for the string: 

Once you have connected to the string, take ground control by entering the TAKE 
GROUNDCONTROL directive in the command line of the Command Control window. The 
string’s three digit identifier follows the command, for example: TAKE GROUNDCONTROL 
STRING=100. 

To create a shared logical string: 

Enter the STRING CREATE directive in the Control window command line: 

STRING CREATE REALTIME SPACECRAFTID=AM1 DATABASEID=1_0 
MODE=OPERATIONAL SERVER=1. 

To submit a request for shared replay: 

On the Data Replay Controller window, select the spacecraft, database, data type, replay 
type/server [shared/real-time server 1 (RTS1), 2 (RTS2), or 3 (RTS3)] and replay rate under 
Replay String Specification. Enter the year, day, and time to start and stop the telemetry data 
replay in spacecraft time format. Click Submit Request to submit the request. The 
submission of the request for shared replay will result in the creation of a shared logical string. 
Click Cancel Request to discard the request. The buttons in the lower portion of the Data 
Replay Controller are accessible once the request has been submitted. 

To start the data replay controller: 

Open the Data Replay window by clicking Tools... at the bottom of the Control window. The 
Tools dialog box opens. Select Replay Control from the list of tools and click OK.  When the 
Data Replay Controller opens, the options in the bottom portion of the screen will be grayed out. 

To play archived telemetry data from a shared logical string: 

If you established control of the shared string through the TAKE GROUNDCONTROL directive, 
you control the playback of telemetry data associated with that string. Other users may connect to 
the string and monitor the replay of telemetry data. 

The default begin time listed in the Begin Time dialog box is the start time of your request. 
However, you can shorten the playback interval by typing a new begin time after the start time in 
the Begin Time dialog box. Click Play; the data replay begins at the time specified in the Begin 
Time entry box. 

Monitor the dynamic page as it is updated to reflect the archived telemetry data. The start and stop 
time span for the data replay is displayed in the bottom half of the Replay Controller window. As 
data plays, its time is displayed between the start and stop times and the slider bar moves from left 
to right. To move ahead or behind in the replay time span, click the slider bar and drag it to the left 
or right. 

Pause the replay by clicking Pause .  Adjust the replay rate (in kilobits per second) by clicking 
the up or down arrow next to the Replay Rate text box. Click Play to play the data at the newly 
entered replay rate. To play the data starting from the begin time, click Reset. 
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To step through archived telemetry data: 

Stepping through archived telemetry data enables you to play segments of the data span 1 to 59 
seconds long. Drag the slider bar to the starting point for the step. Select a duration for the step 
interval in seconds by clicking the up and down arrows next to the Step Interval dialog box. Click 
Step. The interval plays for the number of seconds specified in the Step Interval dialog box and 
stops. Click Step to continue playing segments of the replay interval or Play to play the data at 
the rate specified in the Replay Rate dialog box. 

To terminate the shared data replay session: 

When all users are disconnected from the shared logical string, you may terminate the shared 
replay session by clicking Kill. A dialog box opens, requesting that you verify your request to 
terminate the replay. Click OK to terminate the session or Cancel to cancel the termination 
request. The fields on the Replay Controller window return to their default settings, the start and 
stop times are blank, and the buttons in the lower portion of the window are grayed out. 

7.13.4 Connect to a Shared Replay Session 

Open the Command Control window by entering TOOL Command_Control in the ECL command 
line of the Control window, or by selecting the Command Control window from the Tools menu 
of the Control window. Enter the STRING CONNECT directive to associate your userstation 
with the logical string established for the shared replay. Your connection to the string may have 
either a mirrored or tailored connection, depending on preference. Mirrored connections inherit the 
configuration defined by the Ground Controller for the string, while tailored connections enable 
you to tailor the string’s configuration. 

To monitor telemetry via display pages: 

Monitor data played back from the database via system- or user-defined dynamic pages. 

7.14 Schematics Definition 

RTWorks is a suite of commercial software products you access via the Schematic Builder 
and Schematic Display options on the Tool Selection box to create schematic pages 
displaying telemetry mnemonics. Like a dynamic page, display items are placed on the schematic 
page and associated with parameters. For Release B, the drawings and graphs on a schematic page 
display parameters from logical string 100 only. It is not necessary to connect to string 100. The 
connection to the string is automatically accomplished by the software. This section presents a 
brief overview of a subset of the capabilities of RTWorks. For complete information on creating 
schematic pages, refer to RTDraw documentation. 

7.14.1 Compose a Schematic Page 

A schematic page contains a combination of graphs, drawings, and icons that may be customized 
to display data from parameters. To create a schematic page, the first step is to add graphs 
associated with parameters to the page. Once the page is saved, these graphs can be customized to 
display the data in a wide variety of user-defined formats. 
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1. Start the schematic display builder (see Figure 7.14.1-1). 

Click Tools... at the bottom of the Control window. The Tools dialog box opens. Select 
Schematic Display from the list of tools and click OK. 

Figure 7.14.1-1. RTWorks Window 

2.	 Create a schematic page. 

Click Compose in the upper left corner of the RTWorks window. 

The RThci Compose window opens (see Figure 7.14.1-2). 

3.	 Select a parameter. 

Select a parameter from the list on the right of the Compose window. 
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This parameter will be associated with the next graph you place on the page. 

4. Select a graph format. 

Select a graph format from the options listed under Graph type. For information about 
graph types, refer to RTDraw documentation. 

5. Add a graph to display the parameter. 

Click Create Graph and position the mouse pointer in the area of the Compose 
window where you wish to place the graph. Press the left mouse button, drag the mouse 
pointer to create a square or rectangle the size of the graph and click the left mouse button. 
Repeat steps 3, 4, and 5 to select additional parameters and to associate them with graphs. 

6. Save the schematic page. 

Position the mouse pointer inside the Save As box and click the left mouse button. Type 
a file name in the box and press <Enter>. 

7. Close the Compose window. 

Click Close. 

The Compose window closes. 
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Figure 7.14.1-2. Compose Window 

7.14.2 Customize a Schematic Page 

Once a page contains graphs associated with parameters, the page recognizes the parameters. More 
graphs and schematics can be created to display the parameters, and previously created shapes, 
icons, or drawings can be edited to display the parameters. Refer to RTDraw documentation for 
instructions on customizing graphs to display telemetry in a variety of formats. 

1. Start the schematic builder and open a page. 

Select Schematic Builder from the Tools menu of the Control window and click OK. 

The RTDraw window opens (see Figure 7.14.2-1). 
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2. Open the page previously saved from the RThci Compose window. 

Select Load View from the Cmds> menu. Select the name of the file to open and click 
OK. 

3. Add new display items and associate them with parameters. 

Refer to RTDraw documentation for instructions on adding display items and associating 
them with parameters. 

4. Customize graphs to display parameters in a variety of formats. 

To reformat graphs which are associated with parameters, refer to the RTDraw 
documentation. Data for parameters displayed on the page are listed under the Data > 
menu. 

Figure 7.14.2-1. RTDraw Window 
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7.14.3 Monitor Telemetry Mnemonics on a Schematic Page 

1. Ensure the RTWorks Data server is running. 

Enter the following directive in the command line of the Control window to start the 
RTWorks Data server: 

EA ENABLE String ID=100 

If the RTWorks Data server is already running, entering the above command will generate 
an error message but will not negatively impact the system. 

2.	 Start the schematic display. 

Select Schematic Display from the Tools menu of the Control window and click OK. 

The RTWorks window opens. 

3. Select the page to display in the Page Selection box and click Display. 

The schematic page opens (see Figure 7.14.3-1). The graphs and drawings update 
automatically to reflect incoming data from string 100. 
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Figure 7.14.3-1. Schematic Page 

7.14.4 Close RTWorks 

Click Quit on the RTWorks window. To disable the RTWorks Data server, enter the command 
EA DISABLE String ID=100 in the Control window command line. 
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