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1. Introduction 

1.1 Purpose 

This paper provides background material on Evaluation Package 4 and scripts that science users 
can use to exercise the functionality of Evaluation Package 4 across three areas: 

I. Exploration of Scientist Workbench 

II. Exploration of Advertisement Service 

III. Exploration of EOSView 

The examples are presented as a list of "actions" and "results" with some introductory material 
and occasional elaborations on particular topics or functionality 

1.2 Organization 

This paper is organized as follows:


Chapter 2: Evaluation Package background material.


Chapter 3: Scripts for exercising Evaluation Package 4.


Questions regarding technical information contained within this Paper should be addressed to the

following ECS contact: Thomas (Tom) Dopplick, ECS Science Office, (301) 925-0333,

tom@eos.hitc.com.


1.3 Review and Approval 

This Technical Paper is an informal document approved at the Office Manager level. It does not

require formal Government review or approval.


Questions concerning distribution or control of this document should be addressed to:


Data Management Office

The ECS Project Office

Hughes Applied Information Systems

1616 McCormick Dr.

Landover, MD 20785
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2. Evaluation Package Background Material 

2.1 Next Generation EOSDIS 

The next generation of EOSDIS, beyond Version 0, must provide end-to-end services across the 
broad range of EOS mission operations, from EOS instrument data collection to science data 
processing to full access to EOS and other Earth science data holdings. Next generation EOSDIS 
must accommodate high throughput and storage on a scale not seen before by NASA data centers 
in order to ingest, process, archive, and distribute the high data rates from EOS instruments. 
EOSDIS' infrastructure, the EOSDIS Core System (ECS), will give EOS and other U.S. and 
international scientists access to a broad range of services provided by the Distributed Active 
Archive Centers (DAACs) as well as other data providers who rehost and adapt reusable ECS 
components. The ECS infrastructure will also support exchange of data and research results 
within the science community, across multiple agencies, and internationally. 

2.2 Multi-Track Development 

The ECS Team is developing ECS using a multi-track development approach that includes 1) 
development of a portion of ECS on an incremental track and 2) parallel development of the 
remainder of ECS on a formal track using the traditional waterfall development methodology. 
The two primary drivers for development on the incremental track are 1) anticipated volatility of 
user-sensitive requirements, and 2) commercial-off-the-shelf (COTS) intensive integration. To 
accelerate and accommodate early user feedback, a delivery mechanism called an Evaluation 
Package (EP) was devised to put incremental developments and selected prototypes in the hands 
of distributed users for evaluation and design iteration significantly in advance of formal track 
releases. Another purpose of the Evaluation Package is early integration of COTS hardware and 
software in order to evaluate advertised capabilities of commercial vendors. 

2.3 The Evaluation Package Challenge 

The key to successful development on the incremental track is to provide structure without 
creating an administration overload that removes the freedom to react to objectives and design 
changes dictated by emerging circumstances, such as programmatic changes or technology 
evolution. To meet this challenge, we have adopted an Evaluation Package life cycle that merges 
selected practices from more traditional engineering methods with rapid prototyping 
methodology. For example, an objectives review is held with ESDIS and science community 
representatives at the beginning of each Evaluation Package to establish common understanding 
of design and evaluation goals. Other reviews with ESDIS and science community 
representatives include design, test readiness, consent to ship, and final readiness reviews. At 
each review, status and lessons learned are discussed and changes incorporated based on 
feedback by review attendees. Mockups, early prototyping, and in-process demonstrations give 
reviewers progressively better insight into the planned Evaluation Package functionality. 
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After final integration and testing, the Evaluation Package software is then distributed to the 
DAACs and other evaluator sites for a multi-week evaluation. Also, science community 
representatives are invited to participate in structured usability testing at the ECS development 
facility in Landover, MD. Usability testing is an efficient and low cost method of testing and 
quantifying ease of use. Experience to date indicates that the minimum time to produce 
meaningful content in an Evaluation Package is about six months, and that evaluation will 
require an additional two months including time for data analysis and results sharing. Details 
can be found in the Evaluation Package Strategic Plan White Paper which is readily available on 
WWW using Mosaic from the ECS Data Handling System (EDHS) home page, URL: 
http://edhs1.gsfc.nasa.gov/. The EDHS provides a catalog listing and full text search. 
Documents of interest can be retrieved in four commonly used formats from simple ASCII text 
to full-figured Postscript. 

2.4 Prior Evaluation Packages 

Evaluation Packages 1 through 3 were focused primarily on establishing a distributed testbed 
environment that interconnected ECS workstations at each DAAC and the ECS development 
facility in Landover, MD. The testbed environment is built upon an emerging communications 
technology, Open System Foundation's (OSF) Distributed Communications Environment (DCE). 
Evaluation Package 3 also introduced mockups of early concepts for the ECS Client. 

2.5 Current Evaluation Package 

Evaluation Package 4 explores new concepts for the ECS Client based on the revised architecture 
presented at the ECS System Design Review in June 1994. In particular, Evaluation Package 4 
focuses on the Scientist Workbench; search and traversal of advertisements available from the 
Advertising Service; continued development of EOSView, an ECS tool for viewing Hierarchical 
Data Format (HDF) data; and continued development of selected communications infrastructure 
components. The ECS Client now consists of a Scientist Workbench, which contains various 
tools, and desktop support for organizing user interface objects and setting interface preferences. 
Note that most of the communications infrastructure is not directly visible to end users but is, 
nevertheless, critical to developing an extensible and open core system as strongly recommended 
by the science community and the National Research Council. In addition to OSF's Distributed 
Computing Environment (DCE), HP's OPENVIEW is also being evaluated for use in the core 
communications infrastructure. 

2.6 Current Status 

A 2-month evaluation period of Evaluation Package 4 is scheduled to begin January 1995. 
Structured usability testing will be conducted at Landover with science community 
representatives. Additionally, users at the DAACs and other user sites will evaluate and provide 
feedback on Evaluation Package 4 through on-line surveys. Results of usability testing and 
evaluation feedback will be analyzed and a report published in March 1995. 
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2.7 Future 

Evaluation Package 5 will be completed in April 1995 but will focus completely on 
communications infrastructure components needed for Interim Release 1 that supports early 
interface testing with TRMM and EOS missions. On the horizon, however, is a prototype 
workshop scheduled for May, 1995 to present prototype concepts to the science community for 
user interfaces to data search and access services. The results of this prototype workshop will be 
incorporated in Evaluation Package 6 that will be completed in November, 1995. Evaluation 
Package 6 will allow users to evaluate the following services: advertising, data dictionary, data 
search and access, browse, and ECS to V0 interoperability. A second prototype workshop will 
be held in December 1995 to present prototype concepts for product access, processing requests, 
and request/results status. 
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3. Scripts for Exercising Evaluation Package 4 

3.1 Overview 

Examples to exercise the functionality of Evaluation Package 4 are presented for three areas: 

I. 	 Exploration of Scientist Workbench 
I.A Help Menu 
I.B File Menu 
I.C Tools Menu 
I.D Action Menu 

II.	 Exploration of Advertisement Service 
II.A Service Types 
II.B Data Sets and Other Products 
II.C Data Providers (Data Centers) 
II.D Search through Advertisements 

III.	 Exploration of EOSView 
III.A Tools 
III.B Simple Animation 
III.C Scripts 

The examples are presented as a list of "actions" and "results" with some introductory material 
and occasional elaborations on particular topics or functionality. 
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Table 3-1. Exploration of Scientist Workbench�

I. Exploration of Scientist Workbench 

I.A Help Menu 

I.B File Menu 

I.C Tools Menu 

I.D Action Menu 

Scientist Workbench. The Scientist Workbench is the desktop portion of the 
ECS Client and allows access to ECS applications and data. The Prototype in 
Evaluation Package 4 will refine desktop requirements for launching and 
installing ECS applications. The present prototype uses screens similar to 
those presented at the ECS System Design Review. The Evaluation Package 
4 version of the Scientist Workbench is implemented using native X and Motif. 
Alternate desktop paradigms for implementing the Scientist Workbench will be 
incorporated when they are available on more platforms. 

The ECS Scientist Workbench is the primary interface for working with ECS. 
Displayed on the Evaluation Package 4 Scientist Workbench are two 
applications: the "Adv_Service" (Advertising Service) and "EOSView" (HDF 
viewing tool). Also displayed is a “HDF_Samples” folder that contains sample 
HDF data files from each DAAC for use in evaluating EOSView. In a fully 
functioning ECS, data files would be present as the result of previous searches 
and data retrievals. Desktop pull-down menus contain other tools and aids to 
assist the user of the Scientist Workbench. An on-line survey is also available 
so users can enter their numerical evaluation and free text comments. 

I.A Help Menu 

Actions Results 

1 Login to the "ECS Workbench" "ECS Workbench" window is displayed. 

2 Select the "On EP4" option from the "Help" 
menu item 

"NCSA Mosaic: Document View" window is 
displayed containing "Document Title: EP4 
Help System" page 

3 Select " • Workbench" "Document Title: Scientist Workbench Help" 
page is displayed 

4 Select " • Launching Applications" "Document Title: Launching Applications 
Help" page is displayed 
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5 Select the "back" button Returns to "Document Title: Scientist 
Workbench Help" page 

6 Select the "back" button Returns to "Document Title: EP4 Help 
System" page 

7 Select the "Close Window" button "NCSA Mosaic: Document View" window 
closes. Returns to "ECS Workbench" window. 

I.B File Menu 

Actions Results 
8 Select the "Create Directory" option from the 

"File" menu item 
"prompt_popup" window is displayed 

9 At the blinking cursor type "TEMP" 

10 Select OK button Creates a new folder "TEMP" on "ECS 
Workbench" 

11 Single click "TEMP" folder Highlights "TEMP" folder 

12 Select "Delete Item" option from "File" menu 

13 Select "Yes" button when asked 'Do you want 
to delete TEMP?' 

Deletes "TEMP" folder from "ECS 
Workbench" window 

I.C Tools Menu 
Actions Results 

14 Select the "User Survey" option from the 
"Tools" pull-down menu 

"INTERACTIVE EVALUATION TOOL" window 
is displayed 

15 Select "Workbench" button at top of survey Questions change to those appropriate for 
Scientist Workbench evaluation 

16 Single click in the embedded window at 
bottom of survey 

Activates embedded window 

17 Type "text" in embedded window Verify acceptance of free text 
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18 Select the "Exit" button "INTERACTIVE EVALUATION TOOL" window 
closes. 

After you finish exploring EP4, return to "User 
Survey" and enter your numerical evaluation 
and comments. 

19 Select the "EDHS" option from the "Tools" 
pull-down menu 

" NCSA Mosaic: Document View" window is 
displayed containing "Document Title: EDHS 
Home Page" 

20 Select the "Close Window" button Returns to "ECS Workbench" window 

21 Select the "RRDB" option from the "Tools" 
pull-down menu 

" NCSA Mosaic: Document View" window is 
displayed containing "RRDB Home Page" 

22 Select the "Close Window" button Returns to "ECS Workbench" window 

I.D Action Menu 
Actions Results 

23 Single click on the "Adv_Service" icon Highlights "Adv_Service" icon 

24 Select "Execute" option in "Action" menu "advertise" window is displayed; action 
launches "ECS Advertising Client" 

25 Select the "Exit" option from the "File" pull -
down menu 

Returns to "ECS Workbench" 

26 Single click on the "HDF_Samples" folder Highlights "HDF_Samples" folder 

27 Select "OpenNewWindow" option from the 
"Action" menu items 

Opens "HDF_Samples" folder and presents 
contents in new "ECS Workbench" window 

28 Select "Close" from the "File" pull-down menu 
on new "ECS Workbench" window 

Closes new "ECS Workbench" window 
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Table 3-2. Exploration of Advertisement Service. 

II. Exploration of Advertisement Service 
II.A Service Types 
II.B Data Sets and Other Products 
II.C Data Providers (Data Centers) 
II.D Search through Advertisements 

Advertising Service. The Advertising Service provides the interfaces needed to 
support the Client browsing and searching of data and service advertisements. 
The directory function is subsumed by the advertising service. The Prototype 
in Evaluation Package 4 will flush out search/traversal requirements and 
interface requirements with the Trader Service (see below). Also, the prototype 
will be used to determine the level of information that is needed to build useful 
service advertisements. 

The Advertising Service is built using a modified MOSAIC interface and should 
be familiar to those who have used MOSAIC or Netscape. Users can "surf" 
through advertisements for services, data sets, and data providers (examples 
II.A, II.B, and II.C) or users can submit queries (example II.D) to find services of 
interest. Example II.A shows a user finding a hypothetical "AVHRR 1 KM 
Browse" service. When located, the description of the AVHRR 1KM Browse 
service and reference icon are presented to the requester. The browse service 
can be immediately invoked by double clicking on the reference icon or the 
user can install the reference icon, using drag-and-drop, onto the Scientist 
Workbench for launching at the user's convenience. A future Evaluation 
Package will provide the actual browse services. Query forms (shown in 
example II.D) are also available for finding services of interest. 

Trader Service.  The Trader Service, although not directly visible to the user, 
plays an important role by accepting general service queries from the 
advertising service and returning objects that match the characteristics of the 
queries. This service also matches EOSDIS user requests to ECS servers. 
The prototype for Evaluation Package 4 is a static trader developed using HP's 
Object Oriented Distributed Computing Environment to allow object passing 
over the Distributed Communications Environment. 

II.A Service Types 
Actions Results 

29 Double click the "Adv_Service" icon "advertise" window is displayed 
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30 Scroll down to find: 
• Service Types 
• Data Sets and Other Products 
• Data Providers (Data Centers) 
• Search through Advertisements 

31 Select "• Service Types" Opens "Services Types Listing" page 

32 Select "Browse" under ECS Services Opens "ECS Browse Services Listing" 

33 Select "AVHRR 1 KM Browse" Advertising Service locates and displays 
"AVHRR 1 KM Browse Description" page 
containing the reference icon (bottom of page) 

34 Double click on the AVHRR 1 KM Browse 
reference icon (bottom of page) 

In EP6 double clicking a browse reference 
icon will invoke an actual Browse Service. In 
EP4, double clicking the browse reference 
icon opens the "topLevelShell" window that 
describes the future browse service. 

35 Select "Close" button Returns to "AVHRR 1KM Browse Description" 
page 

36 Adjust the locations, if necessary, of the "ECS 
Workbench" and "advertise" windows so the 
browse reference icon in the "advertise" 
window can be dragged-and-dropped onto the 
"ECS Workbench" window. 

37 Using the MIDDLE mouse button, drag-and -
drop the browse reference icon onto the "ECS 
Workbench" window 

Installs AVHRR 1KM Browse reference icon 
on "ECS Workbench." AVHRR 1 KM Browse 
Service can then be launched at user's 
convenience. The reference icon remains 
installed in the Workbench at logoff and is 
available during future login sessions. 

38 Double click the AVHRR 1 KM Browse 
reference icon on the "ECS Workbench" 

In EP6 double clicking a browse reference 
icon will invoke an actual Browse Service. In 
EP4, double clicking the browse reference 
icon opens the "topLevelShell" window that 
describes the future browse service. 

39 Select "Close" button Returns to "ECS Workbench" window 

40 Single click somewhere on "AVHRR 1 KM 
Browse Description" page 

Activates "AVHRR 1 KM Browse Description" 
page 
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41 Select "Home" button Returns to "ECS ADVERTISING SERVICE" 
page on "advertise" window 

II.B Data Sets and Other 
Products 

Actions Results 
42 Scroll down and select "• Data Sets and Other 

Products" 
Opens "Data Listing" page 

43 Select "• All Data" Opens "All Data Set Listing" page 

44 Select "• EDC/NOAA Held AVHRR Data" Advertising Service, interacting with Trading 
Service, locates and displays "EDC/NOAA 
Held AVHRR Data Description and Services" 
page containing a reference icon for each 
available service. 

Note that the AVHRR 1 KM Browse reference 
icon is the same as the reference icon 
previously installed on the ECS Workbench. 

Again, one or all of the reference icons could 
be installed onto the ECS Workbench by 
drag-and-drop. 

45 Single click somewhere on "ECS Workbench" 
window 

Activates "ECS Workbench" window 

46 Single click on "AVHRR 1 KM Browse" icon Highlights "AVHRR 1 KM Browse" icon 

47 Select "Delete Item" from "File" pull-down 
menu 

48 Select "Yes" button when asked 'Do you want 
to delete AVHRR 1 KM Browse?' 

Deletes icon from "ECS Workbench" 

49 Single click somewhere on "advertise" window 
that contains "EDC/NOAA Held AVHRR Data 
Description" page 

Activates "EDC/NOAA Held AVHRR Data 
Description" page 

50 Select "Home" button Returns to "ECS ADVERTISING SERVICE" 
page 
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II.C Data Providers (Data 
Centers) 

Actions Results 
51 Scroll down and select "• Data Providers 

(Data Centers) 
Opens "Provider Listing" page. 

52 Select "• Earth Resources Observation 
System, USGS (EDC)" 

Opens "Earth Resources Observation 
System, USGS (EDC)" page. 

53 Select "Here" Opens "Detail Description Document" page. 
In future, this document would describe actual 
services and data sets available from the 
provider 

54 Select "Home" button Returns to "ECS ADVERTISING SERVICE" 
page 

II.D Search through 
Advertisements 

Actions Results 
55 Scroll down and select "• Search through 

Advertisements" 
Opens "Searching for Advertisements" page 

56 Select "• Services Related to Earth Science 
Data" 

Opens "Earth Science Service Search 
Options" page 

57 Select "• Search Services form" Opens "Search Services Form" page 

58 Scroll down to embedded window titled 
"Sensor?" 

59 Select AVHRR Creates query for services associated with 
sensor AVHRR 

60 Scroll down and select "Submit" button Submits query to Trader Service. Returns 
"Search Services" page with description of 
available search services for sensor AVHRR 
and reference icons. 

Again, reference icons could be installed onto 
the ECS Workbench by drag-and-drop. 

61 Select "Exit" from File pull-down menu Returns to "ECS Workbench" window 
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Table 3-3. Exploration of EOSView. 

III. Exploration of EOSView 
III.A Tools 
III.B Simple Animation 
III.C Scripts 

EOSView. This HDF viewing tool will make it easy for anyone, even non-EOS 
users, to read and understand HDF-EOS data files. Currently, EOSView 
provides the following capabilities: 

1. Displays HDF File Structures 
2. Displays raster images and 2D arrays as pseudocolor 
3. Provides image pan and zoom capability 
4. Displays a color palette for selection of alternate palette 
5. Provides the capability to overlay bitmap images 
6. Provides simple animations 
7. Provides a preliminary scripting language 

EOSView will be widely available, both in terms of physical locations and in 
terms of supported platforms. Visualization in EOSView will be for the purpose 
of data verification only. Analysis and presentation of data is best left to 
commercial applications. A DAAC sampler is available in Evaluation Package 
4 with sample HDF files from each DAAC so that users can examine and, 
where appropriate, visualize samples of current DAAC products. 

There are several ways to activate EOSView: a) double clicking the EOSView 
icon, b) drag-and-drop of a HDF data file onto the EOSView icon, or c) double 
clicking a HDF data file. Each method will result in a display that lets a user 
view the internal structure of the data file. Those sections of the HDF data file 
delineated by a “+” sign contain further levels of information or image data. 
Double clicking a "+Raster Image Group" will activate the image display 
capability of EOSView. Another option for activating EOSView is to use a 
script to perform a series of operations such as opening EOSView, displaying 
the internal structure of the data file, and preparing images for animation. This 
last option is exercised in III.C. 

III.A Tools 
Actions Results 

62 Double click "EOSView" icon on "ECS 
Workbench" window 

Opens "EOSView" window 
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63 Select "Open" option from "File" pull-down 
menu 

Opens "Filter" window for selecting HDF 
images 

64 Select ".../images/ASF" under "Directories" Highlights ".../images/ASF" 

65 Select "Filter" button Displays new directory for ".../images/ASF" 

66 Select ".../ASF/SEAICE" Highlights ".../ASF/SEAICE" 

67 Select "Filter" button Displays "Files" within ".../ASF/SEAICE". 
Note that the directory ".../ASF/SEAICE" 
contains both TXT and HDF files. EOSView 
opens only the HDF files. 

68 Select "...5496010A.HDF" Highlights "...5496010A.HDF" 

69 Select "OK" button Opens "Document Title - EOSView: 
5496010A.HDF" window and shows the 
content of the HDF file 

70 Double click "+ Raster Image Group (306/1)" Opens "Document Title - 5496010A.HDF" 
window with display of image 

71 Single click "Zoom +" button Zoom in 

72 Place cursor in miniature image on left side of 
window. Hold down LEFT mouse button and 
slowly move around miniature image 

Pan around image 

73 Select "Palette" pull-down menu Displays "Select" and "Use entire palette" 
options on pull-down menu 

74 Choose "Select" option on the pull-down 
menu 

Displays additional options: "Default, 
Greyscale, Antarctica, Rainbow, and World 
Colors" 

75 Select "Greyscale" and other options Changes color presentation of image 

76 Reset option to "Default" Returns to original color presentation 
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77 Select "Use entire palette" option on pull-down 
menu 

Changes X-Y grid to red 

Note: choosing "Use entire palette" for some 
HDF files can result in loss of all background 
color. 

78 Select "Overlay" option on "File" pull-down 
menu 

Opens "Filter" window. EP4 has no overlay 
files. In the future, user would use this 
window to select and apply overlay to image. 

79 Select "Cancel" button Returns to "Document Title - 5496010A.HDF" 
window 

80 Select "Close" option on "File" pull-down 
menu 

Returns to Document Title - EOSView: 
5496010A.HDF" window 

81 Select "Exit Alt+X" option in "File" pull-down 
menu 

Returns to "ECS Workbench" window 

III.B Simple Animation 
Actions Results 

82 Single click on the "HDF_Samples" folder Highlights "HDF_Samples" folder 

83 Select "OpenNewWindow" option from the 
"Action" menu items 

Opens "HDF_Samples" folder and presents 
contents in new "ECS Workbench" window 

84 Double click "image_demo.hdf" icon Displays "Document Title -
EOSView:b_srb_monavgs_8706.hdf" window 

85 Select "Animate images" option from 
"Options" pull-down menu 

Displays "Document Title �
b_srb_monavgs_8706.hdf" window and loads 
all images in HDF file 

NOTE THAT THIS ANIMATION SEQUENCE 
CYCLES THROUGH 19 DIFFERENT 
PARAMETERS FOR THE SAME MONTH. 
EOSVIEW ANIMATES THE HDF FILE AS 
PREPARED BY THE DATA PROVIDER. 
LATER IN III.B WE WILL EXAMINE 
ANOTHER ANIMATION SEQUENCE WHICH 
CYCLES THROUGH THE SAME SSMI 
PARAMETER OVER 9 TIME STEPS. 

86 Select "Stop at end" from the "Mode" option 
from the "Options" menu item 

“Stop at end” mode plays in either forward or 
backward direction and then stops 
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87 Select the ">>" (play forward) animation 
button 

Animation starts in the forward mode; 
animation stops at the last frame 

88 Select the "<<" (play backwards) animation 
button 

Animation starts in backward mode; animation 
stops at first frame 

89 Select the " ||" (stop) animation button Animation stops 

90 Select the " >|" (frame forward) animation 
button 

Animation moves one frame forward 

91 Select the " |<" (frame backward) animation 
button 

Animation moves one frame backward 

92 Select "Continuous run" from the "Mode" 
option from the "Options" pull-down menu 

“Continuos run” mode plays in either forward 
or backward direction continuously 

93 Select the ">>" (play forward) animation 
button 

Animation starts in the forward mode; 
animation does not stop at the last frame but 
continues to the first frame and keeps cycling. 

94 Move the speed slider right to increase the 
speed of the animation 

Animation increases in speed 

95 Move the speed slider left to decrease the 
speed of the animation 

Animation decreases in speed 

96 Select the " ||" (stop) animation button Animation stops 

97 Select "Bounce" from the "Mode" option from 
the "Options" pull-down menu 

“Bounce” mode plays in one direction and 
then reverses, bouncing between directions 

98 Select the ">>" (play forward) animation 
button 

Animation starts in the forward mode; 
animation plays in the forward mode until the 
last frame and then plays in the backward 
mode until the first frame and continues this 
cycle. 

99 Select the "||" (stop) animation button Animation stops 
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100 Select "Close" option from "File" pull-down 
menu 

Returns to "Document Title - EOSView: 
b_srb_monavgs_8706.hdf" window 

101 Select "Exit Alt+X" from "File" pull-down menu Returns to second "ECS Workbench" showing 
the contents of "HDF_Samples" folder 

This concludes the animation example of 19 
parameters for the same month 

THIS ANIMATION SEQUENCE SHOWS THE 
SAME SSMI PARAMETER AS IT VARIES 
OVER 9 TIME STEPS. 

102 Double click "MSFC" folder Displays contents of "MSFC" folder 

103 Double click "SSMI_movie.hdf" icon Opens "Document Title - EOSView: 
SSMI_movie.hdf" window 

104 Select "Animate images" option from 
"Options" pull-down menu 

Opens "Document Title - SSMI_movie.hdf" 
window. Loads images to be animated. 

105 Select "Continuous run" option from "Mode" 
option from "Options" pull-down menu 

“Continuos run” mode plays in either forward 
or backward direction continuously 

106 Select ">>" (play forward) animation button Animation starts in forward direction 

107 Select "||" (stop) animation button Animation stops 

108 Select "Close" option from "File" pull-down 
menu 

Returns to "Document Title - EOSView: 
SSMI_movie.hdf" window 

109 Select "Exit Alt+X" from "File" pull-down menu Returns to window displaying contents of 
"MSFC" folder 

110 Double click on upper left icon showing open 
folder 

Returns to second "ECS Workbench" window 
displaying contents of "HDF_Samples" folder 
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III.C Scripts 

Actions Results 
111 Double click "anim_demo.hdf" icon Double clicking icon activates a script that: 

1) Opens "Document Title - EOSView: 
TOVS_MONTHLY_PM_8810.HDF_BROWSE 
" window that displays HDF content 
2) Activates "Animate Images" option from 
"Options" pull-down menu 
3) Opens "Document Title -
TOVS_MONTHLY_PM_8810.HDF_BROWSE 
" window 
4) Animates images using "Stop at end" from 
the "Mode" option from the "Options" pull -
down menu 

112 Select "Bounce" from the "Mode" option from 
the "Options" pull-down menu 

“Bounce” mode plays in one direction and 
then reverses, bouncing between directions 

113 Select the ">>" (play forward) animation 
button. 

Animation starts in the forward mode; 
animation plays in the forward mode until the 
last frame and then plays in the backward 
mode until the first frame and continues this 
cycle. 

114 Select the "||" (stop) animation button Animation stops 

115 Select "Close" option from "File" pull-down 
menu 

Returns to "Document Title - EOSView: 
TOVS_MONTHLY_PM_8810.HDF_BROWSE 
" window 

116 Select "Exit Alt+X" from "File" pull-down menu Returns to second "ECS Workbench" window 
showing the contents of "HDF_Samples" 
folder 

117 Select "Close" option from "File" pull-down 
menu 

Closes second "ECS Workbench" window 

118 Select the "User Survey" option from the 
"Tools" pull-down menu 

"INTERACTIVE EVALUATION TOOL" window 
is displayed 
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119 Complete numerical evaluation and enter any 
comments 

120 Select the “Save” button after completing the 
“User Survey” 

Saves answers and comments 

121 Select the "Exit" button "INTERACTIVE EVALUATION TOOL" window 
closes. 

122 Select "Exit" option from the "File" pull-down 
menu 

123 Select "Exit" button when asked 'Exit ECS 
Workbench?' 

Logoff EP4 
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